Hallo, Gast! (Registrieren)

Letzte Ankündigung: MyBB 1.8.8 veröffentlicht (17.10.16)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
Coppermine in eigener Seite
#1
Hallo zusammmen,

ich habe ein "kleines" Problem mit der Coppermine Galerie:

und zwar habe ich nun für die Galerie einen eigene Seite erstellt. Diese wird nun über ein iFrame innerhalb des Forums aufgrufen.
Das funktioniert für Registrierte auch super, wer allerdings nicht angemeldet ist sieht die Anmeldeseite des Forums. Wenn ein Gast nun aber die Galerie aufruft lässt sich die Seite bis zum Sanktnimmerleinstag immer wieder per iFrame aufrufen.

Wer weiß eine einfache Lösung dafür? Evtl. die Anmeldeseite umgehen? Lässt sich eine Abfrage ins Template der Galerie einbauen?

Gruß,
Dirk

edit: den Gästen in der Galerie den Zugriff erlauben geht schonmal nicht. Bei Aufruf der Galerie kommt dann folgende Fehlermeldung:

Code:
Template error
Failed to find block 'logout'(#(<!-- BEGIN logout -->)(.*?)(<!-- END logout -->)#s) in :
            <!-- BEGIN my_gallery -->
        <a href="{MY_GAL_TGT}" title="{MY_GAL_TITLE}">{MY_GAL_LNK}</a> <img src="themes/water_drop/images/orange_carret.gif" width="8" height="8" border="0" alt="" />
  <!-- END my_gallery -->  <!-- BEGIN allow_memberlist -->
        <a href="{MEMBERLIST_TGT}" title="{MEMBERLIST_TITLE}">{MEMBERLIST_LNK}</a> <img src="themes/water_drop/images/orange_carret.gif" width="8" height="8" border="0" alt="" />
  <!-- END allow_memberlist -->  <!-- BEGIN my_profile -->
        <a href="{MY_PROF_TGT}" title="{MY_PROF_TITLE}">{MY_PROF_LNK}</a> <img src="themes/water_drop/images/orange_carret.gif" width="8" height="8" border="0" alt="" />
  <!-- END my_profile -->  <!-- BEGIN enter_admin_mode -->
        <a href="{ADM_MODE_TGT}" title="{ADM_MODE_TITLE}">{ADM_MODE_LNK}</a> <img src="themes/water_drop/images/orange_carret.gif" width="8" height="8" border="0" alt="" />
  <!-- END enter_admin_mode -->  <!-- BEGIN leave_admin_mode -->
        <a href="{USR_MODE_TGT}" title="{USR_MODE_TITLE}">{USR_MODE_LNK}</a> <img src="themes/water_drop/images/orange_carret.gif" width="8" height="8" border="0" alt="" />
  <!-- END leave_admin_mode -->  <!-- BEGIN upload_pic -->
        <a href="{UPL_PIC_TGT}" title="{UPL_PIC_TITLE}">{UPL_PIC_LNK}</a> <img src="themes/water_drop/images/orange_carret.gif" width="8" height="8" border="0" alt="" />
  <!-- END upload_pic -->  <!-- BEGIN register -->
        <a href="{REGISTER_TGT}" title="{REGISTER_TITLE}">{REGISTER_LNK}</a> <img src="themes/water_drop/images/orange_carret.gif" width="8" height="8" border="0" alt="" />
  <!-- END register -->  <!-- BEGIN faq -->
        <a href="{FAQ_TGT}" title="{FAQ_TITLE}">{FAQ_LNK}</a> <img src="themes/water_drop/images/orange_carret.gif" width="8" height="8" border="0" alt="" />
  <!-- END faq -->  <!-- BEGIN login -->
        <a href="{LOGIN_TGT}" title="{LOGIN_TITLE}">{LOGIN_LNK}</a>
  <!-- END login -->
Gruß,
NixxusMinimax
Zitieren
#2
Füge in der PHP-Datei deiner Seite nach dem Einbinden der global.php folgenden Code ein:
PHP-Code:
if($mybb->user['uid'] == "0") {
    
error_no_permission();


Gruß,
Michael
[Bild: banner.png]
Support erfolgt NUR im Forum!
Bitte gelöste Themen als "erledigt" markieren.
Beiträge mit mangelhafter Rechtschreibung/Grammatik werden kommentarlos gelöscht.
Zitieren
#3
Ich danke dir,

werds nachher testen, bzw. umsetzen.

Gruß,
Dirk
Wie erwartet erledigt.

Besten Dank!
Gruß,
NixxusMinimax
Zitieren


Möglicherweise verwandte Themen...
Thema Verfasser Antworten Ansichten Letzter Beitrag
  Neueste Themen auf eigener Seite - Status ungelesen abfragen Zwoetzen 13 1.676 16.11.2016, 17:02
Letzter Beitrag: Amaryllion
  Titel bei eigener Seite fehlt Rev0 17 2.214 13.03.2011, 15:56
Letzter Beitrag: Rev0
  Wer ist online auf "eigener Seite" Jockl 12 2.227 29.12.2008, 13:39
Letzter Beitrag: Jockl