Hallo, Gast! (Registrieren)

Letzte Ankündigung: MyBB 1.8.8 veröffentlicht (17.10.16)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
Upgrade von 1.2.13 auf 1.4.4 - Fatal Error
#1
Hallo,

ich habe heute morgen versucht ein Upgrade von 1.2.13 auf 1.4.4 durchzuführen.

Ich bin Heizungsbauer und betreue das Forum nur nebenbei, Daher sind meine EDV Kenntnisse begrenz und meine Programmierkenntnisse eher mangelhaft. Das nur vorneweg damit ihr wisse es sitzt kein Profi am anderen Ende der Leitung.

Ich habe versucht alle Schritte so auszuführen wie in der Beschreibung Upgrade vorgegeben.

Beim Starten des Upgrades erscheint folgende Fehlermeldung.

Warning: main(/mnt/web3/12/61/5362061/htdocs/Forum/inc/config.php) [function.main]: failed to open stream: No such file or directory in /mnt/web3/12/61/5362061/htdocs/Forum/install/upgrade.php on line 22

Fatal error: main() [function.require]: Failed opening required '/mnt/web3/12/61/5362061/htdocs/Forum/inc/config.php' (include_path='.:/opt/RZphp4/includes') in /mnt/web3/12/61/5362061/htdocs/Forum/install/upgrade.php on line 22


Kann mir jemand sagen was ich ev. falsch gemacht habe, oder was ich jetzt tun kann.

Gruß Alfons
#2
Laut Fehlermeldung fehlt die Datei inc/config.php. Hast du diese von der Vorversion wieder hochgeladen (wie in der Upgradeanleitung beschrieben)?

Gruß,
Michael
[Bild: banner.png]
Support erfolgt NUR im Forum!
Bitte gelöste Themen als "erledigt" markieren.
Beiträge mit mangelhafter Rechtschreibung/Grammatik werden kommentarlos gelöscht.
#3
Jepp hatte ich anscheinend vergessen.

Habe das grade nachgeholt und bekomme nun folgende Meldung.

Warning: main(/mnt/web3/12/61/5362061/htdocs/Forum/inc/class_timers.php) [function.main]: failed to open stream: No such file or directory in /mnt/web3/12/61/5362061/htdocs/Forum/install/upgrade.php on line 41

Fatal error: main() [function.require]: Failed opening required '/mnt/web3/12/61/5362061/htdocs/Forum/inc/class_timers.php' (include_path='.:/opt/RZphp4/includes') in /mnt/web3/12/61/5362061/htdocs/Forum/install/upgrade.php on line 41
#4
Gleiche Ursache, aber andere Datei: Die Datei inc/class_timers.php fehlt. Lade am besten nochmal das Komplettpaket von der Downloadseite herunter und lade alle Dateien und Ordner (außer den Ordner "install") neu hoch.

Gruß,
Michael
[Bild: banner.png]
Support erfolgt NUR im Forum!
Bitte gelöste Themen als "erledigt" markieren.
Beiträge mit mangelhafter Rechtschreibung/Grammatik werden kommentarlos gelöscht.
#5
Das war Hilfreich Danke schon mal.

Es fehlten noch mehrere Dateien, die habe ich jetzt rein kopiert.

Jetzt kommt ein neue Fehlermeldung.


Fatal error: [SQL] [1146] Table 'DB417041.mybb_mybb_users' doesn't exist
UPDATE mybb_mybb_users SET `newpms`='0' WHERE uid='2' in /mnt/web3/12/61/5362061/htdocs/Forum/inc/db_mysql.php on line 548
#6
Irgendein Plugin ist nicht kompatibel.
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
#7
Danke für den Hinweis

Habe ich als EDV-Laie (um nicht zu sagen DAU) eine Chance irgendwie heraus zu finden wer da mit wem nicht kompatibel ist. Und vor allem habe ich dann eine Chance das irgendwie zu korrigieren?

Das Wort Plugin habe ich schon mal irgendwo gehört oder gelsen, kann aber ehrlich gesagt damit nicht wirklich viel damit anfangen.

Gruß Alfons
#8
Wenn du keine Plugins installiert hast, liegt es wohl an einer veralteten Datei.
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
#9
Ich weiß nicht wie und warum, aber ich bin jetzt anscheinend einen Schrit weiter gekommen, ich habe einfach noch ein paar mal angeklickt und irgendwann lief er einfach weiter.

Jetzt habe ich zumindest schon mal ein blaues Fenster


MyBB Installation Wizard
Upgrade Process
Welcome
Fatal error: Call to undefined method: mylanguage->sprintf() in /mnt/web3/12/61/5362061/htdocs/Forum/install/upgrade.php on line 295


Gruß Alfons
#10
Das sieht wieder nach einer veralteten Datei aus? Hast du wirklich alle neuen Dateien hochgeladen?
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.


Möglicherweise verwandte Themen...
Thema Verfasser Antworten Ansichten Letzter Beitrag
  erster aufruf ---> fatal error wienix 4 1.165 18.11.2008, 13:32
Letzter Beitrag: wienix
  Error - don't have persmission (Upgrade auf 1.4) MH_Razen 14 2.612 08.08.2008, 13:17
Letzter Beitrag: MH_Razen