Hallo, Gast! (Registrieren)

Letzte Ankündigung: MyBB 1.8.8 veröffentlicht (17.10.16)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
Geschlecht anzeigen bei Beitrag
#31
Ja, das sollte möglich sein.

Gruß,
Michael
[Bild: banner.png]
Support erfolgt NUR im Forum!
Bitte gelöste Themen als "erledigt" markieren.
Beiträge mit mangelhafter Rechtschreibung/Grammatik werden kommentarlos gelöscht.
Zitieren
#32
Hab ich probiert:

So sieht das Ergebniss aus: http://www.animewebforum.de/webforum.for...660#pid660

Ich sehe jedoch kein Bild neber dem Nick bzw. vor dem Nick.
Was mach ich Falsch? o.O
Zitieren
#33
Aus deinem Quelltext:
Code:
<img src="images/.gif />
Du solltest überprüfen ob du den Code richtig in die PHP-Datei eingefügt hast, da die Variable im Template leer ist.

Gruß,
Michael
[Bild: banner.png]
Support erfolgt NUR im Forum!
Bitte gelöste Themen als "erledigt" markieren.
Beiträge mit mangelhafter Rechtschreibung/Grammatik werden kommentarlos gelöscht.
Zitieren
#34
Hier der Auszug aus dem Template postbit_author_user:

Code:
<strong><img src="images/{$geschlecht}.gif /><span class="largetext">{$post['profilelink']}</span></strong><br />
<span class="smalltext">
    {$post['usertitle']}<br />
    {$post['userstars']}
    {$post['groupimage']}<br />
    {$post['useravatar']}<br /><div style="text-align: left;">
    <img src="http://www.Animewebforum.de/webforum.forum/images/image.pfeil.gif">{$lang->postbit_joined} <b>{$post['userregdate']}</b><br /><img src="http://www.Animewebforum.de/webforum.forum/images/image.pfeil.gif">Alter: <b>{$age}</b><br/>
    <img src="http://www.Animewebforum.de/webforum.forum/images/image.pfeil.gif">{$lang->postbit_status} {$post['onlinestatus']}<br/>
    <img src="http://www.Animewebforum.de/webforum.forum/images/image.pfeil.gif">{$lang->postbit_posts}<b> {$post['postnum']}</b><br/><img src="http://www.Animewebforum.de/webforum.forum/images/image.pfeil.gif">{$post['replink']}
</span></div>

Und in der Datei steht der Code auch drinne, der weiter oben geschrieben wurde.
Zitieren
#35
Du hast den Code aus Beitrag #5 genommen?

1.) Ist das Geschlecht bei dir im Profilfeld mit der ID 3 gespeichert? Falls nicht, bitte Code anpassen.
2.) In deinem Profil steht bei Geschlecht "Männlich" mit großem M, im Code wird auf "männlich" mit kleinem M geprüft. Bitte Groß-/Kleinschreibung im Code anpassen.

Gruß,
Michael
[Bild: banner.png]
Support erfolgt NUR im Forum!
Bitte gelöste Themen als "erledigt" markieren.
Beiträge mit mangelhafter Rechtschreibung/Grammatik werden kommentarlos gelöscht.
Zitieren
#36
Ich hab beides geändert, siehe angehängte Datei - jedoch bekomm ich immernoch nichts angezeigt.
Wie das Template aussieht, steht ja über deinem Beitrag.

Was ist also nun noch Falsch? Sad
Zitieren
#37
Ab MyBB Version 1.2 ist der Code scheinbar nicht mehr so nutzbar.
Diese variante sollte ab Version 1.2 funktionieren:

Öffne ./inc/functions_post.php
Suche:
PHP-Code:
eval("\$post['user_details'] = \"".$templates->get("postbit_author_user")."\";"); 
Füge darüber ein:
PHP-Code:
        // ['fidX'] durch euer fid-Feld ersetzen!
        
if($post['fidX'] == "Männlich")
        {
        
$geschlecht "mann";
        }
        elseif(
$post['fidX'] == "Weiblich")
        {
        
$geschlecht "frau";
        } 
Das zu verändernde Tempalte ist nun postbit_author_user. (ungetestet, sollte allerdings seine Richtigkeit haben) Smile

@3r4g0n: Ich habe dir deine functions_post.php schon so gemodded, wie hier beschrieben und natürlich auch gleich an meinen Post angehängt.

Mfg Garlant


Angehängte Dateien
.php   functions_post.php (Größe: 17,83 KB / Downloads: 18)
Ich gebe keinen Support per Messenger oder PN!
Zitieren
#38
Garlant schrieb:Das zu verändernde Tempalte ist nun postbit_author_user. (ungetestet, sollte allerdings seine Richtigkeit haben) Smile

Bei mir ist diese angepasst, siehe:

Code:
<strong><img src="images/{$geschlecht}.gif /><span class="largetext">{$post['profilelink']}</span></strong><br />
<span class="smalltext">
{$post['usertitle']}<br />
{$post['userstars']}
{$post['groupimage']}<br />
{$post['useravatar']}<br /><div style="text-align: left;">
<img src="http://www.Animewebforum.de/webforum.forum/images/image.pfeil.gif">{$lang->postbit_joined} <b>{$post['userregdate']}</b><br /><img src="http://www.Animewebforum.de/webforum.forum/images/image.pfeil.gif">Alter: <b>{$age}</b><br/>
<img src="http://www.Animewebforum.de/webforum.forum/images/image.pfeil.gif">{$lang->postbit_status} {$post['onlinestatus']}<br/>
<img src="http://www.Animewebforum.de/webforum.forum/images/image.pfeil.gif">{$lang->postbit_posts}<b> {$post['postnum']}</b><br/><img src="http://www.Animewebforum.de/webforum.forum/images/image.pfeil.gif">{$post['replink']}
</span></div>

Jeoch zeigt er mir nichts an! o.O
Zitieren
#39
Die Variable wird nicht übergeben.

Desweiteren ist noch ein Fehler in dem Template
hier der richtige:

PHP-Code:
<strong><img src="images/{$geschlecht}.gif" /><span class="largetext">{$post['profilelink']}</span></strong><br />
<
span class="smalltext">
{
$post['usertitle']}<br />
{
$post['userstars']}
{
$post['groupimage']}<br />
{
$post['useravatar']}<br /><div style="text-align: left;">
<
img src="http://www.Animewebforum.de/webforum.forum/images/image.pfeil.gif">{$lang->postbit_joined} <b>{$post['userregdate']}</b><br /><img src="http://www.Animewebforum.de/webforum.forum/images/image.pfeil.gif">Alter: <b>{$age}</b><br/>
<
img src="http://www.Animewebforum.de/webforum.forum/images/image.pfeil.gif">{$lang->postbit_status} {$post['onlinestatus']}<br/>
<
img src="http://www.Animewebforum.de/webforum.forum/images/image.pfeil.gif">{$lang->postbit_posts}<b> {$post['postnum']}</b><br/><img src="http://www.Animewebforum.de/webforum.forum/images/image.pfeil.gif">{$post['replink']}
</
span></div
Wut ist das Geheimnis, das Geheimnis meiner Kraft, und wenn Ihr anfangt mich zu mögen, weiß ich, ich hab was falsch gemacht!
Böhse Onkelz - Das Geheimnis meiner Kraft :]
Zitieren
#40
Danke, Samu ... trotzdem sehe ich kein Bild vor dem Nick, der sagt, ob man Männlich oder Weiblich ist...

Solangsam verzeifel ich noch dran, woran es liegen könnte!
Weiß sonst noch jemand Rat?
Zitieren


Möglicherweise verwandte Themen...
Thema Verfasser Antworten Ansichten Letzter Beitrag
  Geschlecht in Mitgliederliste Tifflor 18 3.491 10.10.2008, 16:21
Letzter Beitrag: linwinman
Question Profil von Geschlecht abhängig modercol 23 2.773 21.02.2007, 00:02
Letzter Beitrag: modercol
  Profil-Feld Geschlecht mit Bild arabiczone 1 802 19.01.2007, 23:32
Letzter Beitrag: Michael