Hallo, Gast! (Registrieren)

Letzte Ankündigung: MyBB 1.8.8 veröffentlicht (17.10.16)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
Icons / Bilder vor den Foren auf der Startseite
#1
Hallo zusammen! Smile

Ich würde gerne vor den einzelnen Foren auf der Startseite individuelle Bildchen haben.
Wenn ich allerdings mit html Bilderzum Forennamen einbinde erscheinen diese auch wenn man das Forum betritt oben immer neben dem Namen des Forums, das ist doch irgendwie sehr störend...
Hat jemand eine Idee/ Lösung wie ich das sinnvoller machen könnte?

Grüße,
Maja
Zitieren
#2
Kann niemand helfen?

Ich dachte, dass es dafür sicher schon eine Lösung gibt weil ich sowas in anderen Foren (zwar nicht MyBB) schon sehr häufig gesehen hab...
Zitieren
#3
Hallo Maja,

nimm hierfür folgende Änderungen vor:

öffne (mit einem geeigneten Editor) die Datei ".../inc/functions_forumlist.php" und suche die Zeilen (~ 243)
PHP-Code:
                $posts my_number_format($forum['posts']);
                
$threads my_number_format($forum['threads']); 
Füge hierunter ein
PHP-Code:
                // Start:    => Variable fuer 'Forum-Image'
                
$forum_img "forum_img_".$forum['fid'];
                
// Ende:    => Variable fuer 'Forum-Image' 

Ersetze in "Admin-CP > Templates > dein Template-Set > Forum Bit Templates > forumbit_depth2_forum" die Zeilen
Code:
<td class="{$bgcolor}" valign="top">
<strong><a href="{$forum_url}">{$forum['name']}</a></strong>{$forum_viewers_text}<div class="smalltext">{$forum['description']}{$modlist}{$subforums}</div>
</td>
durch
Code:
<td class="{$bgcolor}" valign="top">
<img src="{$theme['imgdir']}/{$forum_img}.gif" border="0" alt="{$forum['name']}" title="{$forum['name']}" style="vertical-align: middle;" />
<strong><a href="{$forum_url}">{$forum['name']}</a></strong>{$forum_viewers_text}<div class="smalltext">{$forum['description']}{$modlist}{$subforums}</div>
</td>

Die Grafiken benennst du entsprechend der Forum-ID mit "forum_img_X.gif", etc. (X = Forum-ID). Andere Dateitypen (z. B. ".png") musst du ggf. im Template anpassen.
Zitieren
#4
Thumbsup 
Vielen vielen Dank für die Erklärung und deine Mühe!

Ich werds morgen ausgeschlafen gleich ausprobieren! Smile

Grüße
Zitieren
#5
Hey,

noch ne Frage dazu....

jetzt steht der Name der Forums neben dem Bild, die Beschreibung usw aber darunter.
Wie bekomme ich das alles neben das Bild?
Zitieren
#6
Hallo Maja,

ersetze im Template "forumbit_depth2_forum"
Code:
<td class="{$bgcolor}" valign="top">
<img src="{$theme['imgdir']}/{$forum_img}.gif" border="0" alt="{$forum['name']}" title="{$forum['name']}" style="vertical-align: middle;" />
<strong><a href="{$forum_url}">{$forum['name']}</a></strong>{$forum_viewers_text}<div class="smalltext">{$forum['description']}{$modlist}{$subforums}</div>
</td>
durch
Code:
<td class="{$bgcolor}" valign="top">
<div style="float:left;"><img src="{$theme['imgdir']}/{$forum_img}.gif" border="0" alt="{$forum['name']}" title="{$forum['name']}" style="vertical-align: middle;" /></div>
<div><strong><a href="{$forum_url}">{$forum['name']}</a></strong>{$forum_viewers_text}<div class="smalltext">{$forum['description']}{$modlist}{$subforums}</div>
</td>
Zitieren
#7
Super, Danke! Smile
Zitieren
#8
Hallo.

Ist dieser Tipp auch für 1.2.x geeignet?
Zitieren
#9
Hallo KarlMay,

eine (kleine) Abweichung gibt es (Basis: MyBB 1.2.14); ersetze im Template "forumbit_depth2_forum"
Code:
<td class="{$bgcolor}" valign="top">
<strong><a href="forumdisplay.php?fid={$forum['fid']}">{$forum['name']}</a></strong><div class="smalltext">{$forum['description']}{$modlist}{$subforums}</div>
</td>
durch
Code:
<td class="{$bgcolor}" valign="top">
<div style="float:left;"><img src="{$theme['imgdir']}/{$forum_img}.gif" border="0" alt="{$forum['name']}" title="{$forum['name']}" style="vertical-align: middle;" /></div>
<div><strong><a href="forumdisplay.php?fid={$forum['fid']}">{$forum['name']}</a></strong><div class="smalltext">{$forum['description']}{$modlist}{$subforums}</div><div>
</td>
Die weiteren Änderungen aus Beitrag #3 können übernommen werden.
Zitieren
#10
Huhu vielleicht könnte man mir hier auch weiter helfen.
hat auch mit den individuellen icons zu tun Smile

Also ich habe bereits einen neuen Theme hinzugefügt und diese benutzen meine User als standard - sie können sich zwischen den themes aber auch entscheiden, diese sind farblich völlig anders von einander und jetzt passen die icons nicht zum neuen Theme also würde ich gerne andere Icons haben, jedoch sollten die alten icons auch im anderen (früheren) Theme da bleiben wo sie sind.

Ich habs also ausprobiert das wenn ich ein Icon verändere im neuen Theme das diese sich auch im alten theme ändert und das will ich nicht.
Gibt es eine Möglichkeit oder lösung?!?!
Hoffentlich konnte ich mich klar ausdrücken :S
Ach ja ich meine die Icons vor den Foren selber Smile nicht die icons vor den beiträgen Smile!
Zitieren


Möglicherweise verwandte Themen...
Thema Verfasser Antworten Ansichten Letzter Beitrag
  Lücke zwischen Foren auf Startseite schließen Buster1704 4 966 17.02.2010, 21:11
Letzter Beitrag: Buster1704
  Problem mit den Beitrags-Icons & On/Off Anzeige Skyline-Chef 1 686 19.04.2009, 08:58
Letzter Beitrag: Michael
  Bilder vor Forenüberschrift Malone 4 764 06.03.2008, 16:11
Letzter Beitrag: Malone
  Männchen vor der Benutzernamen in der Wer ist Online anzeige... Crasher 5 897 21.10.2006, 16:01
Letzter Beitrag: ElkeK.