Hallo, Gast! (Registrieren)

Letzte Ankündigung: MyBB 1.8.8 veröffentlicht (17.10.16)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
Icons / Bilder vor den Foren auf der Startseite
#21
ja hab ich! ein Bild hab ich jetzt eben schon online

muss ich dass dann so machen?:

theme['imgdir']}/forum_img_2.png/forum_img_6"

oder wo füg ich die weiteren Bilder ein?
Zitieren
#22
Der Code oben besitzt eine passende Variable. Da brauchst du gar nichts ändern.
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
Zitieren
#23
PHP-Code:
<img src="{$theme['imgdir']}/{$forum_img}.gif" border="0" alt="{$forum['name']}title="{$forum['name']}style="vertical-align: middle;" /> 
...heißt es im Template. Die Variable "{$forum_img}" wird beim verarbeiten durch MyBB mit der entsprechenden Nummer gefüllt:
PHP-Code:
$forum_img "forum_img_".$forum['fid']; 
Du brauchst bzw kannst im Template keine Zahl für ein bestimmtes Bild anzugeben.
Einfach die Grafiken in den Ordner schmeißen und die Änderungen aus Beitrag #3 vornehmen.
Zitieren
#24
danke jetzt hab ich es endlich geschafft!!
Zitieren
#25
Moin!
Ich schalte mich mal in die Diskussion ein.
Ich habs genauso gemacht wie beschrieben... (Naja wohl eher doch nicht. Wink)
Leider ist mein ganzes Theme jetzt gesprengt und es sieht ziemlich komisch aus.
Mein Ziel war ein Template wie auf z.B mybbcentral.com
mfG


Angehängte Dateien Thumbnail(s)
   
Zitieren
#26
Hallo L4rZ,

verwendest du ein anderes als das Standard-/Default-Theme?

Poste bitte einmal einen Link zum Forum oder zumindest den Code im Template "forumbit_depth2_forum".
Zitieren
#27
User 
Moin!

Ja ich nutze aber abgeändertes Theme.
Ein Link zum Forum kann ich leider nicht posten, da alles nur lokas läuft.
(Der Server für das Forum läuft noch mit einem altären System)
Den Code kann ich natürlich posten.

PHP-Code:
<tr>
<
td class="{$bgcolor}valign="top">
<
img src="{$theme['imgdir']}/{$forum_img}.gif" border="0" alt="{$forum['name']}title="{$forum['name']}style="vertical-align: middle;" /> 
<
strong><a href="{$forum_url}">{$forum['name']}</a></strong>{$forum_viewers_text}<div class="smalltext">{$forum['description']}{$modlist}{$subforums}</div>
</
td>
<
td class="{$bgcolor}valign="top" align="center" style="white-space: nowrap">{$threads}{$unapproved['unapproved_threads']}</td>
<
td class="{$bgcolor}valign="top" align="center" style="white-space: nowrap">{$posts}{$unapproved['unapproved_posts']}</td>
<
td class="{$bgcolor}valign="top" align="right" style="white-space: nowrap">{$lastpost}</td>
</
tr
Zitieren
#28
Verwende einmal diesen Code
Code:
<tr>
<td class="{$bgcolor}" align="center" valign="top" width="1"><img src="{$theme['imgdir']}/{$lightbulb['folder']}.gif" alt="{$lightbulb['altonoff']}" title="{$lightbulb['altonoff']}" class="ajax_mark_read" id="mark_read_{$forum['fid']}" /></td>
<td class="{$bgcolor}" valign="top">
<img src="{$theme['imgdir']}/{$forum_img}.gif" border="0" alt="{$forum['name']}" title="{$forum['name']}" style="vertical-align: middle;" />
<strong><a href="{$forum_url}">{$forum['name']}</a></strong>{$forum_viewers_text}<div class="smalltext">{$forum['description']}{$modlist}{$subforums}</div>
</td>
<td class="{$bgcolor}" valign="top" align="center" style="white-space: nowrap">{$threads}{$unapproved['unapproved_threads']}</td>
<td class="{$bgcolor}" valign="top" align="center" style="white-space: nowrap">{$posts}{$unapproved['unapproved_posts']}</td>
<td class="{$bgcolor}" valign="top" align="right" style="white-space: nowrap">{$lastpost}</td>
</tr>
Zitieren
#29
Funktioniert, Danke Smile
Kann ich es irgendwie hinbekommen das diese Extra Icons nur bei bestimmten Foren angezeigt werden?
Zitieren
#30
Dazu müssen dann PHP-Dateien bearbeitet werden. Aber du kannst ja auch leere bzw. durchsichtige Icons verwenden.
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
Zitieren


Möglicherweise verwandte Themen...
Thema Verfasser Antworten Ansichten Letzter Beitrag
  Lücke zwischen Foren auf Startseite schließen Buster1704 4 967 17.02.2010, 21:11
Letzter Beitrag: Buster1704
  Problem mit den Beitrags-Icons & On/Off Anzeige Skyline-Chef 1 686 19.04.2009, 08:58
Letzter Beitrag: Michael
  Bilder vor Forenüberschrift Malone 4 764 06.03.2008, 16:11
Letzter Beitrag: Malone
  Männchen vor der Benutzernamen in der Wer ist Online anzeige... Crasher 5 897 21.10.2006, 16:01
Letzter Beitrag: ElkeK.