Hallo, Gast! (Registrieren)

Letzte Ankündigung: MyBB 1.8.8 veröffentlicht (17.10.16)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
Icons / Bilder vor den Foren auf der Startseite
#31
Danke für den Tipp, auf die Idee bin ich gar nicht gekommen.
Komischer Weise sind jetzt die Bilder aus dem Punkt "Forenstatistik" verschwunden..
Wie bekomme ich die da wieder hin?
Zitieren
#32
(05.10.2008, 22:04)linwinman schrieb: Hallo Maja,

nimm hierfür folgende Änderungen vor:

öffne (mit einem geeigneten Editor) die Datei ".../inc/functions_forumlist.php" und suche die Zeilen (~ 243)
PHP-Code:
                $posts my_number_format($forum['posts']);
                
$threads my_number_format($forum['threads']); 
Füge hierunter ein
PHP-Code:
                // Start:    => Variable fuer 'Forum-Image'
                
$forum_img "forum_img_".$forum['fid'];
                
// Ende:    => Variable fuer 'Forum-Image' 

Ersetze in "Admin-CP > Templates > dein Template-Set > Forum Bit Templates > forumbit_depth2_forum" die Zeilen
Code:
<td class="{$bgcolor}" valign="top">
<strong><a href="{$forum_url}">{$forum['name']}</a></strong>{$forum_viewers_text}<div class="smalltext">{$forum['description']}{$modlist}{$subforums}</div>
</td>
durch
Code:
<td class="{$bgcolor}" valign="top">
<img src="{$theme['imgdir']}/{$forum_img}.gif" border="0" alt="{$forum['name']}" title="{$forum['name']}" style="vertical-align: middle;" />
<strong><a href="{$forum_url}">{$forum['name']}</a></strong>{$forum_viewers_text}<div class="smalltext">{$forum['description']}{$modlist}{$subforums}</div>
</td>

Die Grafiken benennst du entsprechend der Forum-ID mit "forum_img_X.gif", etc. (X = Forum-ID). Andere Dateitypen (z. B. ".png") musst du ggf. im Template anpassen.
#####################################################
bei mir schaut das ganz anders aus, was muss ich da Ändern ??? Nicht das ich mir den freeChat dadurch kille ???

(Clean Cut Blue Theme)

PHP-Code:
<tr>
<
td class="{$bgcolor}align="center" valign="top" width="1"><img src="{$theme['imgdir']}/{$lightbulb['folder']}.gif" alt="{$lightbulb['altonoff']}title="{$lightbulb['altonoff']}class="ajax_mark_read" id="mark_read_{$forum['fid']}/></td>
<
td class="{$bgcolor}valign="top">
<
strong><a href="{$forum_url}">{$forum['name']}</a></strong>{$forum_viewers_text}<div class="smalltext">{$forum['description']}{$modlist}{$subforums}</div>
</
td>
<
td class="{$bgcolor}valign="top" align="center" style="white-space: nowrap">{$threads}{$unapproved['unapproved_threads']}</td>
<
td class="{$bgcolor}valign="top" align="center" style="white-space: nowrap">{$posts}{$unapproved['unapproved_posts']}</td>
<
td class="{$bgcolor}valign="top" align="right" style="white-space: nowrap">{$lastpost}</td>
</
tr>

');else if(engine == "opera") document.write('');// else if(engine == "khtml") document.write(' '); 

Was muss ich hier noch rein kopieren ?

###############################################
.... Die Grafiken benennst du entsprechend der Forum-ID mit "forum_img_X.gif", etc. (X = Forum-ID). Andere Dateitypen (z. B. ".png") musst du ggf. im Template anpassen.

Verstehe ich das richtig ? Wenn ich jetzt einen Kategorie habe , die zB. heißt
Kettwiesels Privat Forum, der name ist dabei egal? dann müsste ich das Bild dazu doch wie folgt erstellen...oder ?

(http://kettwieselforum.witziges.eu/forum....php?fid=3)

forum_img_3.gif

Aber wo soll ich das Bild hochladen ? Unter images ???? oder wo hin ?

Sprich wenn es kein Bild mit der ID gibt, wird kein Bild angezeigt, und will ich eines dazu haben, muss ich nur ein Bild mit der ID erstellen. Verstehe ich das so richtig ?

Danke im voraus. LG Kettwiesel
ich habs jetzt so geändert, da passiert überhaupt nix ??? Was mache ich falsch ?

PHP-Code:
<tr>
<
td class="{$bgcolor}align="center" valign="top" width="1"><img src="{$theme['imgdir']}/{$lightbulb['folder']}.gif" alt="{$lightbulb['altonoff']}title="{$lightbulb['altonoff']}class="ajax_mark_read" id="mark_read_{$forum['fid']}/></td>
<
td class="{$bgcolor}valign="top">
<
img src="{$theme['imgdir']}/{$forum_img}.gif" border="0" alt="{$forum['name']}title="{$forum['name']}style="vertical-align: middle;" /> 
<
strong><a href="{$forum_url}">{$forum['name']}</a></strong>{$forum_viewers_text}<div class="smalltext">{$forum['description']}{$modlist}{$subforums}</div>
</
td>
<
td class="{$bgcolor}valign="top" align="center" style="white-space: nowrap">{$threads}{$unapproved['unapproved_threads']}</td>
<
td class="{$bgcolor}valign="top" align="center" style="white-space: nowrap">{$posts}{$unapproved['unapproved_posts']}</td>
<
td class="{$bgcolor}valign="top" align="right" style="white-space: nowrap">{$lastpost}</td>
</
tr>

');else if(engine == "opera") document.write('');// else if(engine == "khtml") document.write(' '); 

ich habe des Rätsels Lösung selbst gefunden ;-)

http://www.deineHP.de/forum/images/clean...img_12.gif

Clencut, steht für den Aktuellen Style, also muss man es für alle Styles eintragen, wer mehrere hat.

allerdings ist das Icon NICHT in der Hauptkategorie wie ich es dachte, sondern in den einzelnen Foren. Aber egal, so ist das auch schon super.

Danke für die Hilfe , auch wenn ich es selber gefunden habe ;-) Aber somit kann ich wenigstens anderen helfen die das auch nicht begriffen haben.

   

voll easy wenns klappt. Bild mit ID Nr erstellen, hochladen worla das Bild ist drinnen!

LG Kettwiesel
hier noch mal nur der Code der zugefügt werden muss.

PHP-Code:
<img src="{$theme['imgdir']}/{$forum_img}.gif" border="0" alt="{$forum['name']}title="{$forum['name']}style="vertical-align: middle;" /> 

Ich habe nochmal einen Bildschirmausdruck gemacht, damit ihr seht wie es fertig aussieht

   
Wenn ich aber zu einzelnen Themen ein Bild hochlade, wir KEIN Bild angezeigt. Was muss ich jetzt da noch für eine Zeile hinzufügen, und wo ?
Zitieren
#33
Muss vor jedes Forum ein Bild, wenn ich den Quellcode aus Seite 1 in das Forum eingefügt habe?
Zitieren
#34
Ja... Du kannst natürlich transparente oder kleine Bilder verwenden, wenn du ein paar Ausnahmen willst.
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
Zitieren
#35
Hallo zusammen bei mir kommt wenn ich das einbaue folgende Fehlermeldung.
Code:
Parse error: syntax error, unexpected T_NS_SEPARATOR, expecting T_STRING in /data/multiserv/users/276483/projects/333112/www/test-forum/inc/functions_forumlist.php(320) : eval()'d code on line 4

Ich nutze Simple Grey

Danke schon mal
Zitieren
#36
da hast du einen syntaxfehler in deinem template
Zitieren
#37
Hallo,

Zitat:Einfach die Grafiken in den Ordner schmeißen und die Änderungen aus Beitrag #3 vornehmen.

Ist wahrscheinlich eine ganz dumme Frage, aber in WELCHEN Ordner schmeiße ich die Grafiken?

Läßt es sich einrichten, daß auch die Kategorien eigene Icons bekommen?
Ich habe Kategorien und Foren oft auf der selben Ebene, und enn ich nur Forenicons einbinde zerstört das die ganze Tabelle.

LG ZaunköniG


----------------------------------

Ok, die erste Frage hat sich erledigt: einfach in den images-Ordner kopieren...

Bleibt noch die verschobene Tabelle. Ich habe mal ein Bild angehangen, wie es im Moment bei mir aussieht:

   

Die Einträge Themen, Beiträge und Letzter Beitrag stehen nicht mehr unter der entsprechenden Überschrift.
Außerdem werden für weitergeleitete Foren keine Icons angezeigt.

Gibt es dafür eine Lösung?
Ich nutze die aktuelle Version 1.4.13

LG ZaunköniG
Zitieren
#38
Thumbsup 
Ist zwar schon ein paar Jährchen her, aber da ich den Tipp der ersten Seite super umsetzen konnte, mag ich mich an dieser Stelle nochmal bei linwinman bedanken für diese Toperklärung, welche ich problemlos umsetzen konnteWink
The eyes are useless if the mind is blind
Zitieren


Möglicherweise verwandte Themen...
Thema Verfasser Antworten Ansichten Letzter Beitrag
  Lücke zwischen Foren auf Startseite schließen Buster1704 4 966 17.02.2010, 21:11
Letzter Beitrag: Buster1704
  Problem mit den Beitrags-Icons & On/Off Anzeige Skyline-Chef 1 686 19.04.2009, 08:58
Letzter Beitrag: Michael
  Bilder vor Forenüberschrift Malone 4 764 06.03.2008, 16:11
Letzter Beitrag: Malone
  Männchen vor der Benutzernamen in der Wer ist Online anzeige... Crasher 5 897 21.10.2006, 16:01
Letzter Beitrag: ElkeK.