Hallo, Gast! (Registrieren)

Letzte Ankündigung: MyBB 1.8.8 veröffentlicht (17.10.16)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
"Fehlermeldung" nach erfolgreicher Registrierung
#1
Hallo zusammen,

wenn sich ein neuer User erfolgreich registriert bekommt er die folgende Meldung angezeigt (Grafik). Unschön ist dabei die unpassende rote Überschrift ("Ein Fehler ist aufgetreten") die den User ziemlich irritiert. Wie kann ich die Überschrift ändern, z. B. in ein "Registrierung erfolgreich" o.ä.? Danke.


Angehängte Dateien Thumbnail(s)
   
Viele Grüße
Andreas
---------------------------------------------------------
http://www.muenchenslangeleute.de/forum
Running on MyBB v1.4.13
#2
Hast du irgendwas an deinen Templates geändert?
Vantage-Forum: http://vantage-forum.de/
#3
Ich glaube ja. Wenn ich nur wüsste welches das war... Rolleyes
Viele Grüße
Andreas
---------------------------------------------------------
http://www.muenchenslangeleute.de/forum
Running on MyBB v1.4.13
#4
Schau in den Quelltext der Seite. In HTML-Kommentaren werden die Templates genannt. Wenn das bei dir nicht der Fall ist musst du die Option in den Server-und Optimierungsoptionen noch aktivieren.

Gruß,
Michael
[Bild: banner.png]
Support erfolgt NUR im Forum!
Bitte gelöste Themen als "erledigt" markieren.
Beiträge mit mangelhafter Rechtschreibung/Grammatik werden kommentarlos gelöscht.
#5
Ich habe mir den Quelltext angeschaut, konnte aber keinen Ansatz finden:
Code:
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd"><!-- start: error -->
<html lang="de">
<head>
<title>Muenchens lange Leute</title>
<!-- start: headerinclude -->
<link rel="shortcut icon" href="http://www.muenchenslangeleute.info/favicon.ico" />
<link rel="alternate" type="application/rss+xml" title="Letzte Themen (RSS 2.0)" href="http://www.muenchenslangeleute.de/forum/syndication.php" />
<link rel="alternate" type="application/atom+xml" title="Letzte Themen (Atom 1.0)" href="http://www.muenchenslangeleute.de/forum/syndication.php?type=atom1.0" />
<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
<meta name="robots" content="NOINDEX, NOFOLLOW">
<meta name="robots" content="NOARCHIVE">
<script type="text/javascript" src="jscripts/prototype.lite.js?ver=121"></script>
<script type="text/javascript" src="jscripts/moo.ajax.js?ver=121"></script>
<script type="text/javascript" src="jscripts/general.js?ver=121"></script>

<script type="text/javascript" src="jscripts/popup_menu.js?ver=121"></script>
<link rel="stylesheet" type="text/css" href="http://www.muenchenslangeleute.de/forum/css.php?theme=4" />
<script language="Javascript" type="text/javascript">
<!--
    var cookieDomain = ".muenchenslangeleute.de";
    var cookiePath = "/forum/";
    var newpm_prompt = "Du hast eine private Nachricht erhalten. Ein Klick auf OK öffnet die neue Nachricht.";
    var deleteevent_confirm = "Soll dieses Ereignis wirklich gelöscht werden?";
    var removeattach_confirm = "Sollen die ausgewählten Attachments wirklich aus diesem Beitrag entfernt werden?";
    var loading_text = 'Lade.<br />Bitte warten...';
    var saving_changes = 'Speichere Änderungen...';
// -->
</script>

<!-- end: headerinclude -->

<style type="text/css">
<!--
.fehler {
    color: #FF0000;
    font-weight: bold;
}
-->
</style>

</head>
<body>
<!-- start: header -->
    <a name="top" id="top"></a>
    <div id="container">

        <div id="header">
            <div class="logo"><a href="http://www.muenchenslangeleute.de/forum/index.php"><img src="http://www.muenchenslangeleute.de/forum/images/forum_logo_gross.gif" alt="Muenchens lange Leute" /></a></div>
            <div class="menu">
                <ul>
                    <li><a href="http://www.muenchenslangeleute.de/forum/search.php"><img src="http://www.muenchenslangeleute.de/forum/images/toplinks/search.gif" alt="" />Suche</a></li>
                    <li><a href="http://www.muenchenslangeleute.de/forum/memberlist.php"><img src="http://www.muenchenslangeleute.de/forum/images/toplinks/memberlist.gif" alt="" />Mitglieder</a></li>
<!--                    <li><a href="http://www.muenchenslangeleute.de/forum/calendar.php"><img src="http://www.muenchenslangeleute.de/forum/images/toplinks/calendar.gif" alt="" />Kalender</a></li>
-->
                    <li><a href="http://www.muenchenslangeleute.de/forum/misc.php?action=help"><img src="http://www.muenchenslangeleute.de/forum/images/toplinks/help.gif" alt="" />Hilfe</a></li>

                </ul>
            </div>
            <hr class="hidden" />
            <div id="panel">
                <!-- start: header_welcomeblock_guest -->
    <span style="float:right;"><strong>Es ist:</strong> Montag der 12. November 2007, 10:17 Uhr</span>
        Hallo, Gast! (<a href="http://www.muenchenslangeleute.de/forum/member.php?action=login">Anmelden</a> — <a href="http://www.muenchenslangeleute.de/forum/member.php?action=register">Registrieren</a>)

<!-- end: header_welcomeblock_guest -->
            </div>
        </div>
        <hr class="hidden" />
        <br class="clear" />
        <div id="content">
            
            
            
            
            
            
            
            
            
            
            <!-- start: nav -->

<div class="navigation">
<!-- start: nav_bit -->
<a href="http://www.muenchenslangeleute.de/forum/index.php">Muenchens lange Leute</a>

<!-- end: nav_bit --><!-- start: nav_sep_active -->
/
<!-- end: nav_sep_active --><!-- start: nav_bit_active -->
<span class="active">Forenmeldung</span>
<!-- end: nav_bit_active -->
</div>
<!-- end: nav -->
            <br class="clear" />
<!-- end: header -->
<br />
<table border="0" cellspacing="1" cellpadding="4" class="tborder">
<tr>
<td class="thead"><span class="smalltext"><strong>Muenchens lange Leute</strong></span></td>

</tr>

<tr>
<td align="center" class="fehler">EIN FEHLER IST AUFGETRETEN</class></td>
</tr>

<tr>
<td align="center" <class="trow1">Vielen Dank für deine Registrierung bei Muenchens lange Leute, andreastest.<p>Um deine Registrierung abzuschließen, musst du den Anweisungen in der E-Mail folgen, die dir gerade geschickt wurde. Erst danach kannst du Beiträge schreiben.</class></td>
</tr>

</table>

<!-- start: footer -->
            <br />
            <div class="bottommenu"><span class="smalltext"><a href="mailto:info@muenchenslangeleute.de">Kontakt</a> | <a href="http://www.muenchenslangeleute.de">Muenchens lange Leute - Homepage</a> | <a href="#top">Nach oben</a> | <a href="#content">Zum Inhalt</a> | <a href="http://www.muenchenslangeleute.de/forum/archive/index.php">Archiv-Modus</a> | <a href="http://www.muenchenslangeleute.de/forum/misc.php?action=syndication">RSS-Synchronisation</a></span>

            </div>
            </div>
        <hr class="hidden" />
            <div id="copyright">
                <div id="debug"></div>
                <!-- You may NOT remove, modify or hinder the visibility of the MyBB copyright at any time.
                     It must contain the links to the MyBB website and be formatted appropriately.

                     Failure to comply with the above will result in prosecution to the full extent of the law.
                     This is free software, support us and we'll support you. -->
Powered By <a href="http://www.mybboard.net" target="_blank">MyBB</a> 1.2.9<br />

                Deutsche Übersetzung: <a href="https://www.mybb.de" target="_blank">MyBBoard.de</a><br />Copyright © 2002-2007 <strong><a href="http://www.mybboard.net" target="_blank">MyBB Group</a></strong>
                <!-- End copyright -->
                <br />
<br class="clear" />
        </div>
        </div>

<!-- end: footer -->
</body>
</html>
<!-- end: error -->
Ich glaube das Problem liegt vielmehr in der member.php in Zeile 240. Dort steht folgende Anweisung:
Code:
error($lang->redirect_registered_activation);
Wenn ich mich nicht irre wird hierdurch die Bestätigungsmeldung der erfolgreichen Registrierung als "Fehler" ausgegeben, was ja Unsinn ist, da es sich ja nicht um einen Fehler handelt. Die Überschrift "EIN FEHLER IST AUFGETRETEN" wird dabei wohl automatisch vorgegeben.
Viele Grüße
Andreas
---------------------------------------------------------
http://www.muenchenslangeleute.de/forum
Running on MyBB v1.4.13
#6
Tritt der Fehler seit Anfang an auf oder erst seit kurzem? Wenn das der Fall ist muss er durch eine Änderung hervorgerufen werden, die du durchgefühhrt hast.

EDIT:
Code:
<td align="center" class="fehler">EIN FEHLER IST AUFGETRETEN</class></td>
Die CSS-Klasse "fehler" gibt es im MyBB nicht, das muss von dir kommen.

Gruß,
Michael
[Bild: banner.png]
Support erfolgt NUR im Forum!
Bitte gelöste Themen als "erledigt" markieren.
Beiträge mit mangelhafter Rechtschreibung/Grammatik werden kommentarlos gelöscht.
#7
Also wenn ich mich recht erinnere trat der Fehler schon immer auf.
Richtig, die CSS-Klasse "Fehler" habe ich selbst definiert. Danke, ich hab jetzt einfach den Text EIN FEHLER IST AUFGETRETEN in HINWEIS geändert (Fehler-Nachricht Templates -> error).
Viele Grüße
Andreas
---------------------------------------------------------
http://www.muenchenslangeleute.de/forum
Running on MyBB v1.4.13
#8
Ich kann keine solche Sprachvariable finden. Bist du sicher, dass du das nicht selber eingefügt hast?
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
#9
Ja, kann auch sein. Weiss es leider nimmer.. Sad
Viele Grüße
Andreas
---------------------------------------------------------
http://www.muenchenslangeleute.de/forum
Running on MyBB v1.4.13
#10
Ich habe genau den gleichen Fehler - bei mir steht oben im Verzeichnisbaum dann Erorr
gibts ne Lösung ?


Möglicherweise verwandte Themen...
Thema Verfasser Antworten Ansichten Letzter Beitrag
Sad Forum nach erfolgreicher installation nicht sichtbar UnicoNoco 3 802 16.10.2007, 13:09
Letzter Beitrag: krafdi
  Fehlermeldung nach Registrierung StefanTS 5 1.045 02.07.2007, 00:02
Letzter Beitrag: linwinman