Hallo, Gast! (Registrieren)

Letzte Ankündigung: MyBB 1.8.8 veröffentlicht (17.10.16)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
Sidebox Ein/Ausklappen + -
#1
Hi zusammen

Ich hab mir ein paar Sideboxen mit dem blocksystem von Dragon erstellt.
Alles wunderbar ! Wink

Nun möchte ich so wie auf dem bild dargestellt, so eine +/- funktion.
So das die Boxen ein/ausklappbar sind !
   

Ich habe folgenden code bereits eingebaut (daher sieht man auf dem bild bereits ein -) !
Aber leider ist der - button nicht anklickbar.
Zitat:<div class="expcolimage"><img src="{$theme['imgdir']}/collapse{$collapsedimg['boardstats']}.gif" id="boardstats_img" class="expander" alt="[-]" /></div>
Der code ist aus dem "index" Template !
Die roten sachen hab ich mal so gelassen, dachte es könnte gehen.

Was muss ich ändern damit das ganze funktioniert ?

bis gli...
greetz DaStaFlexX
Zitieren
#2
http://www.mybbcoder.de/showthread.php?t...53#pid2353

Gruß,
Michael
[Bild: banner.png]
Support erfolgt NUR im Forum!
Bitte gelöste Themen als "erledigt" markieren.
Beiträge mit mangelhafter Rechtschreibung/Grammatik werden kommentarlos gelöscht.
Zitieren
#3
ja danke Michael Wink
Nur geht das bei mir nicht !

Mein Original Code sieht so aus:
Code:
<table border="0" cellspacing="{$theme['borderwidth']}" cellpadding="{$theme['tablespace']}" class="tborder"><thead><tr><td class="thead"><strong>Board Suche</strong></td></td></tr></thead><tbody><tr><td style="background: #202427" align="center"><form action="search.php" method="post"><input type="text" name="keywords" style="width:56px;" /><input type="submit" name="Submit" value="GO"><input type="hidden" name="action" value="do_search" /><input type="hidden" name="forums" value="all" /><input type="hidden" name="postthread" value="1" /></form><span class="smalltext">[<a href="search.php">Erweiterte Suche</a>]</span></td></tr></table>

So sieht er aus wenn der Code erweitert ist:
Code:
<table border="0" cellspacing="{$theme['borderwidth']}" cellpadding="{$theme['tablespace']}" class="tborder"><thead><tr><td class="thead"><div class="expcolimage"><img src="{$theme['imgdir']}/collapse{$collapsedimg['blabla']}.gif" id="blabla_img" class="expander" alt="[-]" /></div><strong>Board Suche</strong></td></td></tr></thead><tbody style="{$collapsed['blabla_e']}" id="blabla_e"><tr><td style="background: #202427" align="center"><form action="search.php" method="post"><input type="text" name="keywords" style="width:56px;" /><input type="submit" name="Submit" value="GO"><input type="hidden" name="action" value="do_search" /><input type="hidden" name="forums" value="all" /><input type="hidden" name="postthread" value="1" /></form><span class="smalltext">[<a href="search.php">Erweiterte Suche</a>]</span></td></tr></table>

Geht leider nicht !
Zitieren
#4
Da fehlt zumindest der schließende </tbody>-Tag.

Gruß,
Michael
[Bild: banner.png]
Support erfolgt NUR im Forum!
Bitte gelöste Themen als "erledigt" markieren.
Beiträge mit mangelhafter Rechtschreibung/Grammatik werden kommentarlos gelöscht.
Zitieren
#5
Ok, wenn ich das noch hinzufüge sieht es so aus:
Code:
<table border="0" cellspacing="{$theme['borderwidth']}" cellpadding="{$theme['tablespace']}" class="tborder"><thead><tr><td class="thead"><div class="expcolimage"><img src="{$theme['imgdir']}/collapse{$collapsedimg['blabla']}.gif" id="blabla_img" class="expander" alt="[-]" /></div><strong>Board Suche</strong></td></td></tr></thead><tbody style="{$collapsed['blabla_e']}" id="blabla_e"><tr><td style="background: #202427" align="center"><form action="search.php" method="post"><input type="text" name="keywords" style="width:56px;" /><input type="submit" name="Submit" value="GO"><input type="hidden" name="action" value="do_search" /><input type="hidden" name="forums" value="all" /><input type="hidden" name="postthread" value="1" /></form><span class="smalltext">[<a href="search.php">Erweiterte Suche</a>]</span></td></tr></tbody></table>

Aber funktionieren tut es nicht !

Hat jemand ne Idee dazu ?
Zitieren
#6
Kannst du bitte mal den Link dazu posten?

Gruß,
Michael
[Bild: banner.png]
Support erfolgt NUR im Forum!
Bitte gelöste Themen als "erledigt" markieren.
Beiträge mit mangelhafter Rechtschreibung/Grammatik werden kommentarlos gelöscht.
Zitieren
#7
Jop, zusehen ist das ganze hier:
www.wsc-gtat.ch.vu
Zitieren
#8
Wo hast du den Code denn da eingebaut?

Gruß,
Michael
[Bild: banner.png]
Support erfolgt NUR im Forum!
Bitte gelöste Themen als "erledigt" markieren.
Beiträge mit mangelhafter Rechtschreibung/Grammatik werden kommentarlos gelöscht.
Zitieren
#9
Also die Boxen hab ich mit dem Blocksystem von Dragon eingefügt !

Alle Boxen sind rechts !
Beim "Board Suche" Block habe ich es bereits drin !
dort wird das "-" angezeigt, hat aber keine funktion !
Zitieren
#10
Bin ich blind? Ich sehe weder den Button, noch kann ich den Code im Quelltext finden. Rolleyes

Gruß,
Michael
[Bild: banner.png]
Support erfolgt NUR im Forum!
Bitte gelöste Themen als "erledigt" markieren.
Beiträge mit mangelhafter Rechtschreibung/Grammatik werden kommentarlos gelöscht.
Zitieren


Möglicherweise verwandte Themen...
Thema Verfasser Antworten Ansichten Letzter Beitrag
  Anderes Logo, bzw. anderes Bild im Sidebox bei jedem neuan Thema monique 4 542 04.10.2012, 11:44
Letzter Beitrag: monique
  images unter sidebox awex 5 670 21.02.2012, 13:48
Letzter Beitrag: awex
  Diverse Foren ein/ausklappen ? DaStaFlexX 2 791 25.06.2007, 22:11
Letzter Beitrag: Martito