Hallo, Gast! (Registrieren)

Letzte Ankündigung: MyBB 1.8.8 veröffentlicht (17.10.16)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
Prolem mit Attachement
#11
Den MyCode (inkl. den regulären Ausrücken) liefert ja schon das Plugin. Wenn Du den MyCode direkt in den Editor einarbeiten willst, dann kannst Du Dich an querschlaegers Beitrag orientieren (siehe: Video-Portale dem Editor von MyBB 1.6 hinzufügen). Da ist das recht gut beschrieben.

Die Fehlermeldung hängt vermutlich damit zusammen, dass der JWPlayer von longtailvideo keine avi's abspielen kann, da es sich um einen Flashplayer handelt. Du musst das avi-File vorher z.B. in ein flv-File umwandeln. Dazu kannst Du z.B. Super 2011 verwenden.
viele Grüße
Jockl
übersetzte und eigene Plugins
Zitieren
#12
Bald kann ich im Support-Team tätig werden was ich schon alles weiß Wink

Hab jetzt mal in Querschlägers Beitrag den Punkt durchstudiert.

In der editor.js habe ich jetzt mal den MyCode eingefügt... allerdings

zeigt er mir dann beim Einbetten
[Video: http://] an,
aber es müsste [video]http://[/video] heißen.

Hab sämtliche Varianten versucht aber bekomme es einfach nicht hin...


this.videos["youtube"] = this.options.lang.video_youtube;
this.videos["video"] = "MyVideos";


als 2tes wollte ich fragen, ob es möglich ist, das Fenster mit der "Url einfügen" wegfallen zulassen,
da ich mit diesem MyCode nur Attachement-Beiträge einfüge.

Zum anderen Problem - Dann müssen meine Mitglieder ihre Videos eben vorher umwandeln ;-)


Zitieren
#13
oder hast du eventuell noch eine andere Lösung wie ich es hinbekomme,
damit meine User ihre Videos per Attachement auf meinen Webspace laden
und im Forum einbinden können?? Am Besten alle Files (Avi, Mpeg, Flv, ect,)
Zitieren
#14
Nunja, grundsätzlich könnte man ein MyCode machen. Dazu müsste man noch Attachments so anweisen können, dass sie die URL rausrücken. Grundsätzlich müsste man nur den Parser dem entsprechend abändern.

Gruss FalkenaugeMihawk
Zitieren