Hallo, Gast! (Registrieren)

Letzte Ankündigung: MyBB 1.8.37 veröffentlicht (04.11.23)


Benutzer, die gerade dieses Thema anschauen: 3 Gast/Gäste
Plugins für PhP8+
#11
nur kurz zum Übersetzen

Die Übersetzungstools sind heute schon recht gut, da kommt wirklich nicht mehr nur Murks raus

am bekanntesten sicherlich https://translate.google.com/

aber noch besser übersetzt eigentlich: https://www.deepl.com/translator
gibt sicher noch andere
Da ich sehr viel vom englischen ins deutsche übersetze, nutze ich diese Tools manchmal um eine Phrase nochmal gegen zu checken; gerade bei wissenschaftlichen Essays steht man als fachlicher Laie sonst schnell auf dem Schlauch Big Grin

Das Problem mit den Plugins ist ja auch, dass viele Entwickler nicht im deutschen Forum schauen, weil sie der Sprache nicht mächtig sind; das sind eben zum Teil Inder, Vietnamesen, Pakistani, Araber und natürlich auch viele englischsprachige Wink
Von daher macht eine Anfrage dort manchmal noch Sinn Wink Nicht alle sind Im Nebel des weltweiten Netzes untergetaucht. Leider eben aber auch viele deutsche Entwickler, wie Jockl, MrBrechreiz etc. pp.
Vorsicht Mogelpackungen! Nicht überall, wo "Admin" dran steht, ist auch "Admin" drin
Zitieren
#12
(10.02.2024, 07:08)bv64 schrieb: Von daher macht eine Anfrage dort manchmal noch Sinn Wink Nicht alle sind Im Nebel des weltweiten Netzes untergetaucht. Leider eben aber auch viele deutsche Entwickler, wie Jockl, MrBrechreiz etc. pp.

Stimmt, Lu. Die meisten Plugins sind fast 10  Jahre alt ... und wurden nicht mehr weiterentwickelt. 
Vom Forenbetreiber erwarten sich die User, dass das Forum funktioniert, vielleicht dass ein paar nette Annehmlichkeiten eingebaut sind. 
Aber wenn halt nix mehr kommt, obwohl sich vieles ändert - ist das mühsam. 

Und @ Gerti: nein, es ist nicht die Bequemlichkeit, aber dass PHP8 kommt, war ja nun keine Überraschung. 
Und dass es Probleme geben wird, war vermutlich auch klar. 
Und wenn man selber nicht programmieren kann, ist man auf Hilfe angewiesen, damit man zumindest einige der Fehlermeldungen wegkriegt.

Aber wenn ich dann bei den Plugin-Veröffentlichungen sehe, dass das 3. oder 4. Plugin für Favicons rauskommt  Big Grin
Dafür braucht man kein Plugin, das geht in 30 Sekunden ohne.
Dogs and Fun

Liebe Grüße
Karin
Zitieren
#13
Für viele RPG-spezifische Plugins gibt es Support und teilweise auch Updates im Storming Gates Forum. Dort könntest du wahrscheinlich noch eher Hilfe finden als im englischen Forum, da eine ganze Reihe dieser Plugins dort veröffentlicht wurden.


(10.02.2024, 00:25)FlederMaus schrieb: die meisten Meldungen kamen mit dem "Zitate auf dem Index" gefolgt vom "Accountswitcher mit "wer ist wer"

Klingt fast so, als hättest du eine veraltete Version des Accountswitcher (aktuell ist 2.1.12. diese ist hier zu finden)
Sollten mit der neuesten Version Warnungen o.a. auftreten, melde sie bitte im Support-Thread des Accountswitchers, denn Fehler, die mir nicht bekannt sind, kann ich nicht beheben.  Wink
Zitieren
#14
Ich schließe mich Doylecc an, gerade im <a href="https://storming-gates.de/">Storming Gates</a>, <a href="https://epic.quodvide.de/index.php">Epic</a> und im <a href="https://think-and-wonder.de/index.php">think & wonder</a> bekommt man für RPG Plugins Hilfe. Auch kann man dort nach Hilfe fragen. Und es gibt auch schon einige PHP 8 fixes dort. Man muss nur schauen.

Und zum Wer ist Wer-Plugin - es gibt zum Beispiel von mir eine Alternative. <a href="https://github.com/little-evil-genius/Spielerverzeichnis/">Spielerverzeichnis & Statistiken</a> - es bietet mehr als eine Wer ist Wer, aber man kann die Extras auch ausschalten.

Zitat:die RPG-Relations, da gibt es auch nichts für PHP8+

Alleine im SG gibt es drei Stück für die Relation. Und sollten nicht alle PHP 8 Probleme gelöst worden sein, kann man sich direkt dort melden.

Zitat:Letzter Beitrag im Profil, weiß ich nicht ob der sich stören würde an PHP8+
Kann man auch ohne Plugin lösen und gibt es auch im SG ein Anleitung. Und sollte die unter 8 nicht laufen, kann man dort auch nach fragen.

Solltest du wirklich interessiert daran sein ein RPG aufzubauen, dann solltest du dich vielleicht in der deutschen RPG Community herumtreiben -> und das sind hauptsächlich die oben verlinkten Foren.

MfG
Lara
Zitieren
#15
ich glaube nicht, dass die Fledermaus noch etwas aufbauen möchte Wink Die flattert schon seit 8 Jahren durch das MyBB und hatte vorher auch ein Woltlab-Board Wink Das ist also wohl eher eine alte gewachsene RPG-Community

Schön, dass es spezielle Seite für so einen "Kram" gibt, die kenne ich zum Glück nicht Big Grin
Aber wenn die Plugins von dort sind, besteht ja doch noch Hoffnung.
Die Hoffnung stirbt zuletzt ---> aber sie stirbt!
Vorsicht Mogelpackungen! Nicht überall, wo "Admin" dran steht, ist auch "Admin" drin
Zitieren
#16
(10.02.2024, 12:41)doylecc schrieb: Für viele RPG-spezifische Plugins gibt es Support und teilweise auch Updates im Storming Gates Forum. Dort könntest du wahrscheinlich noch eher Hilfe finden als im englischen Forum, da eine ganze Reihe dieser Plugins dort veröffentlicht wurden.
(10.02.2024, 00:25)FlederMaus schrieb: die meisten Meldungen kamen mit dem "Zitate auf dem Index" gefolgt vom "Accountswitcher mit "wer ist wer"

Klingt fast so, als hättest du eine veraltete Version des Accountswitcher (aktuell ist 2.1.12. diese ist hier zu finden)
Sollten mit der neuesten Version Warnungen o.a. auftreten, melde sie bitte im Support-Thread des Accountswitchers, denn Fehler, die mir nicht bekannt sind, kann ich nicht beheben.  Wink
ahhhh, ein überlebender Schreiber, ist das nicht klasse Big Grin

Also zuerst mal Danke für den Link zur neuen Version, ich habe tatsächlich die letzte 2.1.9, allerdings dem Umstand geschuldet, das die Seite wie erwähnt noch auf 7.4 läuft die Testseite steht noch nicht wo ich dann auf PHP8 gehen könnte, um an die exakten Fehlermeldungen zu kommen, diese dann an die Entwickler weiter zu reichen

(10.02.2024, 16:32)little.evil.genius schrieb: Ich schließe mich Doylecc an, gerade im <a href="https://storming-gates.de/">Storming Gates</a>, <a href="https://epic.quodvide.de/index.php">Epic</a> und im <a href="https://think-and-wonder.de/index.php">think & wonder</a> bekommt man für RPG Plugins Hilfe. Auch kann man dort nach Hilfe fragen. Und es gibt auch schon einige PHP 8 fixes dort. Man muss nur schauen.

Und zum Wer ist Wer-Plugin - es gibt zum Beispiel von mir eine Alternative. <a href="https://github.com/little-evil-genius/Spielerverzeichnis/">Spielerverzeichnis & Statistiken</a> - es bietet mehr als eine Wer ist Wer, aber man kann die Extras auch ausschalten.

Zitat:die RPG-Relations, da gibt es auch nichts für PHP8+

Alleine im SG gibt es drei Stück für die Relation. Und sollten nicht alle PHP 8 Probleme gelöst worden sein, kann man sich direkt dort melden.

Zitat:Letzter Beitrag im Profil, weiß ich nicht ob der sich stören würde an PHP8+
Kann man auch ohne Plugin lösen und gibt es auch im SG ein Anleitung. Und sollte die unter 8 nicht laufen, kann man dort auch nach fragen.

Solltest du wirklich interessiert daran sein ein RPG aufzubauen, dann solltest du dich vielleicht in der deutschen RPG Community herumtreiben -> und das sind hauptsächlich die oben verlinkten Foren.

MfG
Lara

Storming Gates ist bekannt, da bin ich auch schon seit jahren, einzig als ich mal gewagt habe leicht kritisch was zu äußern, wurde das nicht als "dann werden wir da was ändern-motivation erkannt, sondern es wurde gegen meine Haltung gemeckert

Die meisten Plugins die wir nutzen, hatte Jule erstellt und wenn ich das richtig gesehen habe ist sie nicht mehr bei SG dabei?

(10.02.2024, 17:41)bv64 schrieb: ich glaube nicht, dass die Fledermaus noch etwas aufbauen möchte Wink Die flattert schon seit 8 Jahren durch das MyBB und hatte vorher auch ein Woltlab-Board Wink Das ist also wohl eher eine alte gewachsene RPG-Community

korrekt, die sind eingeschworene Community seit nunmehr fast 10 Jahren, neu aufbauen, wäre so gesehen eher nicht einfach, da der importer für das MyBB kein PHP8 unterstützt und bekannter Maßen verzichten RPGler nicht gern auf ihre alten Texte und der import funktioniert halt nur wenn der Importer auch die PHP-Version unterstützt, würde der das hätte ich nur die Hälfte der Probleme gehabt von der MyBB 1.8.21 auf 1.8.36 zu kommen, einfach "neu installieren und importieren" fertig dann die Plugins ergänzen und das wäre dann bereits erledigt das Problem, aber, siehe oben der Importer macht nicht was er soll, also bin ich gezwungen die alte Version zu halten und mit den Fehlern klarkommen zu müssen die dabei dann aufkommen, wenn ich die PHP-Version wechseln muss

(10.02.2024, 17:41)bv64 schrieb: Schön, dass es spezielle Seite für so einen "Kram" gibt, die kenne ich zum Glück nicht Big Grin
Aber wenn die Plugins von dort sind, besteht ja doch noch Hoffnung.
Ja aber auch die machen das ja nicht "hauptberuflich" und immer wieder der sein, dem was nicht gelingt was vorher bereits erklärt wurde, das hemmt schon ein wenig, den Leuten dann auf den Nerv zu gehen mit Problemen

(10.02.2024, 17:41)bv64 schrieb: Die Hoffnung stirbt zuletzt ---> aber sie stirbt!

ey .. das mein Spruch Toungue Big Grin
Zitieren
#17
(12.02.2024, 04:53)FlederMaus schrieb: ...allerdings dem Umstand geschuldet, das die Seite wie erwähnt noch auf 7.4 läuft die Testseite steht noch nicht wo ich dann auf PHP8 gehen könnte, um an die exakten Fehlermeldungen zu kommen,...

Dann verstehe ich diese Konversation hier nicht, oder habe dich grundlegend falsch verstanden.
Deine RPG-Plugins laufen unter PHP 7.4 alle. Zumindest die, die ich kenne.
Was für PHP 8.x angepasst werden muss, kannst du erst feststellen, wenn du es im Einsatz hast und bestenfalls verfügbare Plugin-Updates installiert hast.
Also wie ich bereits sagte... Ein Testboard einrichten (möglichst eine 1zu1-Kopie vom Original) und dann in Ruhe dran arbeiten. Wink
Zitieren
#18
Hallo Fledermaus,
ich kann dir nur auch noch einmal empfehlen den mybb support im storming gates zu nutzen. Dass du da unangenehme Erfahrungen gemacht hast, tut mir leid, aber im Technikbereich findet man eigentlich immer Hilfe. Alternativ könnte ich dir noch https://discord.gg/2pNrBgJdFN diesen discord server empfehlen. Dort sind auch hauptsächlich rpgler unterwegs.

Und ja, Jule ist nicht mehr im SG, allerdings viele Mitglieder, die ihre Plugins benutzen und entsprechend Erfahrungen mit den Meldungen haben und ich kann nur auch nochmal betonen, es gibt zu den meisten Plugins, die du erwähnst auch Alternativen, die auf PHP8 laufen bzw. eben ansonsten zumindest noch aktiven Support bieten.

LG
Zitieren
#19
(12.02.2024, 07:46)Schnapsnase schrieb:
(12.02.2024, 04:53)FlederMaus schrieb: ...allerdings dem Umstand geschuldet, das die Seite wie erwähnt noch auf 7.4 läuft die Testseite steht noch nicht wo ich dann auf PHP8 gehen könnte, um an die exakten Fehlermeldungen zu kommen,...

Dann verstehe ich diese Konversation hier nicht, oder habe dich grundlegend falsch verstanden.
Deine RPG-Plugins laufen unter PHP 7.4 alle. Zumindest die, die ich kenne.
Was für PHP 8.x angepasst werden muss, kannst du erst feststellen, wenn du es im Einsatz hast und bestenfalls verfügbare Plugin-Updates installiert hast.
Also wie ich bereits sagte... Ein Testboard einrichten (möglichst eine 1zu1-Kopie vom Original) und dann in Ruhe dran arbeiten. Wink

ich denke mal ich habe mich zu umständlich ausgedrückt und daher die Missverständnisse, alles gut, wenn ich das Testboard am Start habe, werde ich die Meldungen sammeln und sofern möglich vorsortieren nach "Problem-plugin" und dann entsprechend der Empfehlung die Fehler melden, damit die ggf, beseitigt werden können

Danke @Risu ich werde dann bei SG mein Glück versuchen
Zitieren