Hallo, Gast! (Registrieren)

Letzte Ankündigung: Sicherheitsupdate: MyBB 1.8.30 veröffentlicht (09.03.22)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
Fehler bei Verwendung von PHP 8
#1
Hi,
in einem anderen Thead war ja schon einmal die Rede von Fehler mit php 8. Der Thread ist allerdings mit erledigt gekennzeichnet und von daher stelle ich mein Problem neu dar, da auch bei mir Probleme mit php 8 auftreten.

Ich habe lediglich folgende PlugIns laufen: s. Anhang

Ich erhalte bei php 8 einen Error 500 wenn ich unter "Foren & Beiträge" an Foren Berechtigungsänderungen vornehme und diese dann speichere. Vorher bei der Berechtigungsbearbeitung und dem "Speidere Forenberechtigung" geschieht so nichts, d.h. nach dem Betätigen des Buttons müsste je eigentlch das Fenster wieder schließen, das tut es jedoch nicht. Die Berechtigungen werden jedoch übernommen.

Nach Umschalten auf php 7.4 läuft alles.
Gibt es Hinweise, welches PlugIn da evtl. Probleme bereiten könnte?

Bevor ich das ganze Forum nochmal neu aufsetze[, frag ich lieber mal. PHP 8 wäre schon für mich wichtig.

   
Bye Uwe
mybb1.8.30
Zitieren
#2
was ich auch noch mit php 8 feststelle.
es wird in einem Forum immer wieder angezeigt, dass ein neuer Beitrag vorhanden wäre, was jedoch nicht der Fall ist. Die schwarze Kugel wird immer wieder dunkel.
Ist immer reproduzierbar mit STRG F5
Bye Uwe
mybb1.8.30
Zitieren
#3
ferner funktioniert das "Mergen" aus einer anderen Forensoftware nicht mit php 8.
Habe eines meiner Foren gerade neu aufgesetzt und es getestet.
Bye Uwe
mybb1.8.30
Zitieren
#4
Nachdem ich nun ein Forum komplett neu aufgesetzt und ohne jegliche weitere PlugIns eingerichtet habe stelle ich fest, dass myBB unter PHP 8 bei mir nicht funktioniert.
Das ist nicht nur schade für mich, sondern leider demnächst auch ein Problem für andere User.
Ich finde die Forensoftware sehr ordentlich und würde sie auch gern nutzen, leider wird bei mir PHP 7.4 im November abgeschaltet und dann wäre eh Schluss mit myBB -schade.

Ich werde die Software aber weiter beobachten und vielleicht tut sich ja in dieser Hinsicht noch etwas.
Bye Uwe
mybb1.8.30
Zitieren
#5
Hallo,
wir stehen auch vor dem Umstellen auf PHP8, aber ich habe keine Wahl, es gibt der Hoster ab 14.11. so vor:

https://www.hosteurope.de/faq/webhosting...versionen/

Kann jemand vom Team sagen ob die MyBB Version 1.8.30 mit PHP8 funktioniert?

Bisher habe ich immer nur die Empfehlung vpn PHP 7.4 gefunden.
Vielen Dank,
Andrea
Zitieren
#6
Vor allem Plugins sind problematisch, da diese häufig nicht an PHP 8 angepasst worden sind.
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
Zitieren


Möglicherweise verwandte Themen…
Thema Verfasser Antworten Ansichten Letzter Beitrag
  Mehr als eine Verwendung von E-Mail-Adr. nicht möglich Darkness Rises 2 118 16.09.2022, 22:49
Letzter Beitrag: Darkness Rises