Hallo, Gast! (Registrieren)

Letzte Ankündigung: Sicherheitsupdate: MyBB 1.8.26 veröffentlicht (10.03.21)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
PN System > Sperre nicht vollständig!?
#1
Hallo,

normalerweise steht unten an jedem Beitrag das man dem Beitragsersteller eine PN senden kann.
    = korrekt

deaktivere ich im ACP bei in einer Benutzergruppe:
* Kann das Private Nachrichten System benutzen
* Kann Private Nachrichten versenden
wird beim des Benutzer
    = korrekt

sieht man sich das Profil des Benutzers an, kann man (obwohl deaktiviert) eine PN senden.
    = inkorrekt

Muss da noch irgendeine Einstellung geändert//angepasst  werden oder ist dies ein Bug?

Wenn es ein BUG ist, wäre ich erfreut wenn mir jemand mitteilt in welcher Datei was ergänzt werden muss, dass das PN-System tatsächlich nicht über das Profil verwendet werden (analog wie bei den Beiträgen).

Vorab besten Dank für Tipps, Hin weise, Lösungsvorschläge.
Jammer nicht rum ...Du musst (k/m)eine (nicht) Hilfe annehmen!
MyBB: 1.8.24 | PHP: 7.4.14 | SQL: 5.7.28
Tools [Unixzeit ⇔ Realzeit] ♦ [BOM-Finder] ♦ [301] ♦ [SQL-Prefix-Changer] ♦ [USV-Rechner]
Zitieren
#2
In den Gruppenberechtigungen gibt es die Option: "Kann Private Nachrichten senden, auch wenn der Empfänger dies deaktiviert hat"
Beim Admin sollte die Option eigentlich gesetzt sein.
Kann es damit zusammenhängen?!
Zitieren
#3
@Gerti

Keine Antwort ist auch eine Antwort.
Ich bin leider gerade erst zum Testen meiner These gekommen.
Es ist genau so, wie ich es beschrieben habe.
Wenn in der Gruppenberechtigung die Option "Kann Private Nachrichten senden, auch wenn der Empfänger dies deaktiviert hat" aktiviert ist, dann ist für diese Gruppe in den Profilen aller User die Möglichkeit zum Senden einer PN gegeben.
Allerdings bleibt auch dann im showthread (unter den Beiträgen) die Möglichkeit erhalten.
Diesen Punkt bei Dir kann ich leider nicht nachvollziehen.

Das ist kein Bug, eher sogar hilfreich. Wink
Zitieren
#4
Sorry, aber habe mich erst heute mal wieder damit beschäftigen können.

Die Option "Kann Private Nachrichten senden, auch wenn der Empfänger dies deaktiviert hat" ist deaktiv und trotzdem wird es angezeigt. Vermutlich liegt es daran, das die betroffene Gruppe das PN-System zwar nutzen kann, aber durch ein für mich gesondert erstelltes PlugIn "nur an den Admin PNs versenden können". Denke da muss ich nocht etwas nacharbeiten lassen.

Werde es aber fürsorglich noch bei einem "neutralem" (Sonderoption nicht gegeben) Forum testen.
Yep, meine vermeintliche Fehleranalyse war meinem individuellem PlugIn geschuldet.

Besten Dank für den Gedankenanstoß.
Jammer nicht rum ...Du musst (k/m)eine (nicht) Hilfe annehmen!
MyBB: 1.8.24 | PHP: 7.4.14 | SQL: 5.7.28
Tools [Unixzeit ⇔ Realzeit] ♦ [BOM-Finder] ♦ [301] ♦ [SQL-Prefix-Changer] ♦ [USV-Rechner]
Zitieren


Möglicherweise verwandte Themen…
Thema Verfasser Antworten Ansichten Letzter Beitrag
  IP-Sperre funktioniert nicht richtig JND_3004 3 686 23.04.2015, 16:49
Letzter Beitrag: StefanT