Hallo, Gast! (Registrieren)

Letzte Ankündigung: MyBB 1.8.27 veröffentlicht (22.06.21)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
Kein ACP-Zugang nach Upgrade
#11
Ich habe alle Plugins deaktiviert, das Forum geschlossen, das neue Paket hochgeladen, den Upgrade-Prozess gestartet und nach Aufforderung "weiter" geklickt. Eigentlich eine Idioten-sichere Sache, dachte ich.
Ich habe dann zunächst die Lock-Datei, danach das ganze Install-Verzeichnis gelöscht, wie auf einer anderen Hilfe-Seite vorgeschlagen. Aber der Fehler, dass ich nicht ins ACP komme war schon vor den Löschungen.
forum.sonett-archiv.com
Zitieren
#12
Man lese und staune:
Zitat:Zu Ihrem Schutz erlaubt www.sonett-archiv.com es Firefox nicht, diese Seite anzuzeigen, wenn sie in eine andere Seite eingebettet ist. Zur Anzeige der Seite muss diese in einem neuen Tab geöffnet werden.
Der Meldung ist wohl eindeutig. Klickt man auf "im neuen TAB öffnen" kommt man zur Adminseite. Es handelt sich hierbei nicht um einen Fehler von MyBB, sondern da dürfte ein Fehler in Deiner Konfiguration auf dem Webspace gegeben sein. Das gemeldete "einbetten" dürfte die Ursache sein.

Poste bitte mal den Inhalt Deiner .htaccess (Root und Adminverzeichnis) und, soweit vorhanden, auch die php.ini

Darfst mir auch gerne mal einen FTP-Zugang einrichten (Zugangsdaten via PN senden) damit ich für Dich der Sache auf den Grund gehen kann.
Jammer nicht rum ...Du musst (k/m)eine Hilfe (nicht) annehmen!
MyBB: 1.8.27 | PHP: 7.4.19 | SQL: 5.7.34
Tools [Unixzeit ⇔ Realzeit] ♦ [BOM-Finder] ♦ [301] ♦ [SQL-Prefix-Changer] ♦ [USV-Rechner]
Zitieren
#13
(28.12.2020, 18:32)Gerti schrieb: Man lese und staune:

Poste bitte mal den Inhalt Deiner .htaccess (Root und Adminverzeichnis)

Was gibt es da zu staunen? Wink 
Genau Deine Aussage hatte ich bereits im Post 7 getroffen. Toungue
Zitieren
#14
Da der Fehler unmittelbar nach dem Upgrade auftrat und ich an der Konfiguration meines Webspace nicht händisch herumgespielt habe, war mir diese Schlussfolgerung nicht so spontan eingefallen, aber gut, ihr seid die Experten.


Der Inhalt meiner .htaccess 
(Log-Ordner im Hauptverzeichnis meines Webspace)


Zitat:Options +Indexes
RemoveHandler .html
RemoveType .html
AddType text/html .html
Satisfy any
Order Deny,Allow
Allow from 212.227.112.228
Deny from all
AuthType Basic
AuthName "Access to /logs"
AuthUserFile /kunden/homepages/11/d113043283/htpasswd
Require user XXXXXXXX


im Forum-Hauptordner gibt es noch eine htaccess.txt 
im admin-Ordner nichts dergleichen.

Eine php.ini kann ich jetzt auch nicht finden. in welchem Ordner sollte die sein?



Gruß ZaunköniG
forum.sonett-archiv.com
Zitieren
#15
Warum steht in der .htaccess die IP-Adresse: 212.227.112.228? Deine Domain hat die IP-Adresse: 217.160.0.177

Eine htcess.txt hat keine Auswirkung. Benötigt wird die ".htaccess". Ist eventuell in Deinem FTP-Programm der Parameter "Anzeigen versteckter Dateien" deaktviert?
Jammer nicht rum ...Du musst (k/m)eine Hilfe (nicht) annehmen!
MyBB: 1.8.27 | PHP: 7.4.19 | SQL: 5.7.34
Tools [Unixzeit ⇔ Realzeit] ♦ [BOM-Finder] ♦ [301] ♦ [SQL-Prefix-Changer] ♦ [USV-Rechner]
Zitieren
#16
Für mich sieht es so aus, als ob es bei der Sub-Domain Einrichtung ein Zuordnungsproblem gibt, bzw. die Einstellunge der URL im den Foreneinstellungen nicht stimmt.

Über diese URL solltest du ins ACP kommen => http://sonett-archiv.com/forum/admin/
Zitieren
#17
(28.12.2020, 19:20)SvePu schrieb: Für mich sieht es so aus, als ob es bei der Sub-Domain Einrichtung ein Zuordnungsproblem gibt, bzw. die Einstellunge der URL im den Foreneinstellungen nicht stimmt.

Zustimmung!

Der OP gibt wie folgt an:
URL zum Forum: forum.sonett-archiv.com/index.php
das ACP lässt sich nicht unter: forum.sonett-archiv.com/admin/index.php erreichen
die Fehlermeldung verlinkt dann auf sonett-archiv.com/forum/admin/index.php

Versuche mal:
Einloggen auf URL: sonett-archiv.com/forum/index.php
dann zum ACP klicken (müsste dann sonett-archiv.com/admin/index.php lauten)
dann müsstest Du eigentlich ohne Fehlermeldung direkt ins ACP gelangen.
Jammer nicht rum ...Du musst (k/m)eine Hilfe (nicht) annehmen!
MyBB: 1.8.27 | PHP: 7.4.19 | SQL: 5.7.34
Tools [Unixzeit ⇔ Realzeit] ♦ [BOM-Finder] ♦ [301] ♦ [SQL-Prefix-Changer] ♦ [USV-Rechner]
Zitieren
#18
Gerti:
Ich benutze FileZilla und habe keine Filter aktiv. Ich habe es auch mit "anzeigen versteckter Dateien erzwingen" versucht, aber an der Anzeige ändert sich nichts. keine .htaccess und keine php.ini im forum-Ordner.

Sven:
Ins ACP komme ich auch, wenn ich den Link aus dem Forum in einem neuen Tab öffne. Der Pfad ist also nicht das Problem.
forum.sonett-archiv.com
Zitieren
#19
Das Problem ist, wenn du forum.sonett-archiv.com/ aufrufst, wird die eigentliche Forenadresse sonett-archiv.com/forum/ darin in einem iFrame geladen.
Wenn du jetzt das ACP im gleichen Fenster aufrufst, wird versucht sonett-archiv.com/forum/admin/ ebenfalls in diesem iFrame zu laden und es wird durch den X-Frame-Options SAMEORIGIN" Header geblockt:

Code:
admin:1 Refused to display 'http://www.sonett-archiv.com/forum/admin/' in a frame because it set 'X-Frame-Options' to 'sameorigin'.


Du solltest am besten - und nicht nur wegen dieses Problems - auf die Variante mit einer Frame-Einbindung verzichten.
Zitieren
#20
Ok, wenn ich nicht über die Subdomain gehe, brauche ich keinen neuen Tab öffnen.
Da das Problem bei Benutzer- und Moderator-CP nicht auftritt, also keine anderen User betrifft, kann ich mit dieser Lösung leben.

Die Fehlermeldung im den Admin-Einstellungen (siehe Bild in #9) ist aber dennoch da.
Habe ich eine Möglichkeit die fehlende Spalte selbst einzufügen, z.B. in den Templates?
forum.sonett-archiv.com
Zitieren


Möglicherweise verwandte Themen…
Thema Verfasser Antworten Ansichten Letzter Beitrag
  Nach upgrade auf 1.8.2 kein Zugriff auf CSS und Styles möglich Mickilina33 5 1.385 17.11.2014, 19:28
Letzter Beitrag: Mickilina33