Hallo, Gast! (Registrieren)

Letzte Ankündigung: Sicherheitsupdate: MyBB 1.8.24 veröffentlicht (09.08.20)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
HTML in Posts nicht mehr umsetzbar
#1
Hallo! 

Ja, ich weiß, es gibt eine Menge Themen zu diesem Thema, aber leider hat meine Suche keinen Erfolg gebracht. Ich habe seit dem Update auf 1.8.24 das Problem, dass statt der Umsetzung des HTML Codes, nur noch der HTML Code selbst zu sehen ist. Anbei Screenshots zum Verdeutlichen. 

Inzwischen habe ich alle möglichen Sachen ausprobiert, die Ankündigung mit dem SCEditor umgesetzt, also Ordner gelöscht, neu eingefügt, Codebuttons auf Original zurück gesetzt usw. 
Ich habe sogar einen User, der Programmier-Ahnung hat aufgrund vom Beruf konsultiert, aber auch der ist im Moment sehr ratlos. 

Das HTML ist nach wie vor nicht in den Posts zu sehen. 

Alte Version: 1.8.22
Neue Version: 1.8.24

Ich weiß jetzt spontan nicht welche Angaben noch gebraucht werden, mache aber gerne alle, wenn Fragen offen sind. Für Hilfe wäre ich außerordentlich dankbar und wie gesagt, angehängte Screenshots verdeutlichen mein Problem. 

Liebe Grüße
Carie Ma  Big Grin

EDIT: Oh ähm ich vergaß den Forenlink: https://www.abeginningthatneverends.de/


Angehängte Dateien Thumbnail(s)
   
Zitieren
#2
Hattest du vor dem Update die class_parser.php bearbeitet?
Standardmäßig sind <style> Tags bei MyBB aus Sicherheitsgründen immer deaktiviert, auch wenn HTML aktiviert ist.
Zitieren
#3
Ja, ich glaube schon, dass ich sie bearbeitet habe, weiß nur leider nicht mehr wie. Und wie aktiviere ich diese style Tags wieder?

EDIT: Lösung gefunden - aus Zeile 
Code:
$message = preg_replace('#<(/?)(base|meta|script|style)([^>]*)>#i', '&lt;$1$2$3&gt;', $message);
einfach das Style rausnehmen!
Zitieren


Möglicherweise verwandte Themen…
Thema Verfasser Antworten Ansichten Letzter Beitrag
  HTML in Posts - Ersetzen von Font thomas310769 7 515 09.09.2020, 08:53
Letzter Beitrag: thomas310769
  <p><br> Tags werden in den Posts angezeigt. Formatierung geht nicht mehr lumpi 6 723 05.08.2019, 12:20
Letzter Beitrag: The-Error
Question HTML Tags in den Posts macca 14 1.003 15.06.2019, 14:18
Letzter Beitrag: StefanT
  HTML-Codes im Template Editor nicht mehr farbig angezeigt paperlove 2 812 05.08.2015, 23:38
Letzter Beitrag: paperlove