Hallo, Gast! (Registrieren)

Letzte Ankündigung: Sicherheitsupdate: MyBB 1.8.24 veröffentlicht (09.08.20)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
HTML Tags in den Posts
#1
Question 
Ich weiss nicht warum, aber seit kurzem sind in einigen Posts plötzlich HTML Tags die keiner braucht.

https://www.koronaforum.de/Thread-Zeitwe...-des-Forum

MyBB 1.8.21
PHP 7.2.19
Standard Theme/Template MyBB
Editor Standart Mybb Style

Was kann das sein?
Zitieren
#2
nach dem Update das hier beachtet: https://github.com/mybb/mybb/pull/3639#i...-480689866

und bitte das codebuttons-Template auf Originalversion zurück setzen
Du findest es bei den Templates in der Gruppe "Templates ohne Gruppe"
schönen Gruß
bv64 / Lu

kein Support per PN, Mail, Messenger etc.
still alive - aus gesundheitlichen Gründen aktuell nur sehr sporadisch aktiv
Zitieren
#3
(13.06.2019, 21:24)bv64 schrieb: nach dem Update das hier beachtet: https://github.com/mybb/mybb/pull/3639#i...-480689866

und bitte das codebuttons-Template auf Originalversion zurück setzen
Du findest es bei den Templates in der Gruppe "Templates ohne Gruppe"

Ich habe am codebuttons-Template nichts geändert, wie soll ich das zurücksetzen?
Bin Neuling in MyBB, kannst Du das etwas genauer erklären?
Zitieren
#4
tut mir leid, heute nicht mehr, mein Akku ist leer.
Vielleicht ist jemand so freundlich und übernimmt
schönen Gruß
bv64 / Lu

kein Support per PN, Mail, Messenger etc.
still alive - aus gesundheitlichen Gründen aktuell nur sehr sporadisch aktiv
Zitieren
#5
(13.06.2019, 21:48)bv64 schrieb: tut mir leid, heute nicht mehr, mein Akku ist leer.
Vielleicht ist jemand so freundlich und übernimmt

Habs hinbekommen, ich habe beim Update wohl etwas falsch gemacht, ich habe das Update nochmal durchgeführt und nun passt das.

Was mir nicht ganz klar ist, wie genau erkenne ich ob und was ich wie am Template wieder anpassen oder zurücksetzen muss?

Danke
Zitieren
#6
Du kannst die zu aktualisierenden Templates direkt im Admin-CP suchen (siehe: https://www.mybb.de/doku/installationakt...lisierung/ -> Templates aktualisieren), zudem befindet sich eine Liste der geänderten Templates in der jeweiligen Ankündigung. Die genauen Änderungen aller Dateien und Templates lassen sich auch in unserer Doku nachvollziehen: https://www.mybb.de/doku/sonstiges/geaen...templates/
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
Zitieren
#7
(13.06.2019, 22:05)StefanT schrieb: Du kannst die zu aktualisierenden Templates direkt im Admin-CP suchen (siehe: https://www.mybb.de/doku/installationakt...lisierung/ -> Templates aktualisieren), zudem befindet sich eine Liste der geänderten Templates in der jeweiligen Ankündigung. Die genauen Änderungen aller Dateien und Templates lassen sich auch in unserer Doku nachvollziehen: https://www.mybb.de/doku/sonstiges/geaen...templates/

Ok, auch das geschnallt, ich habe die Anpassung die ausgegeben wurde durchgeführt und die Zeile entsprechend in meine Templatedatei eingefügt.
Zitieren
#8
Ist das Problem damit gelöst? Mich irritiert allerdings, dass du von einer Zeile schreibst. An besagtem Template gibt es umfangreiche Änderungen.
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
Zitieren
#9
Mir wurde unter "finde aktualisierte Templates" nur eine Datei angezeigt, im Vergleich neu gegen alt war nur eine Zeile einzufügen.
Die Änderung war glaube ich in der "showthread", diese ist jetzt auch grün hervorgehoben.

Ich glaube folgendes musste ich hinter eine </script> einfügen:
Code:
src="{$mybb->asset_url}/jscripts/thread.js?ver=1821"></script>

Sieht nun wie folgt aus:
Code:
<html>
<head>
<title>{$thread['subject']}</title>
{$headerinclude}
<script type="text/javascript">
<!--
var quickdelete_confirm = "{$lang->quickdelete_confirm}";
var quickrestore_confirm = "{$lang->quickrestore_confirm}";
var allowEditReason = "{$mybb->settings['alloweditreason']}";
lang.save_changes = "{$lang->save_changes}";
lang.cancel_edit = "{$lang->cancel_edit}";
lang.quick_edit_update_error = "{$lang->quick_edit_update_error}";
lang.quick_reply_post_error = "{$lang->quick_reply_post_error}";
lang.quick_delete_error = "{$lang->quick_delete_error}";
lang.quick_delete_success = "{$lang->quick_delete_success}";
lang.quick_delete_thread_success = "{$lang->quick_delete_thread_success}";
lang.quick_restore_error = "{$lang->quick_restore_error}";
lang.quick_restore_success = "{$lang->quick_restore_success}";
lang.editreason = "{$lang->postbit_editreason}";
lang.post_deleted_error = "{$lang->post_deleted_error}";
lang.softdelete_thread = "{$lang->soft_delete_thread}";
lang.restore_thread = "{$lang->restore_thread}";
// -->
</script>
<!-- jeditable (jquery) -->
<script type="text/javascript" src="{$mybb->asset_url}/jscripts/report.js?ver=1820"></script>
<script src="{$mybb->asset_url}/jscripts/jeditable/jeditable.min.js"></script>
<script type="text/javascript" src="{$mybb->asset_url}/jscripts/thread.js?ver=1820"></script>
<script type="text/javascript" src="{$mybb->settings['bburl']}/jscripts/thankyoulike.min.js"></script>
<script type="text/javascript">
<!--
var tylEnabled = "{$mybb->settings['g33k_thankyoulike_enabled']}";
var tylDisplayGrowl = "{$mybb->settings['g33k_thankyoulike_displaygrowl']}";
var tylCollapsible = "{$mybb->settings['g33k_thankyoulike_collapsible']}";
var tylUser = "{$mybb->user['uid']}";
var tylSend = "{$lang->tyl_send}";
var tylRemove = "{$lang->tyl_remove}";
// -->
</script>src="{$mybb->asset_url}/jscripts/thread.js?ver=1821"></script>
</head>
<body>
{$header}
{$threadnotesbox}
{$pollbox}
<div class="float_left">
{$multipage}
</div>
<div class="float_right">
{$newreply}
</div>
{$ratethread}
<table border="0" cellspacing="{$theme['borderwidth']}" cellpadding="{$theme['tablespace']}" class="tborder tfixed clear">
<tr>
<td class="thead">
<div class="float_right">
<span class="smalltext"><strong><a href="javascript:void(0)" id="thread_modes">{$lang->thread_modes}</a>{$threadnoteslink}</strong></span>
</div>
<div>
<strong>{$thread['displayprefix']}{$thread['subject']}</strong>
</div>
</td>
</tr>
<tr><td id="posts_container">
<div id="posts">
{$posts}
</div>
</td></tr>
<tr>
<td class="tfoot">
{$search_thread}
<div>
<strong>&laquo; <a href="{$next_oldest_link}">{$lang->next_oldest}</a> | <a href="{$next_newest_link}">{$lang->next_newest}</a> &raquo;</strong>
</div>
</td>
</tr>
</table>
<div class="float_left">
{$multipage}
</div>
<div style="padding-top: 4px;" class="float_right">
{$newreply}
</div>
<br class="clear" />
{$quickreply}
{$threadexbox}
{$similarthreads}
<br />
<div class="float_left">
<ul class="thread_tools">
{$printthread}
{$sendthread}
{$addremovesubscription}
{$addpoll}
</ul>
</div>

<div class="float_right" style="text-align: right;">
{$moderationoptions}
{$forumjump}
</div>
<br class="clear" />
{$usersbrowsing}
{$footer}
<div id="thread_modes_popup" class="popup_menu" style="display: none;"><div class="popup_item_container"><a href="showthread.php?mode=linear&amp;tid={$tid}&amp;pid={$pid}#pid{$pid}" class="popup_item">{$lang->linear}</a></div><div class="popup_item_container"><a href="showthread.php?mode=threaded&amp;tid={$tid}&amp;pid={$pid}#pid{$pid}" class="popup_item">{$lang->threaded}</a></div></div>
<script type="text/javascript">
// <!--
if(use_xmlhttprequest == "1")
{
$("#thread_modes").popupMenu();
}
// -->
</script>
<script type="text/javascript">
var thread_deleted = "{$thread_deleted}";
if(thread_deleted == "1")
{
$("#quick_reply_form, .new_reply_button, .thread_tools, .inline_rating").hide();
$("#moderator_options_selector option.option_mirage").attr("disabled","disabled");
}
</script>
</body>
</html>
Zitieren
#10
Also zumindest das Template "headerinclude" ist nicht auf dem aktuellen Stand, auch wenn es mit diesem Problem wohl nichts zu tun hat.

Bitte kontrolliere auch die Option "Editor-Stil" deines Themes (befindet sich unterhalb der Liste mit den Stylesheets). Standard ist dort Mybb.
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
Zitieren


Möglicherweise verwandte Themen…
Thema Verfasser Antworten Ansichten Letzter Beitrag
  HTML in Posts - Ersetzen von Font thomas310769 7 531 09.09.2020, 08:53
Letzter Beitrag: thomas310769
  HTML in Posts nicht mehr umsetzbar Carie Ma 2 432 06.09.2020, 15:16
Letzter Beitrag: Carie Ma
  <p><br> Tags werden in den Posts angezeigt. Formatierung geht nicht mehr lumpi 6 730 05.08.2019, 12:20
Letzter Beitrag: The-Error