Hallo, Gast! (Registrieren)

Letzte Ankündigung: MyBB 1.8.27 veröffentlicht (22.06.21)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
[geteilt] [Tutorial] Wie installiere ich etwas Lokal ?
#21
Danke!
Ich werde mir Deine Änderungen mal anschauen.
Bleibt noch abzuwarten, was Gerti sagt - ob es denn jetzt funktioniert.

Grüße
Zitieren
#22
(13.06.2020, 12:30)The Incredible schrieb: das liegt nicht an XAMPP selbst, sondern an der mit XAMPP verwendeten PHP Version (7.4.x). Dadurch kam die Fehlermeldung im Plugin.
Zunächst einmal Danke dass Du Dich der Thematik  annimmst.

Habe die asoi.php ausgetauscht und das PlugIn aktiviert.
Fehlermeldung:
Zitat:Fatal error: require_once(): Failed opening required 'C:\xampp\htdocs\url/asoi.php' (include_path='\xampp\php\PEAR') in C:\xampp\htdocs\url\inc\plugins\asoi.php on line 408
warum, wieso, weshalb kann ich nicht beurteilen!

Du hast in den Zeilen 349 und 262 das require zu require_once geändert (hatte ich ja auch bereits) und den Abschnitt (Zeilen 408 bis 417) von
PHP-Code:
// Start Header im Forum
require "asoi.php";
if (
$mybb->user['usergroup'] != 1) {
$heads_index .= "<span style=\"margin-left: 5px;\">".$lang->asoi_tip1." ".$limit." ".$lang->asoi_tip2."</span></br>&nbsp;&nbsp;&nbsp;&nbsp;";
}
else {
$heads_index .= "<span style=\"margin-left: 5px;\">".$lang->asoi_tip3." ".$limit." ".$lang->asoi_tip4."</span></br>&nbsp;&nbsp;&nbsp;&nbsp;";
}
// Start Anzeige im Forum nach den im ACP eigenstellten Auswahlkriterien 
$asoi_show false
zu
PHP-Code:
require_once MYBB_ROOT."asoi.php";
 
$asoi_show false
geändert. Ändere ich hier(Ziele 408) require_once zu require kommt die gleichfalls die oben erwähnte Fehlermeldung.

@Nachtrag:
sollte ich XAMPP mit PHP 7.2.x neu aufsetzen? Dies würde das eigentliche Problem jedoch nur hinausschieben.
Jammer nicht rum ...Du musst (k/m)eine Hilfe (nicht) annehmen!
MyBB: 1.8.27 | PHP: 7.4.19 | SQL: 5.7.34
Tools [Unixzeit ⇔ Realzeit] ♦ [BOM-Finder] ♦ [301] ♦ [SQL-Prefix-Changer] ♦ [USV-Rechner]
Zitieren
#23
Hallo Gerti,

bei mir funzt das Plugin lokal via XAMPP einwandfrei mit den Änderungen. Vielleicht ist bei dir schon bei dir Installation etwas schief gegangen? Das vermag ich aber nicht zu beurteilen.
Cheers
Zitieren
#24
*grübel, was soll/kann da schief gelaufen sein?

Ich habe das PlugIn nicht nur deaktiviert, sondern auch deinstalliert, danach Deine asoi.php nach  ./inc/plugins/ kopiert und das PlugIn wieder Installiert und Aktiviert.

Mehr verbleibt mir doch nicht zu tun.
Jammer nicht rum ...Du musst (k/m)eine Hilfe (nicht) annehmen!
MyBB: 1.8.27 | PHP: 7.4.19 | SQL: 5.7.34
Tools [Unixzeit ⇔ Realzeit] ♦ [BOM-Finder] ♦ [301] ♦ [SQL-Prefix-Changer] ♦ [USV-Rechner]
Zitieren
#25
Ob "require" oder "require_once" hat doch mit der php-Version eigentlich nichts zu tun. Huh
Es verhindert doch nur, dass eine Datei (Funktion) nicht mehrfach eingebunden werden kann.
Die eigentliche Frage bleibt bestehen. Was ist auf Deinem XAMPP anders, als im laufenden Betrieb?
Zitieren
#26
@Gerti
Ich meine die Installation MyBB lokal auf XAMPP bei dir, nicht die Installation des Pluigins.

@Schnapsnase
Ich bin auch kein Profi was Programmierung angeht und habe mich an folgendes gehalten und das einfach mal getestet. http://www.php-faq.de/q/q-fehler-class-redeclare.html

Bei mir hat das auch geholfen.
Cheers
Zitieren
#27
(13.06.2020, 15:40)The Incredible schrieb: @Gerti
Ich meine die Installation MyBB lokal auf XAMPP bei dir, nicht die Installation des Pluigins.
Vermute ich auch. Leider ist das MyBB-Fehlerlog leer. Wenn wenigsten ein Fehler geloggt werden würde, dann könnte ich dem wenigstens nachgehen. In der eigenen Fehlerdatei (über .htaccess definiert) steht nur der PlugIn-Fehler Zeile 408 wie bereits gepostet.
Jammer nicht rum ...Du musst (k/m)eine Hilfe (nicht) annehmen!
MyBB: 1.8.27 | PHP: 7.4.19 | SQL: 5.7.34
Tools [Unixzeit ⇔ Realzeit] ♦ [BOM-Finder] ♦ [301] ♦ [SQL-Prefix-Changer] ♦ [USV-Rechner]
Zitieren
#28
Ändere Zeile 408

zu

PHP-Code:
require_once(MYBB_ROOT 'asoi.php'); 
Zitieren
#29
Macht Sinn, war aber nicht der Fehler.
Problem scheint erledigt zu sein - hoffe ich nach meiner nächtlichen Aktion. Big Grin
Zitieren
#30
doch, das war der Fehler. Ich habe es bei mir reproduziert und mir gerade XAMPP installiert Wink

Nachdem ich den Fehler ebenfalls erhalten habe in der index.php, habe ich effektiv 3 Minuten nach dem Fehler gesucht und es wie oben beschrieben behoben bekommen. Ich weiß nicht, was du da in der Nacht alles umprogrammiert hast, aber wenn es läuft dann ist ja okay.
Zitieren


Möglicherweise verwandte Themen…
Thema Verfasser Antworten Ansichten Letzter Beitrag
  Wie installiere ich das Danke Plugin 3.9.1 Mario 6 1.980 18.12.2013, 16:26
Letzter Beitrag: MrBrechreiz
  wie installiere ich den pjirc chat ? System 5 1.997 03.11.2006, 23:45
Letzter Beitrag: Garlant
  Wie installiere ich das denn nun ? diggler 5 2.362 16.05.2006, 15:11
Letzter Beitrag: StefanT