Hallo, Gast! (Registrieren)

Letzte Ankündigung: MyBB 1.8.27 veröffentlicht (22.06.21)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
SQL Error: 1364 - Field 'thx' doesn't have a default value
#1
Hallo,

ich habe in MyBB 1.8.22 einige plugins installiert und aktiviert, unter anderem "Thanks_#1_stable". Wenn sich nun jemand im Forum registrieren will, kommt nach Ausfüllen der Profilangaben folgende Fehlermeldung:

-------------------------------------------------------------------------------------------------------------------------------------
MyBB SQL Error
MyBB has experienced an internal SQL error and cannot continue.

SQL Error:
1364 - Field 'thx' doesn't have a default value
Query:
INSERT INTO p5QQ_users (`username`,`password`,`salt`,`loginkey`,`email`,`postnum`,`threadnum`,`avatar`,`avatartype`,`usergroup`,`additionalgroups`,`displaygroup`,`usertitle`,`regdate`,`lastactive`,`lastvisit`,`website`,`icq`,`skype`,`google`,`birthday`,`signature`,`allownotices`,`hideemail`,`subscriptionmethod`,`receivepms`,`receivefrombuddy`,`pmnotice`,`pmnotify`,`showimages`,`showvideos`,`showsigs`,`showavatars`,`showquickreply`,`showredirect`,`tpp`,`ppp`,`invisible`,`style`,`timezone`,`dstcorrection`,`threadmode`,`daysprune`,`dateformat`,`timeformat`,`regip`,`language`,`showcodebuttons`,`sourceeditor`,`buddyrequestspm`,`buddyrequestsauto`,`away`,`awaydate`,`returndate`,`awayreason`,`notepad`,`referrer`,`referrals`,`buddylist`,`ignorelist`,`pmfolders`,`warningpoints`,`moderateposts`,`moderationtime`,`suspendposting`,`suspensiontime`,`coppauser`,`classicpostbit`,`usernotes`) VALUES ('dummyuser12345','c0eb1eb49c9e2b052834ee5f27959b4b','wZ2YXLCZ','TuTICTKoaDFCY0xOAbUFZyaOnEynYxn6lR4S11kau1JSWiCB9N','dummyuser12345@gmail.com',0,0,'','',2,'',0,'',1587470597,1587470597,1587470597,'',0,'','','','',1,0,0,1,0,1,0,1,1,1,1,1,1,0,0,0,0,'1',2,'linear',0,'','',X'c2605b11','',1,0,1,0,0,0,0,'','',1,0,'','','',0,0,0,0,0,0,0,'')
Please contact the MyBB Group for technical support.

-------------------------------------------------------------------------------------------------------------------------------------

Mittlerweile habe ich schon alle plugins aus /forum/inc/plugins händisch gelöscht, aber das Registrierungsproblem besteht unverändert weiter.

LG
Zitieren
#2
Hast du die Plugins auch vorher im ACP Deinstalliert oder nur vom FPT gelöscht? Das Thanks plugin ist auch schon 6 Jahre alt nehme dann lieber was aktuelles wie das Thank You/Like System
Zitieren
#3
Nebenbei ist auch im ACP die "Home » Plugins"-Seite, aus für mich nicht nachvollziehbaren Gründen, leer geworden, sodass ich keine Chance hatte die Plugins in der korrekten Weise zu deaktivieren usw. Aber jetzt wo ich die plugin-files aus /forum/inc/plugins gelöscht habe, wird im ACP die "Home » Plugins"-Seite wieder korrekt angezeigt, und die Seite zeigt, dass es keine aktiven plugins gibt.
Beim Registrieren kommt aber weiterhin dieselbe Fehlermeldung.
Zitieren
#4
Dann versuch mal nur das verursachende Plugin Thanks wieder im FTP hochzuladen und es dann im ACP zu Deinstallieren.
Zitieren
#5
Das hat geholfen, vielen Dank, man kann sich im Forum wieder normal registrieren.
Zitieren


Möglicherweise verwandte Themen…
Thema Verfasser Antworten Ansichten Letzter Beitrag
  Warning [2] A non-numeric value encountered - Line: 95 - File: inc/languages/deutsch_ Carla 3 732 08.01.2019, 12:34
Letzter Beitrag: StefanT
  SQL Error: 1054 - Unknown column 'fid3' in 'field list' sjfm 4 1.664 11.05.2017, 22:01
Letzter Beitrag: sjfm
  SQL Error 1364 nach update und umzug uvcmd 16 2.770 03.02.2017, 17:53
Letzter Beitrag: uvcmd
  SQL Error: 1054 - Unknown column '2fasecret' in 'field list' Pollux 4 1.521 23.02.2015, 13:53
Letzter Beitrag: Pollux