Hallo, Gast! (Registrieren)

Letzte Ankündigung: MyBB 1.8.21 veröffentlicht (11.06.19)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
Suche Alternative zu Prostats (PHP 7 kompatibel)
#1
Hallo zusammen ;D

Ich suche eine Alternative zu Prostats bzw. ein Plugin was auch wirklich PHP 7.x kompatibel ist. Die meisten Plugins, was ich bisher getestet hab, sind nicht oder nur zum Teil PHP 7.x kompatibel. Natürlich wäre es super, wenn das Prostats auf die 7.2.19 gefixed werden würde. Dazu hab ich auch schon ein Post im englischen forum gemacht, nur ich glaube nicht so recht dran, das sich da ein Entwickler bzw. der Hauptentwickler wirklich dran machen wird. Der Hauptentwickler von Prostats, war zuletzt im Feb 2019 auf mybb.com online.

Daher versuche ich ne Alternative oder vielleicht doch ein Entwickler dazu bewegen sich mal richtig dem Plugin Prostats ranzuwagen ;D

Falls ich im falschen Forum gepotet hab, bitte ich dieses zu entschuldigen und den Thread in das richtige Forum zu verschieben ;D
Greeetings

Bogus

GridTalk.de | Have a nice Day ;D
Zitieren
#2
(19.07.2019, 14:03)Bogus schrieb: Hallo zusammen ;D

Ich suche eine Alternative zu Prostats bzw. ein Plugin was auch wirklich PHP 7.x kompatibel ist. Die meisten Plugins, was ich bisher getestet hab, sind nicht oder nur zum Teil PHP 7.x kompatibel. Natürlich wäre es super, wenn das Prostats auf die 7.2.19 gefixed werden würde. Dazu hab ich auch schon ein Post im englischen forum gemacht, nur ich glaube nicht so recht dran, das sich da ein Entwickler bzw. der Hauptentwickler wirklich dran machen wird. Der Hauptentwickler von Prostats, war zuletzt im Feb 2019 auf mybb.com online.

Daher versuche ich ne Alternative oder vielleicht doch ein Entwickler dazu bewegen sich mal richtig dem Plugin Prostats ranzuwagen ;D

Hast du diese Version auch schon getestet?
https://www.mybb.de/erweiterungen/18x/pl...ats-fixed/

In der Beschreibung wird ja die PHP 7.2 Kompatibilität erwähnt.


(19.07.2019, 14:03)Bogus schrieb: Falls ich im falschen Forum gepotet hab, bitte ich dieses zu entschuldigen und den Thread in das richtige Forum zu verschieben ;D

Na gut  Wink
Zitieren
#3
(19.07.2019, 14:26)doylecc schrieb: Hast du diese Version auch schon getestet?
https://www.mybb.de/erweiterungen/18x/pl...ats-fixed/

In der Beschreibung wird ja die PHP 7.2 Kompatibilität erwähnt.

Ja hab ich, da wird die 7.2 erwähnt, aber mit zu welcher die dann kompatibel ist, das steht da nicht und ich hab mit der 7.2.18 / 19 Fehlermeldungen bekommen
Greeetings

Bogus

GridTalk.de | Have a nice Day ;D
Zitieren
#4
Welche Fehlermeldungen bekommst du denn?
Ich habe es mal unter PHP 7.3.7 getestet und bisher hatte ich keine Probleme damit. Eigentlich sollte es mit 7.2.19 dann auch laufen.
Zitieren
#5
wenn es mit der 2.19 laufen würde, würde ich nicht nach einer Alternative suchen ;D

Aber die 7.3er hab ich noch nicht getestet, das werde ich mal machen ;D

Nachtrag: Nun getestet mit der 7.3.5  wieder fehlermeldungen .. siehe Screenshot, das ist aber nur ein Teil ..

   
Greeetings

Bogus

GridTalk.de | Have a nice Day ;D
Zitieren
#6
Das magische Wort/Funktion ist isset. Bin leider in Urlaub vielleicht kann doylecc dir kurz nen Fix einbauen.
My  PHP-Version: 7.3.1 | MySQL-Version: 5.7.21
My  Plugins: See all
------
Es gibt nur 10 Arten von Menschen. Die, die binär verstehen - und die, die es nicht tun
Zitieren
#7
(19.07.2019, 21:54)itsmeJAY schrieb: Das magische Wort/Funktion ist isset. Bin leider in Urlaub vielleicht kann doylecc dir kurz nen Fix einbauen.

Hm..ich habe es mir noch mal etwas näher angesehen, so ein kurzer Fix mit ein paar isset() ist das gar nicht, da sind u.A. offenbar überall zwischendrin Variablen nicht richtig deklariert usw., das wird bei dem umfangreichen Code eine ziemliche Sucherei.
Dafür, dass das Plugin extra als PHP 7.2 kompatibel beworben wird, müsste eigentlich der Autor da nochmal Hand anlegen und etwas mehr Zeit investieren.
Zitieren
#8
(19.07.2019, 22:12)doylecc schrieb:
(19.07.2019, 21:54)itsmeJAY schrieb: Das magische Wort/Funktion ist isset. Bin leider in Urlaub vielleicht kann doylecc dir kurz nen Fix einbauen.

Hm..ich habe es mir noch mal etwas näher angesehen, so ein kurzer Fix mit ein paar isset() ist das gar nicht, da sind u.A. offenbar überall zwischendrin Variablen nicht richtig deklariert usw., das wird bei dem umfangreichen Code eine ziemliche Sucherei.
Dafür, dass das Plugin extra als PHP 7.2 kompatibel beworben wird, müsste eigentlich der Autor da nochmal Hand anlegen und etwas mehr Zeit investieren.

Oh okay, sorry. Hab mir nur die Fehlermeldung angesehen. Die kennt man ja vom rumcoden und rumtesten seit PHP 7 Big Grin
My  PHP-Version: 7.3.1 | MySQL-Version: 5.7.21
My  Plugins: See all
------
Es gibt nur 10 Arten von Menschen. Die, die binär verstehen - und die, die es nicht tun
Zitieren
#9
Halllo zusammen ;D

Manchmal sollte man die Dinge sich richtig anschaun ;D

Die Sache hat sich erledigt ;D Hab irgendwie die gefixed Version nicht richtig hochgeladen.

Naja Ende gut .,.. alles gut ;D Danke für eure Geduld und Support ;D Noch ein schönes Wochenende ;D
Greeetings

Bogus

GridTalk.de | Have a nice Day ;D
Zitieren


Möglicherweise verwandte Themen…
Thema Verfasser Antworten Ansichten Letzter Beitrag
  Seltsame Ausgabe bei Prostats Übersicht Bogus 25 396 23.07.2019, 18:34
Letzter Beitrag: Bogus
  Plugin "Welcome message" nicht kompatibel falcao1010 5 934 03.11.2016, 18:20
Letzter Beitrag: StefanT
  MyBB 1.8.5 kompatibel mit Plugins von 1.6.x? IGDGN 1 500 29.08.2015, 22:04
Letzter Beitrag: MrBrechreiz
  Prostats Design/ Breiten-Anpassung skrilaxrev 0 307 09.04.2015, 12:11
Letzter Beitrag: skrilaxrev
  Probleme mit ProStats (1.9.6) und MyBB 1.8.4 gmx 2 660 26.02.2015, 07:17
Letzter Beitrag: gmx