Hallo, Gast! (Registrieren)

Letzte Ankündigung: MyBB 1.8.27 veröffentlicht (22.06.21)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
PHP Sprachdatei wie/wo UTF8-ohne BOM definieren
#1
Hallo,

habe eine englische Sprachdatei ins Deutsche übersetzt. Im ACP werden nunmehr die Umlaut (Ää, Öö, Üü, ß)falsch dargestellt, dies obwohl die Datei in "UTF-8 ohne BOM" definiert ist. (Arbeite mit Notepad++)

Leider finde ich in der Konsole des Browsers nicht das zugehörige Template um UTF-8 zu definieren.

Hat mir jemand dazu einen Lösungsansatz? Danke vorab für jedwede Hilfe
Jammer nicht rum ...Du musst (k/m)eine Hilfe (nicht) annehmen!
MyBB: 1.8.27 | PHP: 7.4.19 | SQL: 5.7.34
Tools [Unixzeit ⇔ Realzeit] ♦ [BOM-Finder] ♦ [301] ♦ [SQL-Prefix-Changer] ♦ [USV-Rechner]
Zitieren
#2
In Templates musst du normalerweise nichts machen. Wahrscheinlich liegt es doch an der Sprachdatei.
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
Zitieren
#3
(17.01.2019, 18:03)StefanT schrieb: In Templates musst du normalerweise nichts machen. Wahrscheinlich liegt es doch an der Sprachdatei.
Notepad++ zeigt mir die Dateikodierung als "UTF-8" an, was somit korrekt wäre. Im Frontend werden alle Umlaute korrekt angezeigt. Was könnte Deine Aussage "Wahrscheinlich...." noch beinhalten?
Jammer nicht rum ...Du musst (k/m)eine Hilfe (nicht) annehmen!
MyBB: 1.8.27 | PHP: 7.4.19 | SQL: 5.7.34
Tools [Unixzeit ⇔ Realzeit] ♦ [BOM-Finder] ♦ [301] ♦ [SQL-Prefix-Changer] ♦ [USV-Rechner]
Zitieren
#4
Die Zeichencodierung muss im Header definiert sein, um die höchste Priorität zu haben.
Im Admin-Modul sehe ich im Header allerdings keinen Eintrag dazu.

Evtl. ist das ja zielführend.

Wie werden die Umlaute denn dargestellt? So ä, oder so ? (Beides ist Ä Wink )

Zitieren
#5
Um welches Plugin handelt es sich überhaupt?
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
Zitieren
#6
(18.01.2019, 09:40)StefanT schrieb: Um welches Plugin handelt es sich überhaupt?
Problem hat sich erledigt.

Ursache:
Trotz der Konvertierung mit Notepad++ in UTF-8 und abspeichern, wurde dies zwar die Datei als UTF-8 von Notepad++ angezeigt, aber nicht umgesetzt. Auch mehrmaliges Speichern brachte keine Änderung. Dies scheint ein Bug von Notepad++ zu sein.

Lösung:
Inhalt der PHP-Datei in eine "Neue" (mit Notepad++) erstellte Datei geschrieben (neue Dateien werden bei mir standardmäßig in UTF-8 erstellt) und abgespeichert. Dateiupload durchgeführt, und alle Umlaute wurden korrekt dargestellt.

Besten Dank die Hilfestellung, vllt. hilft auch Anderen vorstehende Erfahrung*.

*[Ärgert mich eh das manch MyBB-Fragesteller hier nach Hilfestellung ersuchen und wenn sie selbst die Lösung gefünden haben nur maximal schreiben "erledigt" (wenn überhaupt) und somit den anderen MyBB-Usern den Lösungsweg vorenthalten. Erkenne ich so etwas, bekommen von mir [i]solche MyBB-User danach keine Hilfestellung mehr, weil es sich um MyBB-User handelt, welche nur Nehmen aber nicht geben!][/i]
Jammer nicht rum ...Du musst (k/m)eine Hilfe (nicht) annehmen!
MyBB: 1.8.27 | PHP: 7.4.19 | SQL: 5.7.34
Tools [Unixzeit ⇔ Realzeit] ♦ [BOM-Finder] ♦ [301] ♦ [SQL-Prefix-Changer] ♦ [USV-Rechner]
Zitieren