Hallo, Gast! (Registrieren)

Letzte Ankündigung: MyBB 1.8.17 veröffentlicht (16.07.18)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
Logout-Problem eingegrenzt
#1
Hallo,
nachdem bei mir ein sehr spezielles Problem beim Logout aufgetaucht ist, konnte ich es eingrenzen und beheben.
Ich habe vor ein paar Tagen mein Forum mit der Version 1.8.14 aufgesetzt.
Bei den ersten Tests ist mir folgendes passiert.

Es scheint das gleiche Problem zu sein, welches hier berichtet wird:
https://www.mybb.de/forum/thread-33474.html
https://www.mybb.de/forum/thread-33245.html
aber auch ev. hier u.a.:
https://www.mybb.de/forum/thread-30654.html

Symptom:
Wenn ich mich als normaler Benutzer anmelde und auch direkt im ACP als Adminstrator anmelde, dann aus dem ACP > "Forum ansehen" wähle, dann komme ich auf die Seite, wo sich der angemeldete Benutzer gerade befindet, was logisch ist.
Aber jetzt ist es nicht möglich, dass sich der Benutzer abmeldet. Er bleibt angemeldet!
Auch wenn sich nun der Admin abmeldet aus dem ACP, funktioniert die Abmeldung des Benutzers nicht.
Auch Tab im Browser schließen, kurz warten, Forum wieder öffnen, und der Benutzer ist noch immer angemeldet!
Browser schließen, ein paar Minuten warten, Browser starten, Forum anwählen >>> Benutzer ist noch immer angemeldet und läßt sich nicht abmelden. Daher ist es auch nicht möglich, sich als ein anderer Benutzer anzumelden!

Lösung: Es wurde nach der Anmeldung des Benutzers vom admin ein Cookie-Prefix eingestellt.

Nachdem das alte Cookie "mybbuser" (ohne Prefix) gelöscht wurde, wird nunmehr ein "prefix_mybbuser" erstellt und das ist nur so lange vorhanden, wie die Anmeldung aktiv ist.

Annahme: Irgendwo im Code wird das Cookie-Prefix nicht berücksichtigt. Wahrscheinlich bei der Anmeldung.
Denn: Nur wenn bei der Anmeldung das [√] Merken aktiviert ist, dann wird dieses Cookie gesetzt und bei der Abmeldung wieder entfernt. Aber durch die Änderung, dh. setzen eines Cookie-Prefix, kann das Cookie ohne dem Prefix bei der Abmeldung ja nicht mehr entfernt werden.
Aber beim Wechsel auf die Startseite wird das Cookie abgefragt und entsprechend gehandelt: Wenn vorhanden, dann den User anzeigen als angemeldet. Es scheint so, dass hier das Prefix nicht berücksichtigt wird.

LG Wolfgang
Zitieren
#2
Cookies mit Präfix werden bevorzugt behandelt, Cookies ohne Präfix allerdings auch berücksichtigt. Dies ist so beabsichtigt, wie aus folgendem Kommentar hervorgeht: https://crossreference.mybb.de/inc/class....html#l349
PHP-Code:
// Fixes conflicts with one board having a prefix and another that doesn't on the same domain
// Gives priority to our cookies over others (overwrites them) 
Grundsätzlich ist es zu empfehlen nach einer Änderung der Cookie-Einstellungen die Cookies im Browser zu löschen, ansonsten sind Konflikte möglich (und teilweise auch unvermeidbar).
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
Zitieren
#3
Hallo,
wir haben auch das Problem.
Dachten ja erst es liegt an einem Testboard was auf Subdomain läuft, aber das wurde komplett gelöscht und die Probleme des ausloggens und einloggen über die obere Leiste funktioniert dennoch nicht.
Daher vermuten wir ein Bug?
Können wir dagegen was tun?

MfG Mo
Zitieren
#4
Bitte bleibe bei dem Thread, den du schon eröffnet hast. Ansonsten wird es unübersichtlich.
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
Zitieren