Hallo, Gast! (Registrieren)

Letzte Ankündigung: MyBB 1.8.19 veröffentlicht (11.09.18)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
Abmelden funktioniert nicht
#1
Hallo ihr Lieben,

leider funktioniert das Abmelden in unserem Forum nicht. Man klickt auf dem Button landet ganz normal auf dem Index und ist immer noch eingeloogt.

Folgende Maßnahmen habe ich unternommen, um das Problem zu lösen:

#1 Cookies und Cache im Browser gelöscht

#2 Cookiedaten in den Foreneinstellungen und vorher in der settings.php überprüft
Dabei habe ich festgestellt, dass ein Cookiepräfix eingestellt war, diesen habe ich rausgelöscht (in der php-Datei und in den Foreneinstellungen) und danach wieder Cookies und Cache des Browsers gelöscht.

#3 Im ACP habe ich eine Dateiüberprüfung durchgeführt, bei der rauskam, dass die member.php verändert ist (was jedoch von meiner Co-Admina geplant war und ich beim Durchsehen auch keinen Fehler entdeckt habe) und das die install/... Dateien alle fehlen. Was jedoch meiner Meinung nach auch kein Problem darstellen sollte, da man diese nach der Installation ja löschen sollte, zumindest meiner Erinnerung nach.

Leider hat nichts davon das Problem gelöst.

Die Cookiedaten habe ich hier zur Sicherheit überprüft, die sehen wie folgt aus:

PHP-Code:
$settings['cookiedomain'] = ".test.cityofdust.de";
$settings['cookiepath'] = "/";
$settings['cookieprefix'] = ""

Hat jemand eine Idee woran das liegen kann?

Vielen Dank im Voraus!

Ciddy

edit:

Ich habe grade noch eine Beobachtung gemacht...
Wenn ich mich in dem nicht Testforum abmelde und mich dann im Testforum abmelde, funktioniert es ohne Probleme. Wobei das sehr skurill ist, weil beide unabhängige Datenbanken haben und das Testforum eine Subdomain von dem eigentlichen Forum ist.

Ach und ich wollte/sollte noch den Link zum Forum posten.

http://test.cityofdust.de/index.php
Zitieren
#2
(10.03.2016, 19:06)Ciddy schrieb: Wenn ich mich in dem nicht Testforum abmelde und mich dann im Testforum abmelde, funktioniert es ohne Probleme. Wobei das sehr skurill ist, weil beide unabhängige Datenbanken haben und das Testforum eine Subdomain von dem eigentlichen Forum ist.
Das ist nicht skurril. Wink Die Cookies von deinem Haupt-Forum gelten auch für alle Subdomains, weshalb es dann im Test-Forum "konkurrierende" Cookies gibt. Das Forum kann dabei nicht erkennen, welche Cookies zu welchem Forum gehören. Daher ist zu empfehlen unterschiedliche Cookie-Präfixe zu setzen, sobald mehrere Forum unter der gleichen Domain betrieben werden.
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
Zitieren
#3
Jetzt wo du es sagst... woher soll das arme Forum es wissen, wenn ich es ihm nicht sage... zum Glück lernt man immer wieder was dazu.

Danke dir!


Hat super geklappt. =)
Zitieren


Möglicherweise verwandte Themen...
Thema Verfasser Antworten Ansichten Letzter Beitrag
  Abmelden funktioniert nicht 2.0 Ciddy 12 970 05.05.2016, 22:46
Letzter Beitrag: MrBrechreiz