Hallo, Gast! (Registrieren)

Letzte Ankündigung: MyBB 1.8.14 veröffentlicht (30.11.17)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
MySQL Erweiterungen
#1
Ich habe MySQL Installiert.ich versuche gerade myBb zu installieren.Alles Ist Installiert,aber er zeigt an:

MyBB benötigt mindestens eine installierte kompatible Datenbankerweiterung. Der Server gab zurück, dass keine zur Verfügung steht.

Welche Erweiterungen sind gemeint Und wie installiere ich sie?

LG BLOCKSTORM
Zitieren
#2
Es fehlt die MySQL-Erweiterung von PHP. Wie du diese installieren kannst, hängt vom Betriebssystem ab.
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
Zitieren
#3
Wir benutzen Debian 8
Zitieren
#4
Dann musst du das Paket php5-mysql installieren: https://packages.debian.org/jessie/php5-mysql
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
Zitieren
#5
Soll ich das mit apt-get install php5-mysqlnd installieren? Weil das habe ich und es geht imernoch nicht
Zitieren
#6
Vermutlich ist das Paket installiert, aber die PHP-Erweiterung noch nicht aktiviert. Die Einrichtung deines Servers geht übrigens etwas über allgemeinen MyBB-Support hinaus. Wink
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
Zitieren
#7
Sad Wie aktiviere ich die?
Zitieren
#8
Prüfen, ob das MySQL-Paket überhaupt installiert ist:
# dpkg-query -l
(hier sollte das Paket angezeigt werden)

Prüfen, ob die MySQL-Erweiterung in PHP aktiv ist:
# php -m
(hier sollte mysql als Erweiterung angezeigt werden)

Falls nicht aktiviert:
3. Wirf einen Blick in die php.ini und entferne dort die Maskierung (Semikolon am Anfang der Zeile) für die MySQL-Extension.
Danach einmal den Webserver neustarten (ob er meckert) und das sollte es gewesen sein.

[ExiTuS]
Zitieren