Hallo, Gast! (Registrieren)

Letzte Ankündigung: MyBB 1.8.19 veröffentlicht (11.09.18)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
nach update von 1.8.6. nach 1.8.7 fehler in disk.php line 14
#1
Hallo MyBB Freunde,

vorhin habe ich nach Prozess das Forum srx6-freun.de von 1.8.6 nach 1.8.7 gepachted. Alles hat, wie immer, einandfrei funktioniert. Leider kann ich nicht mehr die Seite srx6-freunde aufrufen. Es kommt ein error:

Fatal error: Declaration of diskCacheHandler::size_of() must be compatible with that of CacheHandlerInterface::size_of() in /hp/bo/ad/fu/www/mybb/srx6/inc/cachehandlers/disk.php on line 14

Ich habe bereits das update noch mal wiederholt und auch mal die Datei aus dem Full Package ersetzt - ohne Erfolg. Was kann getan werden, um das System wieder lauffähig zu machen?1

Gruß Chris

Nachtrag: in meiner Not habe ich die disk.php aus 1.8.4 eingespielt...geht erst mal wieder.

Gruß Chris
Zitieren
#2
Ich kann den Fehler nicht reproduzieren. Bitte stelle sicher, dass alle Dateien im Ordner inc/cachehandlers aktuell sind und keine Modifikationen enthalten.
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
Zitieren
#3
Info: auch die disk.php aus meiner letzen 1.8.6 Sicherung geht, die aus 1.8.7 nachvollziehbar NICHT.

ich kann KEINE Unterschiede feststellen, siehe Anhang.

Gruß Chris


Angehängte Dateien Thumbnail(s)
   
Zitieren
#4
Welche PHP-Version verwendest du?
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
Zitieren
#5
(24.03.2016, 15:49)StefanT schrieb: Welche PHP-Version verwendest du?

PHP Version 5.2.17
Zitieren
#6
Die Angabe ist ziemlich ungenau, das kann von 5.0.0 (was gar nicht unterstützt wird) bis 5.6.18 alles sein. Wink
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
Zitieren
#7
(24.03.2016, 15:56)StefanT schrieb: Die Angabe ist ziemlich ungenau, das kann von 5.0.0 (was gar nicht unterstützt wird) bis 5.6.18 alles sein. Wink

Du warst da wohl schneller als ich es genauer spezifizieren konnte. Musste erst mal abchecken, wie die php Version heraus zu bekommen ist: http://srx6-freun.de/version.php

Gruß Chris

ich mach mal ein update auf 5.6...und berichte....
Zitieren
#8
Mit PHP 5.2 kann ich das Problem tatsächlich nachstellen. Mit neueren PHP-Versionen tritt es dagegen nicht auf.
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
Zitieren
#9
(24.03.2016, 16:09)StefanT schrieb: Mit PHP 5.2 kann ich das Problem tatsächlich nachstellen. Mit neueren PHP-Versionen tritt es dagegen nicht auf.

cooles Ding und good to know! Kann man ja als known issue bzw. min. php 5.3 system requirement in die Doku einpflegen ;-), oder noch besser das update macht noch einen PHP Version check. danke für die schnelle Hilfe.

Gruß Chris
Zitieren


Möglicherweise verwandte Themen...
Thema Verfasser Antworten Ansichten Letzter Beitrag
  Update von 1.18.15 nach 1.18.17. Fehler "MyBB Error (42)" helmut54 0 138 16.08.2018, 15:34
Letzter Beitrag: helmut54
  Fehler nach Update von 1.8.10 auf 1.8.14 Raccoon 5 455 17.01.2018, 10:20
Letzter Beitrag: Raccoon
  Fehler nach Update von 1.8.0 auf 1.8.3 Draemer-Chan 1 405 14.12.2014, 14:08
Letzter Beitrag: StefanT