Hallo, Gast! (Registrieren)

Letzte Ankündigung: MyBB 1.8.12 veröffentlicht (22.05.17)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
Probleme mit eigenem 1.8-Template
#1
Hallo zusammen,

ich brauche mal wieder eure Hilfe.

Und zwar geht es um das Template für die neue 1.8. Ich habe mir die Software mal nebenbei installiert und will das Template jetzt passend zur Seite umgestalten. Eigentlich mache ich es mir dabei recht einfach: Ich nehme das Rahmentemplate meiner Seite, packe dieses ins Header- und Footertemplate und - von farblichen Anpassungen mal abgesehen - ist das Board mehr oder weniger einsatzbereit. So war es jedenfalls die letzten Jahre.

Nun gibt es aber Probleme...

*URL_gelöscht*

Wenn ihr die Installation aufruft, werdet ihr zwei Dinge feststellen: Zum einen ist das Hauptfenster links- und der Skyscraper-Banner rechtsbündig, zudem klafft im Contentbereich eine recht große Lücke.

Das Schlimme: Ich habe keine Ahnung, was da falsch läuft. Confused

Das Rahmentemplate entspricht 1:1 dem auf der Hauptseite, auf der ja alles soweit korrekt dargestellt wird. Daher muss das Ganze irgendwie mit dem Forencode bzw. vielmehr dessen CSS zusammenhängen. Ich finde da aber rein gar nichts...

Und diese Lücke liegt innerhalb des Forums am div-Container "panel". Nehme ich diesen raus, passt die Darstellung.

Habt ihr vielleicht einen oder mehrere Tipps für mich? Ich sehe den Wald vor lauter Bäumen nicht mehr... Undecided

Danke
bigfraggle
Zitieren
#2
Bei der CSS-Klasse .xa_xboxaktuell ist kein margin: 0 auto; angegeben, mit dem das Element zentrieren werden würde.
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
Zitieren
#3
(22.10.2014, 10:06)StefanT schrieb: Bei der CSS-Klasse .xa_xboxaktuell ist kein margin: 0 auto; angegeben, mit dem das Element zentrieren werden würde.

Nein, das ist es (leider) nicht. Der Container #xa_xboxaktuell soll ja auch nicht zentriert werden...

Im Grunde ist der Code bzw. das CSS ja auch ok, die eigentliche Seite wird ja korrekt dargestellt. Nur sobald ich das Forum in den Rahmen packe, wird das Layout zerrissen. Also muss dort irgendetwas zusammen nicht harmonisieren. Sad
Zitieren
#4
So, das Problem mit dem leeren Raum im Container "panel" konnte ich lösen. Da waren von Haus aus floats und clears, die das ganze gestört haben...

Bleibt noch die Frage, warum nur im Forum der Contentbereich links- und der Banner rechtsbündig sind.

Freue mich weiterhin über Tipps. Smile

Btw... So richtig gelungen finde ich das Standardtemplate inkl. CSS nicht. Also nicht optisch - das ist ok und kann man ja leicht ändern. Aber das Gerüst an sich eignet sich imo deutlich weniger, um daraus ein eigenes Template/Theme zu erstellen, als bei der alten Version. Allein schon CSS-Angaben wie min-width und max-width sollten für eine Vorlage vermieden werden...
Zitieren
#5
Wenn man ein eigenes theme erstellen will, sollten Kenntnisse in HTML und CSS Grundvoraussetzung sein.
Mit freundlichen Grüßen

MrBrechreiz
Zitieren
#6
Es sagt niemand etwas anderes...

Nur sollte ein Standardtemplate auch als Vorlage dienen und dem interessierten User ein gutes Beispiel sein. Und diesbezüglich war das 1.6er Template imo zumindest in Sachen CSS irgendwie besser.

Aber egal...  Wink

Wenn du dich mit CSS auskennst, kannst du mir ja vielleicht behilflich sein?

Danke! 
Zitieren
#7
Klar könnte ich das, wenn es die Zeit zulässt.
Mit freundlichen Grüßen

MrBrechreiz
Zitieren


Möglicherweise verwandte Themen...
Thema Verfasser Antworten Ansichten Letzter Beitrag
  Probleme mit 1.8er Popup Menüs bei eigenem Theme Jockl 0 280 23.11.2014, 12:37
Letzter Beitrag: Jockl
  Probleme mit eigenem Theme niftytimes 6 534 28.10.2014, 20:33
Letzter Beitrag: niftytimes
  Aus eigenem Profilfeld -> Button unterm Beitrag neben PN ToxSox 5 1.114 30.07.2009, 22:33
Letzter Beitrag: ToxSox
  Probleme mit eigenem Theme Kaba 5 1.087 08.05.2007, 20:28
Letzter Beitrag: krafdi