Hallo, Gast! (Registrieren)

Letzte Ankündigung: MyBB 1.8.12 veröffentlicht (22.05.17)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
WYSIWYG-Plugins sind nicht mehr installierbar/tauchen nicht auf
#1
Vermutlich muss ich in dem anderen Forum posten, aber ... ich hab schon das Gefühl ich bin zu doof, aber bei mir ist da kein Thread erstellen-Button!

Vielleicht seh ich aber schon den Wald vor lauter Bäumen nicht mehr, allerdings hier im Forum taucht er auf und darum poste ich hier. Nehmt es mir bitte nicht übel, aber ich dreh eh schon am Rad. Blush

Infos zu Plugins und Co.

Als Plugin hab ich mittlerweile nur noch SR MyBBCoder (1.5.0) drin - das war aber auch die ganze Zeit kein Problem. Das war von Anfang an drin, auch als es mit den WYSIWYG-Plugins noch keine Probleme gab.

PHP Version ist 5.4.26-nmm1

MySQL ist 5.6.17 i

Board ist 1.6-1.5

Kein Update/Upgrade wissentlich Big Grin durchgeführt.
Von keiner anderen Boardsoftware konvertiert.
Keine Fehlermeldung!


Vorgeschichte und Problem:

Ich habe mein Forum installiert und es war auch alles kein Thema, auch nicht als ich diverse WYSIWYG-Plugins installiert habe um zu gucken welches am besten für mich geeignet ist.

Ich habe keine Ahnung wie und warum, aber nachdem ich SCEditor WYSIWYG editor 1.0.9 installiert hatte und diverse Sachen ändern wollte am Design und der Grösse, muss ich irgendwas gemacht haben - wobei ich nicht mal weiß was genau (ich hatte zwischendurch Firebug an, kann ich mir damit etwas reingetextet haben?).

Jedenfalls kam nach dem Erstellen eines Posts am Ende immer:



[url=http://de.pinterest.com/pin/create/extension/][/url]


Ich habe dann versucht und geändert und überlegt und gesucht - vor allem wo sich dieser Pinterest-URL-Kram vielleicht im Template, script oder sonst wo versteckt.

Ich habe auch kein Pinterest als bbcode oder sonst etwas im Forum. Ich habe den Pinterest-Button nur in meinem Browser!

Irgenwann hab ich dann glaube ich auch den Wald vor lauter Bäumen nicht mehr gesehen, wie gesagt. Völlig genervt habe ich dann mal versucht die Plugins zu deaktiveren und schwupps - war der Text auch weg. Ich konnte ganz normal posten ohne das diese ominöse Zeug aufgetaucht ist.

Klug geschlussfolgert das ich also vermutlich beim ändern im SCeditor irgendwas unabsichtlich geändert habe.

Okay, ich also bei dem jeweiligen Plugin alles durch - nichts zu finden. Also WYSIWYG-Plugin wieder raus.

Da sah dann plötzlich der Editor etwas eigenwillig aus. Das Textfeld war ganz schmal und dünn. Das habe ich dann hinbekommen und auch dieses nervige Pinterest-Ding war weiterhin weg.

Ich voller Freude das erste WYSIWYG-Plugin wieder installiert. Alles war aktiviert und an. Aber es blieb nur der alte Editor da.  Überlegt ob ich mit dem Plugin nicht eh Probleme hatte und den SCeditor wieder installiert. Der ist ja d e f i n i t i v schon gelaufen, auch reibungslos.

Aber denkste! Immer nur der alte Original-Editor von MyBB 1.6.* da .... ich weiß nicht wie oft ich das jetzt versucht und auch immer kontrolliert habe ob es überall aktiviert ist - sowohl im ACP als auch bei den Plugins - aber ich kriege keinen WYSIWYG-Editor mehr zum Laufen. Habe noch einen versucht. Immer nur der Original-Editor.

Ich würde das Board ja einfach neu aufsetzen - es ist eh "nur" ein Spieleboard für unsere WG und bis auf die Foren und Kategorien, Teil vom Design und kleinen Änderungen und Smilies nichts drin, aber mir graut davor alle Einstellungen für das Design und so nochmal zu machen. Das war eh so schwierig rauszufinden wo ich da alles was ändern muss und ich bin mit den Nerven am Ende weil ich da jetzt seit drei Tagen dran rumtüftle was plötzlich mit dem Editor los ist. Sad

Ich hoffe das ist alles einigermaßen verständlich.

Ich wäre sehr dankbar wenn irgendjemand eine Idee hat! Danke für die Zeit und das ihr den Text lest. Ich wusste nicht wie ich ihn kürzer halten sollte. Blush
Zitieren
#2
Ist der entsprechende Editor denn in dem Theme auch als Editor ausgewählt? Das hab ich auch schon einmal übersehen und mich dann grün und blau geärgert.

Was mir noch einfällt: Bei den Editoren sind immer eine oder mehrere Dateien mit der Endung .js im Paket. Diese musst du auch mit hochladen. Sind diese mit auf dem Server?
Hast du denn einen Link zu dem Editor?
Zitieren
#3
Erst einmal vielen, vielen Dank das Du Dir echt die Mühe gemacht hast mein ganzes wirres Zeug zu lesen und zu helfen!!!! Wink Kurz vorne weg: Im Moment habe ich tatsächlich einen Plugin-Editor wieder zum Laufen gebracht.

Nach dem ich noch überall geguckt und gesucht habe und mal radikal im ACP aufgeräumt habe.

Da waren plötzlich in den Einstellungen nämlich teilweise Einstellmöglichkeiten von mindestens einem Editor noch vorhanden, obwohl alle Dateien ganz sicher gelöscht waren.
Und ein anderer Plugin-Editor hat scheinbar Editor-Template mitgebracht (war dann bei Templates und Style), das aber auch nur Fehlermeldungen produziert hat und noch da war, obwohl ich auch dem seinen Dateien 1:1 mit Zip-Paket Check und jede Datei einzeln löschen auf dem Server, gekillt hatte. (Allerdings habe ich danach auch erst diese zusätzliche Kategorie unter Templates entdeckt. Vermutlich hat er darum Fehlermeldungen gemacht. Wink )

Ich weiß noch nicht ob der Editor jetzt alles tut was er soll und ob das alles so richtig ist.
Beim Installieren hat er eine MSq-Fehlermeldung ausgegeben (irgendwas mit jquery) und dann bin ich da kurz weg weil ich den Einstellungen was gucken wollte (da tauchte er nämlich trotz Fehlermeldung auf), bin wieder hin zu Plugins und er war plötzlich installiert trotz Fehlermeldung und wollte nur noch mal aktiviert werden. Diese Meldung verunsichert mich natürlich, aber ich bin schon dankbar das ich ihn immerhin wieder sehe! Und die Meldung taucht auch gar nicht mehr auf. Big Grin

Ich musste zumindest für den aktuellen Editor
https://www.mybb.de/erweiterungen/16x/pl...yg-editor/
, der defintiv vorher auch schon mal gelaufen ist bis der Ärger anfing, nicht extra als Editor für ein Theme auswählen. Der ging einfach.

Aber bei den anderen, zumindest bei dem einen könnte es daran auch gelegen haben. Wenn Du magst und Zeit hast, kannst Du mir mal erklären wie genau das gemeint ist bzw. wie man das macht? Falls ich doch noch mal so bescheuert bin und diesen wechseln will  o b w o h l  er läuft. Wink

Die Javascript-Dateien waren alle mit übertragen, ja. Daran hätte es eigentlich nicht liegen dürfen.

Ich vermute also mal es hat durch diese "Leichen" im ACP dazu geführt das ich plötzlich nur noch den Standard-Editor sehen konnte. Warum mir teilweise diese Reste aber erst aufgefallen sind nachdem ich die Plugins wieder entfernt habe, ist mir ein Rätsel.

Soweit ist jetzt also erst einmal wieder alles klar. Nur das ich jetzt noch tausend Fragen zu den Einstellungen bei dem Editor habe, aber das mache ich besser in einem anderen Thread. Big Grin

Danke nochmal!

P.S. Scheinbar kann ich mich nicht kurz fassen. Wink
Zitieren
#4
Zum Ps:

Wenn Du eine Frau bist, ist das völlig normal, aber bist Du männlich, würde ich mir Gedanken machen. Smile
Mit freundlichen Grüßen

MrBrechreiz
Zitieren
#5
(27.08.2014, 01:48)MrBrechreiz schrieb: Zum Ps:

Wenn Du eine Frau bist, ist das völlig normal, aber bist Du männlich, würde ich mir Gedanken machen. Smile

Toungue Big Grin
Zitieren


Möglicherweise verwandte Themen...
Thema Verfasser Antworten Ansichten Letzter Beitrag
  In Der Downloadsektion sind plötzlich keine mehr Kategorien da ! Plexxart 5 1.157 28.10.2008, 15:20
Letzter Beitrag: Michael
  Habe von 1.2.9 auf 1212 upgedatet, nun sind alle Plugins weg Anke 10 2.003 02.02.2008, 17:04
Letzter Beitrag: Anke