Hallo, Gast! (Registrieren)

Letzte Ankündigung: Sicherheitsupdate: MyBB 1.8.29 veröffentlicht (30.10.21)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
Mein Board sendet keine Mails !?
#1
Hallo zusammen,
ich bin ganz neu hier und habe erst jetzt am Wochenende bei mir auf meinem Server das Board installiert. Das hat auch alles wunderbar geklappt, nur eben die Mailfunktion geht bei mir nicht. Weder PHP noch SMTP, was mich doch etwas stutzig macht.
Die PHP Version die ich bei mir drauf habe ist die 5.3.28, per SMTP bin ich einmal über 1und1 und ein zweites Mal über Yahoo! raus.
Jetzt bin ich am Ende mit meinem Latein und bitte um Hilfe !
Am liebsten wäre mir natürlich die PHP Variante, aber welche Voraussetzungen muss da der Server erfüllen ?

Bin für jeden Tipp sehr dankbar !
Umweltfreundlicher Beitrag, Daten aus 100 % Recyclingsbytes ...
#2
Hast Du schonmal die Suchfkt. benutzt? Zu dem Thema gibt es schon einige Threads, Lösungsvorschläge und auch Tutorials.
viele Grüße
Jockl
übersetzte und eigene Plugins
#3
Hallo jockl,
herzlichen Dank für deine schnelle Antwort !
Ja natürlich habe ich mir schon einen ganzen Haufen Beiträge dazu durchgelesen, bin jedoch auf keinen grünen Zweig gekommen.

Nach Eingabe von: MyBB was unable to send the email using the PHP mail() function.

bin ich zuletzt am Beitrag von Michael Malin hängen geblieben, der das in einem Tutorial beschreibt. Nur muss ich zu meiner Schande gestehen, weiß ich bei Schritt 2 nicht welche Datei gemeint ist, sonst wäre ich vielleicht auch schon etwas weiter.

Vielleicht habe ich auch meine Frage etwas dümmlich gestellt, weil eigentlich vermutete ich den Fehler auf meinem QNAP Server, der mir wahrscheinlich die Mailfunktion gar nicht zur Verfügung stellt (weil vielleicht nicht eingeschaltet) o.ä.
Eines verstärkt meine Vermutung dahingehend und zwar geht die PHP Mail Funktion bei Joomla zum Beispiel auch nicht, dort aber wenigstens die SMTP.

Jetzt habe ich aber mittlerweile so viel gelesen, dass ich langsam überhaupt keinen Plan mehr habe ...
Umweltfreundlicher Beitrag, Daten aus 100 % Recyclingsbytes ...
#4
Wenn PHP mail() nicht zur Verfügung steht, muss SMTP aktiviert werden. Die Einstellungen dafür stehen im Admin-CP zur Verfügung.
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
#5
(13.08.2014, 14:59)StefanT schrieb: Wenn PHP mail() nicht zur Verfügung steht, muss SMTP aktiviert werden. Die Einstellungen dafür stehen im Admin-CP zur Verfügung.

Das hatte ich anfänglich schon gemacht, ging aber auch nicht !?

Unable to connect to the mail server with the given details. Reason: 0:

Da habe ich exakt die Daten aus meinem E-Mail-Programm eingetragen, das läuft dann bei mir über 1+1, höchstens dies liegt da an der SSL Verschlüsselung
Umweltfreundlicher Beitrag, Daten aus 100 % Recyclingsbytes ...
#6
Dann ist scheinbar dein Mail Server nicht aktiv, wenn beide Varianten bei dir scheitern.
Mit freundlichen Grüßen

MrBrechreiz
#7
(15.08.2014, 01:23)krawinkel schrieb: Unable to connect to the mail server with the given details. Reason: 0:

Da habe ich exakt die Daten aus meinem E-Mail-Programm eingetragen, das läuft dann bei mir über 1+1, höchstens dies liegt da an der SSL Verschlüsselung

Bei mir funktioniert SMTP Versand über eine 1und 1 Adresse mit den Einstellungen:
SMTP Hostname - smtp.1und1.de
SMTP Port: 587
Sicheres SMTP: TLS-Verschlüsselung
#8
Wenn PHP keine vernünftige Fehlermeldung anbietet, liegt vermutlich ein Konfigurationsfehler vor. Manchmal wird versucht eine verschlüsselte Verbindung aufzubauen, obwohl SSL in PHP gar nicht aktiviert wurde.
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
#9
Hallo Waldo,
Treffer ... Versenkt ...

Ich habe jetzt TSL angeklickt und siehe da. In meinem E-Mail-Programm habe ich SSL angeklickt und da das ja immer funktionierte, wäre ich gar nie auf die Idee gekommen.

Also recht herzlichen Dank für diesen super Tipp !!!
Umweltfreundlicher Beitrag, Daten aus 100 % Recyclingsbytes ...


Möglicherweise verwandte Themen…
Thema Verfasser Antworten Ansichten Letzter Beitrag
  Keine Mails mehr Ich habe keine ahnung 4 948 23.05.2014, 08:23
Letzter Beitrag: Ich habe keine ahnung
  Bei Abbonierten Themen werden keine E-mails verschickt?! VisualBoard 11 2.741 30.01.2011, 13:31
Letzter Beitrag: VisualBoard