Hallo, Gast! (Registrieren)

Letzte Ankündigung: Sicherheitsupdate: MyBB 1.8.29 veröffentlicht (30.10.21)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
Löschung von Schlusszeilen im Template
#1
Einen Guten Abend zusammen.

Nachdem ich weder bei der Suche hier im Forum noch im weiteren Internet irgendetwas hilfreiches zu meinem Problem gefunden habe, melde ich mich jetzt hier.

Zuvor:
Forenadresse - http://www.cityofdust.de/
Forenversion - MyBB 1.6.13

Wenn ihr weitere Infos braucht, stelle ich euch diese gerne zur Verfügung^^

So jetzt zur Sache: Ich bearbeite im Augenblick das Template unserer Enzyklopädie. Das funktionierte Alles wunderbar, bis ich heute Mittag den bösen Fehler gemacht habe, zu versuchen einen Text aus einem Open Office Dokument in das Template zu kopieren. Als ich da nämlich auf "Speichern und Bearbeitung fortsetzen" geklickt habe, musste ich feststellen, dass nach dem eingefügten Text alle weiteren Zeilen des Templates gelöscht worden waren.
Alles wieder hergestellt, den Office Text in einen html Editor auf meinem Rechner kopiert und dann von dort übertragen. Das hat dann wunderbar geklappt.

Nun ja, da wir gerade im Umzug sind mit unserem Forum, wollte ich einen Text aus unserem alten Forum in das selbe Enzyklopädie Template kopieren. Und zwar in den unteren Bereich, auf den aber dennoch einige Zeilen folgen. Nun ja, ich hatte wieder das selbe Problem, dass nach dem Text der Rest gelöscht wurde. Allerdings wurde diesmal auch die Hälfte besagten Textes gelöscht.
Ich habe erneut die Lösung mit dem html Editor ausprobiert. Diesmal funktioniert aber auch das nicht. Ich war bei Zeile 724 - was ja nicht so wahnsinnig viel ist. Ich kann mir kaum denken, dass das Template da schon Schluss macht. Besonders nachdem ich Alles etwas komprimiert habe, auf 707 Zeilen kam und es dann erneut die Schlusszeilen gelöscht hat inklusive des Textes, diesmal jedoch bei einem anderen Wort mitten im Satz abgehackt.

Ich kann keinerlei System daraus ersehen und kann mir höchstens denken, dass die Einstellungen des Open Office Textes von heute Mittag mir noch immer einen Strich durch die Rechnung machen und die Zeilenumbrüche da mit mir würfeln. Aber anders kann ich mir das nicht erklären.

Kann mir jemand helfen oder hatte dieses Erlebnis auch schon? Vielleicht stelle ich mich auch einfach zu dumm an. Aber ich würde mich sehr über Hinweise freuen, da ich jetzt das Template natürlich auch nicht weiter bearbeiten kann.

Ganz liebe Grüße und schon mal vielen Dank,
Cid
Zitieren
#2
In den meisten fällen liegt dies an den Leerzeichen die das MyBB so nicht übernimmt, und entweder alles im Template löscht oder nur Teile danach oder davor.

Welchen Editor verwendest Du zum Zwischenspeichern ?
Mit freundlichen Grüßen

MrBrechreiz
Zitieren
#3
Bei Problemen beim Bearbeiten von Templates empfiehlt sich Codepress im Admin-CP zu deaktivieren.
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
Zitieren
#4
Hallo MrBrechreiz,

danke dass du dich meiner so schnell annimmst =)

Ich verwende zum zwischenspeichern den Dreamweaver. Die Leerzeichen klingen plausibel. Frage ist nur, wie werde ich das Problem wieder los? Gibt es noch eine andere Möglichkeit den Text irgendwo zwischen zu speichern und so die Formatierung zu ändern? Denkst du, es als txt Datei abzuspeichern würde etwas bringen?

Liebe Grüße,

Cid

Entschuldigt bitte den Doppelpost:
EDIT: @StefanT: Das werde ich mir gleich mal genauer ankucken, danke sehr
EDIT: @StefanT: Ich habe jetzt CodePress deaktiviert und es erneut versucht. Leider hat sich nichts geändert. Immernoch dieses seltsame Phänomen und wieder hat er es ganz wilkürlich mitten in einem Wort abgeschnitten.
Zitieren
#5
Magst Du uns Deine Templateeinträge hier zeigen, die Du versuchst einzufügen ?

Nachtrag:

Wenn ja, dann bitte als Anhang Big Grin
Mit freundlichen Grüßen

MrBrechreiz
Zitieren
#6
Ja, natürlich. Das Template besteht ja schon. Da das relativ lang ist, gehe ich davon aus, dass du das nicht unbedingt einsehen möchtest =D

Den Text, den ich einfügen möchte, habe ich jetzt als txt Datei im Anhang drin. Wie gesagt: eigentlich handelt es sich dabei um einen ganz normalen Foreneintrag.


Angehängte Dateien
.txt   Zusammenfassung.txt (Größe: 4,08 KB / Downloads: 7)
Zitieren
#7
Bei mir übernimmt er alles aus Deiner txt, ohne das er einen cut setzt.

Hast Du zufällig ein Plugin installiert, das Beiträge nach x Zeichen aufhören ?
Mit freundlichen Grüßen

MrBrechreiz
Zitieren
#8
Ist dein Template vielleicht einfach insgesamt zu groß/lang? Ich weiß gerade nicht welcher Typ das in der Datenbank ist, aber wenn du Pech hast ist bei 64kb pro Template Schluss (genauso wie bei Forenbeiträgen).
Zitieren
#9
Wenn es mit der Größe des Tabelleninhaltes zusammenhängen sollte, wie frostschutz vermutet, dann müsste man vermutlich den Typ "text" u.U. in "longtext" ändern. Welche Auswirkungen das auf MyBB an sich hat, kann ich aber leider nicht beurteilen.
viele Grüße
Jockl
übersetzte und eigene Plugins
Zitieren
#10
also bei mir wird der text auch ohne wenn und aber übernommen. weiss jetzt nicht ob dies relevant ist, aber sowas ähnliches hatte ich schon mal im acp, seitdem wenn ich alles mit einem editor (hier emditor) mache, dann keinerlei probleme. der text dort war erheblich kürzer.
Mit freundlichen Grüßen



Für etwaige Tipps, Vorschläge oder Anleitungen von mir gebe ich keine Gewähr. Die Durchführung erfolgt auf eigene Gefahr!
Zitieren


Möglicherweise verwandte Themen…
Thema Verfasser Antworten Ansichten Letzter Beitrag
  E-mail an User bei löschung (prune) me.lina 3 981 06.10.2012, 19:54
Letzter Beitrag: borsti67
  Benutzername im Warnungs-Protokoll nach Löschung k4Zz 4 1.470 26.07.2010, 10:08
Letzter Beitrag: k4Zz
  Problem nach Löschung von Plugin the_hole 1 1.033 03.04.2009, 08:53
Letzter Beitrag: linwinman
  Alte Themen auto. Löschung? Bartlomiej 3 1.438 15.05.2008, 16:49
Letzter Beitrag: Michael