Hallo, Gast! (Registrieren)

Letzte Ankündigung: MyBB 1.8.12 veröffentlicht (22.05.17)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
First Post/PM Preview
#41
Kann ich mir nicht vorstellen, dass es mit dem PN Button zu tun hat. Dieses Plugin greift an völlig unterschiedlichen Stellen an und kommt mit der Vorschau gar nicht in Berührung.
Ich habe es gerade auch noch einmal zusammen problemlos getestet.

Du hattest ja einige Änderungen an dem Plugin vorgenommen, zB den "Weiterlesen" Link. Wie sieht denn die URL genau aus, bei der dieser Fehler auftritt, wenn du auf Weiterlesen klickst?
Zitieren
#42
Code:
http://www.xxx.de/Thread-LA-STRADA-Internationales-Festival-der-Sta%C3%9Fenk%C...%3Cp%3E%3Ca%20href=

sorry, mein fehler... es geht anscheinend. man sollte sich nicht selber was empfehlen. aber der link erscheint nicht in der vorschau, sondern nur weiterlesen. muss dies so sein? thx
Mit freundlichen Grüßen



Für etwaige Tipps, Vorschläge oder Anleitungen von mir gebe ich keine Gewähr. Die Durchführung erfolgt auf eigene Gefahr!
Zitieren
#43
Es wird dadurch entstehen, dass der in der PN enthaltene Link abgeschnitten wird und mit dem "Weiterlesen" Link durcheinandergewürfelt wird.

Versuche mal Folgendes.

ändere diesen Teil:
PHP-Code:
if (!empty($mybb->settings['firstpreview_length']) && $mybb->settings['firstpreview_length'] != "0" && my_strlen($pm['message']) > (int)$mybb->settings['firstpreview_length'])
{
    
$pm['message'] = my_substr($pm['message'], 0, (int)$mybb->settings['firstpreview_length']).'...<p><a href="private.php?action=read&amp;pmid='.(int)$pm['pmid'].'">Weiterlesen</a></p>';


zu:

PHP-Code:
if (!empty($mybb->settings['firstpreview_length']) && $mybb->settings['firstpreview_length'] != "0" && my_strlen($pm['message']) > (int)$mybb->settings['firstpreview_length'])
{
    
$pm['message'] = preg_replace("!<a([^>]+)>!isU"""$pm['message']);
    
$pm['message'] = str_replace("</a>"""$pm['message']);
    
$pm['message'] = my_substr($pm['message'], 0, (int)$mybb->settings['firstpreview_length']).'...<p><a href="private.php?action=read&amp;pmid='.(int)$pm['pmid'].'">Weiterlesen</a></p>';

Zitieren
#44
scheint zu funktionieren, nur das halt das x verschwunden ist zum schließen...
Mit freundlichen Grüßen



Für etwaige Tipps, Vorschläge oder Anleitungen von mir gebe ich keine Gewähr. Die Durchführung erfolgt auf eigene Gefahr!
Zitieren
#45
Wirklich? Bei mir ist er noch vorhanden.
Du hast den Button nicht zufällig deaktiviert in den Einstellungen?
Zitieren
#46
nein, hatte ich natürlich nicht vergessen... doch, war mein fehler. funktioniert alles perfekt nun.
Mit freundlichen Grüßen



Für etwaige Tipps, Vorschläge oder Anleitungen von mir gebe ich keine Gewähr. Die Durchführung erfolgt auf eigene Gefahr!
Zitieren
#47
edit, da eigene dummheit....
Mit freundlichen Grüßen



Für etwaige Tipps, Vorschläge oder Anleitungen von mir gebe ich keine Gewähr. Die Durchführung erfolgt auf eigene Gefahr!
Zitieren
#48
wo trage ich ein, dass ich bei der thread-voransicht einen rahmen habe. den vermisse ich iwie. und wäre es möglich in der vorschau bilder auf ein vorgegebenes maß zu verkleinern?
Mit freundlichen Grüßen



Für etwaige Tipps, Vorschläge oder Anleitungen von mir gebe ich keine Gewähr. Die Durchführung erfolgt auf eigene Gefahr!
Zitieren
#49
Beides kannst du entsprechende Werte in der global.css deines Themes hinzufügen.
Als Beispiel ein 5px breiter schwarzer Rahmen und Vorschaubilder nicht breiter als 200px:

Code:
.modal_firstpost img {
    max-width: 200px;
}

.modal_firstpost {
    border: 5px solid #000 !important;
}
Zitieren
#50
cool, danke.
Mit freundlichen Grüßen



Für etwaige Tipps, Vorschläge oder Anleitungen von mir gebe ich keine Gewähr. Die Durchführung erfolgt auf eigene Gefahr!
Zitieren


Möglicherweise verwandte Themen...
Thema Verfasser Antworten Ansichten Letzter Beitrag
  Portal News Preview MyBB.de Bot 0 436 13.01.2016, 07:20
Letzter Beitrag: MyBB.de Bot
  Moderation Actions Preview MyBB.de Bot 1 304 02.04.2015, 18:00
Letzter Beitrag: MyBB.de Bot
  First Post Only MyBB.de Bot 6 692 09.10.2014, 17:06
Letzter Beitrag: TelCont@r
  First Post Only MyBB.de Bot 2 434 05.10.2014, 09:20
Letzter Beitrag: Jockl
  OUGC Unquote First Post MyBB.de Bot 0 293 22.09.2014, 03:15
Letzter Beitrag: MyBB.de Bot