Hallo, Gast! (Registrieren)

Letzte Ankündigung: MyBB 1.8.8 veröffentlicht (17.10.16)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
DB backup
#1
hi, ich möchte von meinem jetzigen 1.18 Forum ein db backup machen. jetz bin ich in die Datenbank per phpmyadmin reingegangen und hab auf "exportieren" geklickt.

Jetzt ist meine Frage, ob ich da rechts noch irgendwas selektieren muss also: zb

Mit 'DROP TABLE'
Mit 'IF NOT EXISTS'

Mein Ziel ist es, bei einer Neuinstallation eines 1.18 Forums die Daten des neuinstallierten Forums mit den alten zu überschreiben.

achja, weiß jemand, wo man noch die 1.18 version runterladen kann?

gruß
www.prowestlich.de.gg
Die Plattform für Politik- und Wirtschaftsdiskussionen.
#2
Wenn du vorhandene Tabellen überschreiben willst muß bei 'DROP TABLE' das häkchen gesetzt sein


--> Download myBBoard_v1.1.8

//Edit:
Link fixed
Gruß NetHunter
#3
NetHunter schrieb:Wenn du vorhandene Tabellen überschreiben willst muß bei 'DROP TABLE' das häkchen gesetzt sein


--> Download myBBoard_v1.1.8

download geht nicht:

Zitat:Sorry, but you have followed an invalid link. We were unable to find the download you requested in the database.

zur DB: aber ich könnte doch auch theoretisch beides selektieren, oder? weil das ja "if not exist" heißt. und wenn ich ein generelles db backup machen möchte wäre, beides doch sicher besser, damit für alle fälle gerüstet ist, oder?

gruß
www.prowestlich.de.gg
Die Plattform für Politik- und Wirtschaftsdiskussionen.
#4
http://www.mybboard.com/downloads/?actio...2&type=zip

Gruß,
Michael
[Bild: banner.png]
Support erfolgt NUR im Forum!
Bitte gelöste Themen als "erledigt" markieren.
Beiträge mit mangelhafter Rechtschreibung/Grammatik werden kommentarlos gelöscht.
#5
danke, aber nochmal zur DB:

egal wie ich es mache: ich bekomme immer eine fehlermeldung. You have an error in your sql syntax.

wie macht ihr das denn, wenn ich ein backup macht.

gruß
www.prowestlich.de.gg
Die Plattform für Politik- und Wirtschaftsdiskussionen.
#6
Die Fehlermeldung geht sicher noch weiter und sagt dir wo, also in welcher Zeile der Fehler liegt.
Gruß NetHunter
#7
NetHunter schrieb:Die Fehlermeldung geht sicher noch weiter und sagt dir wo, also in welcher Zeile der Fehler liegt.


Zitat:#1064 - You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near 'DEFAULT CHARSET=latin1' at line 26

aber ich mein, ich hab einfach nur die gzip datei aus der einen datenbank in die andre importiert, ohne veränderung.

gruß
www.prowestlich.de.gg
Die Plattform für Politik- und Wirtschaftsdiskussionen.
#8
Zitat:aber ich mein, ich hab einfach nur die gzip datei aus der einen datenbank in die andre importiert, ohne veränderung.
Haben die beiden Datenbanken den gleichen Syntax/Namen ?

bis gli...
greetz DaStaFlexX
#9
DaStaFlexX schrieb:Haben die beiden Datenbanken den gleichen Syntax ?

bis gli...
greetz DaStaFlexX

keine Ahnung, weiß nicht wie man das feststellte oder ändert.

gruß
www.prowestlich.de.gg
Die Plattform für Politik- und Wirtschaftsdiskussionen.
#10
Bei mir sieht es so aus:
Zitat:-- phpMyAdmin SQL Dump
-- version 2.6.3-pl1
-- http://www.phpmyadmin.net
--
-- Host: localhost
-- Generation Time: Sep 06, 2006 at 12:28 PM
-- Server version: 4.0.27
-- PHP Version: 4.3.11
--
-- Database: `deineDB_forum1`--

Wenn ich jetzt diese DB in eine andere einfüge, dann muss ich:
Database: `deineDB_forum1`
ändern in z.B.
Database: `deineDB_forum2` - Halt so wie die neue DB heisst !

bis gli...
greetz DaStaFlexX