Hallo, Gast! (Registrieren)

Letzte Ankündigung: MyBB 1.8.8 veröffentlicht (17.10.16)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
Keinen Zugriff auf manche Einstellungen seit Upgrade auf 1.2
#1
Hi!

Wenn ich z.B. versuche im AdminCP auf den Bereich "Admin Permissions" zuzugreifen, kommt folgender Fehler:

Code:
You do not have permission to access this part of the administration control panel.

Das gleiche gilt für das Managen der Language Packs und bestimmt noch andere Bereiche..

Kann mir da jemand helfen?

Gruß veryxRV
#2
Gehe per phpMyAdmin in die Datenbanktabelle adminioptions und ändere alle Berechtigungen bei deiner Benutzer-ID auf "yes".

Gruß,
Michael
[Bild: banner.png]
Support erfolgt NUR im Forum!
Bitte gelöste Themen als "erledigt" markieren.
Beiträge mit mangelhafter Rechtschreibung/Grammatik werden kommentarlos gelöscht.
#3
Erstmal danke für die schnelle Antwort Smile

Ich habe eine Benachrichtigungsmail über eine Antwort von Rowter bekommen, aber hier im Forum steht die Antwort nicht ^^ Er meint irgendetwas von der Config.php , mehr steht in der E-Mail nicht... na ja..

Das Problem ist, ich kenn mich mit phpMyAdmin nicht so sonderlich aus und verstehe da nicht so genau wie ich das setze ^^
#4
Führe bitte folgenden Query aus:
Code:
UPDATE mybb_adminoptions SET caneditaperms = 'yes' WHERE uid = '1';
Ggf. musst du das Präfix und die Benutzer-ID anpassen.

Wie du einen Query (SQL-Befehl) ausführst steht hier: https://www.mybb.de/doku/index.php?title=SQL-Dump

Gruß,
Michael
[Bild: banner.png]
Support erfolgt NUR im Forum!
Bitte gelöste Themen als "erledigt" markieren.
Beiträge mit mangelhafter Rechtschreibung/Grammatik werden kommentarlos gelöscht.
#5
Okay danke Smile

EDIT: Hat leider nichts gebracht ..
#6
Bitte schicke einen Dump der Tabelle adminoptions an support[at]mybboard[punkt]de. Wie du einen Dump erstellst findest du auch unter oben genanntem Link.

Gruß,
Michael
[Bild: banner.png]
Support erfolgt NUR im Forum!
Bitte gelöste Themen als "erledigt" markieren.
Beiträge mit mangelhafter Rechtschreibung/Grammatik werden kommentarlos gelöscht.
#7
Bei mir is das selbe problem hier mein dump

Code:
INSERT INTO `mybb_adminoptions` VALUES (0, '', '', 1, 'yes', 'yes', 'yes', 'yes', 'yes', 'yes', 'yes', 'yes', 'yes', 'yes', 'yes', 'no', 'yes', 'yes', 'yes', '1', 'yes', 'yes');
INSERT INTO `mybb_adminoptions` VALUES (1, '', '', 1, 'yes', 'yes', 'yes', 'yes', 'yes', 'yes', 'yes', 'yes', 'yes', 'yes', 'yes', 'yes', 'yes', 'yes', 'yes', '1', 'yes', 'yes');

EDIT//
Wärend ich es abgesendet habe hat sich das Problem erledigt (zu mindest was den bereich anging wo es bei mir kam

die Lösung einfach ausführen
Code:
UPDATE `mybb_adminoptions` SET `caneditlangs` = 'yes' WHERE `uid` =1 LIMIT 1 ;
Gruss
Silaz

RTFM | BlackStyle | Soulrockers
#8
Ups........^^


Is es ja doch gepostet worden.....


Ja...nun...Kopiere mal deine config.php von deinem Server runter


Diesen Code habe ich im meiner Config.php stehen

Code:
<?php
/**
* Daatabase configuration
*/

$config['dbtype'] = 'mysql';
$config['hostname'] = 'localhost';
$config['username'] = 'XXX';
$config['password'] = 'XXX';
$config['database'] = 'XXX';
$config['table_prefix'] = 'XXX';

/**
* Admin CP directory
*  For security reasons, it is recommended you
*  rename your Admin CP directory. You then need
*  to adjust the value below to point to the
*  new directory.
*/

$config['admin_dir'] = 'admin';

/**
* Hide all Admin CP links
*  If you wish to hide all Admin CP links
*  on the front end of the board after
*  renaming your Admin CP directory, set this
*  to 1.
*/

$config['hide_admin_links'] = 0;

/**
* Data-cache configuration
*  The data cache is a temporary cache
*  of the most commonly accessed data in MyBB.
*  By default, the database is used to store this data.
*
*  If you wish to use the file system (inc/cache directory)
*  you can change the value below to 'files' from 'db'.
*/

$config['cache_store'] = 'db';

/**
* Super Administrators
*  A comma separated list of user IDs who cannot
*  be edited, deleted or banned in the Admin CP.
*  The administrator permissions for these users
*  cannot be altered either.
*/

$config['super_admins'] = '2';

?>
Wobei das "XXX" meiner persöhnlichen Daten entspricht....Setzte dann halt mal deine Daten ein
Probier das mal bei dir bitte Smile
Vielleicht geht´s ja Smile


Mfg

Rowter


Ich habe bei mir diesen Code

Code:
$config['super_admins'] = '2'
weil ich ein Backup eingefügt hab und mit dem User arbeite der die Nummer "2" hat..

Also wenn du MyBB nur installiert hast, müsste der Code so lauten

Code:
$config['super_admins'] = '1'



Jetzt müsstest du eigentlich wieder alles können Smile
Mit freundlichen Grüßen
Mercedo

Luke, I´m your father


Die Deutsche Sprache ist Freeware und nicht OpenSource!
Das heißt du darfst sie benutzen, aber nicht verändern!
#9
Öffnet mal bitte die Datei inc/config.php und sucht den Eintrag $config['super_admins']. Steht dahinter eure Benutzer-ID? Falls nicht, tragt diese bitte ein und guckt ob es funktioniert.

Gruß,
Michael
[Bild: banner.png]
Support erfolgt NUR im Forum!
Bitte gelöste Themen als "erledigt" markieren.
Beiträge mit mangelhafter Rechtschreibung/Grammatik werden kommentarlos gelöscht.
#10
Ja da steht meine Benutzer ID


Möglicherweise verwandte Themen...
Thema Verfasser Antworten Ansichten Letzter Beitrag
  Probleme mit der Umfrage - manche können nicht abstimmen Laello 2 952 19.05.2008, 18:49
Letzter Beitrag: Laello
  Kein Zugriff auf Forum/Zugriff auf Admin vorhanden Doolay 0 672 25.02.2008, 10:41
Letzter Beitrag: Doolay
Question Manche Gäste können Threads lesen?! Lo$tY 2 810 31.07.2007, 19:08
Letzter Beitrag: Lo$tY
  Seit dem Upgrade auf 1.2.3. wichtiges Unterforum unsichtbar Ishiro 7 936 26.04.2007, 07:09
Letzter Beitrag: kow
  Datenbank Backup Problem seit Upgrade freeze 3 692 09.04.2007, 16:24
Letzter Beitrag: Michael