Hallo, Gast! (Registrieren)

Letzte Ankündigung: MyBB 1.8.19 veröffentlicht (11.09.18)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
Keiner kann sich einloggen...
#1
Ich hab gerade ein schnaeppchenforum mit myBB gestartet aber seit heute Morgen kann sich keiner mehr einloggen (ich als admin eingeschlossen).

Nachdem sich ein paar User beschwerten, dass sie nach Registrierung nur "Gast" waren, habe ich mal einen Test-Account erstellt, den aktiviert (bis dahin war alles okay) und mich damit anmelden wollen.

Weil das nicht klappte, habe ich alle Cookies im Browser gelöscht und ... kann mich nun auch nicht mehr als Admin einloggen.

Das sieht so aus: Username + Passwort eingeben, dann abschicken, dann Meldung "Sie haben sich erfolgreich eingeloggt.
Sie werden jetzt zu Ihrem letzten Aufenthaltsort weitergeleitet."

und ... "Hallo, Gast"
Kann es sein, dass es mit dem verwendeten Theme zusammenhängt?
Das scheint ein bekanntes Problem zu sein (und mit den Cookie-Einstellungen zusammen zu hängen):

https://www.mybb.de/doku/haeufig-gestell...elden.html

https://www.mybb.de/forum/thread-19982.html

https://www.mybb.de/forum/thread-20119.html

Der gesetzte Cookie im Firefox geht auf schnaeppchenforum.com, die verwendete Domain im Firefox ist auch ohne "www.". Leider komme ich auch als admin nicht mehr ins Forum, weshalb ich auch die Einstellungen nicht mehr ändern kann.
#2
So auf den ersten Blick sind eigentlich keine Fehler zu sehen; die Cookie-Einstellungen stimmen. Funktioniert es mit dem Standard-Theme?

Vielleicht hilft auch das weiter: https://www.mybb.de/forum/thread-9756-po...l#pid71040

Änderungen an den Einstellungen, kannst du auch manuell in der Datei "inc/settings.php" vornehmen.
 
The User, Formerly Known As "En-Gedi"
 
#3
An einer Datei habe ich tatsächlich geschraubt...

Zur inc/settings.php:
Zitat:"DO NOT EDIT THIS FILE, PLEASE USE
THE SETTINGS EDITOR"
Big Grin
Dort steht:
Zitat:$settings['cookiedomain'] = ".schnaeppchenforum.com";

sollte ich das auf

Zitat:$settings['cookiedomain'] = "/.";
bzw
Zitat:$settings['cookiedomain'] = "http://schnaeppchenforum.com/.";

ändern?

https://www.mybb.de/doku/haeufig-gestell...elden.html
#4
(30.09.2008, 11:41)reichweite.de schrieb: Zur inc/settings.php:
Zitat:"DO NOT EDIT THIS FILE, PLEASE USE
THE SETTINGS EDITOR"
Big Grin

Ausnahmen bestätigen die Regel Wink

Die Cookie-Einstellungen musst du nicht ändern, da diese ja korrekt sind.

Versuch´ als erstes mal, ob es mit dem MyBB-Standard-Theme funktioniert, um einen evtl. Fehler im Theme auszuschließen.

Geht es dann immer noch nicht, lade das Original der von dir geänderten Datei hoch (Sicherungskopie der Änderung erstellen).

Mal sehen, was dann passiert ...
 
The User, Formerly Known As "En-Gedi"
 
#5
So, die geänderte Datei ist wieder mit dem Original überschrieben...

Aktuell steht in der settings.php:
$settings['cookiedomain'] = ".schnaeppchenforum.com";
$settings['cookiepath'] = "/.";

Status: kann mich nicht anmelden.

Ah, eine Antwort. Wie kann ich denn wieder auf das Default-Theme umstellen? Steht das auch in der settings.php?
Aha, ich kann mich wieder anmelden, damit ging's:

settings.php:
$settings['cookiedomain'] = ".schnaeppchenforum.com";
$settings['cookiepath'] = "/";

obwohl ja in der FAQ "/." empfohlen wird...
DANKE!
#6
Arrrgh ... hattest du den Punkt bei "cookiepath" schon immer drin? Den hab´ ich glatt übersehen ... Schande über mein Haupt
 
The User, Formerly Known As "En-Gedi"
 
#7
(30.09.2008, 12:05)reichweite.de schrieb: obwohl ja in der FAQ "/." empfohlen wird...
Wo steht da etwas davon, dass beim Pfad ein Punkt hin soll?
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
#8
Hier steht's:
https://www.mybb.de/doku/haeufig-gestell...elden.html

Aber es könnte auch das Satzzeichen sein Wink
Ich muss En-Gedi noch einen dicken Schmatz für seine Hilfe geben, auf die fehlenden Icons wäre ich nie gekommen. Ich dachte, das Theme wäre so ätzend mit Textlinks, hehe.

Jetzt muss ich nur noch die Stelle finden, wo man die Uhrzeit für Gäste einstellen kann.

Und, by the way: ich finde myBB ziemlich klasse, bereue trotz der Schwierigkeiten heute (Userlimit auf 5 gesetzt, keiner konnte sich anmelden) nicht die Wahl zu myBB! Wem auch immer hier das Lob gut tut...
#9
Da hast du tatsächlich das Satzzeichen mit erwischt Wink

Zur Uhrzeit: Admin-CP --> Konfiguration --> Einstellungen --> Datums- und Zeitformat"

Dort dann "Standard-Zeitzone" auf GMT+1 und darunter die "Sommerzeitkorrektur" aktivieren.
 
The User, Formerly Known As "En-Gedi"
 


Möglicherweise verwandte Themen...
Thema Verfasser Antworten Ansichten Letzter Beitrag
  User kann sich nicht einloggen Loqi-X 29 4.373 26.07.2009, 22:35
Letzter Beitrag: Waluigi
  Man kann sich nicht mehr einloggen! Hecktro 9 1.880 10.05.2009, 17:08
Letzter Beitrag: Hecktro
  User kann sich nicht mehr einloggen Rubin 15 3.600 01.04.2009, 14:00
Letzter Beitrag: Ich habe keine ahnung
  Nach Merge von PhpBB3 kann sich niemand einloggen Solution 2 918 08.02.2009, 22:15
Letzter Beitrag: Solution
  Benutzer kann sich nicht einloggen safari 2 1.133 04.02.2009, 19:39
Letzter Beitrag: safari