Hallo, Gast! (Registrieren)

Letzte Ankündigung: MyBB 1.8.8 veröffentlicht (17.10.16)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
Fehler 550 No such User
#1
Hallo

ich bekomme beim Mailversand aus dem Board eine Fehlermeldung
SMTP Error 550 No such user in c:\Programme\apache\htdocs\forum\inc\function.php in Zeile 194

Wenn ich in diese Datei reinschaue ist doch kein User eingetragen sondern der Verweis auf den user der die Mail aus dem Board versendet, was ja auch richtig wäre. Auf einen anderen Server mit gleicher function.php geht es aber problemlos. Habe beide Function.php schon gegeneinander getauchst aber ohne erfolg. Was kann das noch sein?????

Hat jemand ne idee????

Ich benutze die Standard Mail funktion von php und habe als smtp server den lokalen Server eingetragen auf dem Tobit als Mailserver läuft.

Gruß

Joe
#2
Da stimmen die mail-Einstellungen vom Server nicht.
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
#3
Sicher bin ich nicht: Kann es sein, dass der Versand nur von E-Mail-Adressen erlaubt ist, die auch auf dem Server angelegt sind?

Gruß,
Michael
[Bild: banner.png]
Support erfolgt NUR im Forum!
Bitte gelöste Themen als "erledigt" markieren.
Beiträge mit mangelhafter Rechtschreibung/Grammatik werden kommentarlos gelöscht.
#4
ja das nehme ich an aber wo und wie kann keinen fehler finden das ist es ja
der benutzer ist auf dem server angelegt und die Mailfunktion ansich von php geht auch nur nicht aus dem Board
#5
joebus schrieb:der benutzer ist auf dem server angelegt und die Mailfunktion ansich von php geht auch nur nicht aus dem Board
Das Problem ist: Das MyBB verwendet die Standard Mailfunktion von PHP. Wenn diese geht, sollte es auch keine Probleme geben.

Erstelle bitte eine PHP-Datei mit folgendem Inhalt:
PHP-Code:
<?php
error_reporting
(E_ALL);

$from "Absender";
$to "Empfänger";

mail("".$to."",
"Testmail",
"Dies ist nur eine Testnachricht.",
"From: ".$from."");
?>
Absender und Empfänger musst du natürlich durch Email-Adressen ersetzen. Lade das Skript dann auf deinen Webspace und rufe es über deinen Browser auf.

Wenn alles klappt, solltest du eine Email mit dem Betreff "Testmail" erhalten.

Versuche es mit verschiedenen Absendern und gucke ob es funktioniert.

Gruß,
Michael
[Bild: banner.png]
Support erfolgt NUR im Forum!
Bitte gelöste Themen als "erledigt" markieren.
Beiträge mit mangelhafter Rechtschreibung/Grammatik werden kommentarlos gelöscht.
#6
ich sagte ja diese funktion geht
#7
Funktionieren die Mails, die das Board verschickt (Aktivierungs-Mail, Massen-Mail, Abonnements, neue PNs,...) auch nicht oder nur die, wenn ein Benutzer einem anderen eine E-Mail schreibt?

Gruß,
Michael
[Bild: banner.png]
Support erfolgt NUR im Forum!
Bitte gelöste Themen als "erledigt" markieren.
Beiträge mit mangelhafter Rechtschreibung/Grammatik werden kommentarlos gelöscht.
#8
generell alle nicht aus dem board mit besagter fehlermeldung
#9
Ist eine E-Mail-Adresse als Admin-E-Mail in der General Configuration eingegeben? Bitte speichere die Einstellungen, auch wenn eine Adresse bereits abgegeben ist. Gucke dann, ob der Mail-Versand funktioniert. Bitte stelle auch sicher, dass diese E-Mail-Adresse auf dem Server eingerichtet ist.

Gruß,
Michael
[Bild: banner.png]
Support erfolgt NUR im Forum!
Bitte gelöste Themen als "erledigt" markieren.
Beiträge mit mangelhafter Rechtschreibung/Grammatik werden kommentarlos gelöscht.
#10
ja ist beides drin aber funktioniert leider immer noch nicht
kann es sein das auf der Maschine Tobit als MAilserver läuft unds es deswegen nicht geht ???


Möglicherweise verwandte Themen...
Thema Verfasser Antworten Ansichten Letzter Beitrag
Exclamation SMTP server response: 550 5.5.4 Invalid address Alexandro 2 1.659 18.01.2007, 10:16
Letzter Beitrag: Alexandro