Hallo, Gast! (Registrieren)

Letzte Ankündigung: MyBB 1.8.8 veröffentlicht (17.10.16)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
Brauche Hilfe beim Upgrade
#1
Hallo!

Ich habe vor etwa 2 Jahren MyBB 1.4.4 installiert, welches seither problemlos lief. Da ich in letzter Zeit Probleme mit Spambots habe, komme ich um eine Aktualisierung aber wohl nicht mehr herum. Leider bin ich mit der Thematik inzwischen nicht mehr so vertraut und hoffe, Ihr könnt mir da Schritt für Schritt weiter helfen.

edit #2: Habe die neuen Dateien auf den Server übertragen und die erforderlichen Rechte zugewiesen. Nun möchte ich im Browser das Upgrade-Script ausführen, erhalte jedoch folgende Fehlermeldung:


Parse error: syntax error, unexpected T_STRING, expecting T_OLD_FUNCTION or T_FUNCTION or T_VAR or '}' in /var/www/web920/html/forum/inc/class_core.php on line 18

Hab ich was vergessen?

Mfg Gunnar
#2
(28.08.2011, 18:46)dau83 schrieb: ....
Im Moment versuche ich, meine Datenbank zu sichern. Leider habe ich das Passwort für den My-Sql-Server vergessen. Ich meine mich zu erinnern, dass es im MyBB eine Datei gibt, wo man das nachlesen kann. Welche war das bloß?
....

Das ist inc/config.php Wink
Ansonsten siehe Doku - Aktualisierung
Gruß NetHunter
#3
@NetHunter: Danke für die Hilfe beim Passwort. Bin nun ein ganzes Stück weiter gekommen.

Das nächste Problem scheint etwas kniffliger. Habe es in den Eröffnungsbeitrag hineineditiert. Weiß jemand eine Lösung?
#4
MyBB 1.6 benötigt PHP 5.1, bei dir läuft wohl eine ältere Version.
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
#5
oje...

Laut meinem Webhost kann Serversoftware für php 4 und 5 verwendet werden. Falls ich nicht auf MyBB 1.6 aktualisieren kann, welche Version sollte ich dann nehmen?
#6
Die letzte von 1.4.
Bitte die Suche u. die Doku nutzen.
______________________________

mfg Murphy
#7
Vielleicht kannst Du aber auch in einer .htaccess Datei folgenden Inhalt einsetzen, um php5 zu nutzen:
Code:
AddType x-mapp-php5 .php
AddHandler x-mapp-php5 .php
Das sollte Dir aber auch Dein Webhoster sagen können.
viele Grüße
Jockl
übersetzte und eigene Plugins
#8
Ok, ich mach mal mit 1.4.9 weiter, damit das Forum nicht zu lange offline bleibt.

Nur mal interesseahalber, was ist eigentlich auch MyBB 1.5 geworden?
#9
Wenn schon MyBB 1.4.16. Der Support dazu wurde aber eingestellt...

https://www.mybb.de/doku/sonstiges/versionssystem.html
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
#10
Stimmt, 16 ist größer als 9. Hatte ich ganz übersehen, danke.
So, das Upgrade scheint funktioniert zu haben. Ich habe das Forum im Adminbereich wieder online geschaltet.

Leider bekomme ich, wenn ich das Forum aufrufe nun folgende Fehlermeldung:

Language deutsch_sie (/var/www/web920/html/forum/inc/languages/deutsch_sie) is not installed

Kann ich das deutsche Sprachpaket für diese Version hier noch irgendwo herunterladen? Falls nicht, was muss ich machen, damit das Forum auf Englisch funktioniert?
Entschuldigung, hier hat die Sufu gereicht. Mein Forum läuft nun wieder. Dank an alle, die geholfen haben. Mit dem Vorschlag von Jockl beschäftige ich mich in den nächsten Tagen nochmal, da ich fürchte, dass die Bots sich von diesem Update nicht beeindrucken lassen. Nun aber erst mal noch nen schönen Abend.

MfG Gunnar


Möglicherweise verwandte Themen...
Thema Verfasser Antworten Ansichten Letzter Beitrag
Sad Brauche eure Hilfe :/ BattlieldAD 7 693 10.04.2014, 02:06
Letzter Beitrag: BattlieldAD
Sad Ich brauche dringend Hilfe! BattlieldAD 2 331 23.03.2014, 12:51
Letzter Beitrag: MrBrechreiz
  Brauche ganz schnell Hilfe SyntaX 3 562 04.08.2011, 09:13
Letzter Beitrag: StefanT