Hallo, Gast! (Registrieren)

Letzte Ankündigung: MyBB 1.8.8 veröffentlicht (17.10.16)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
Frage zu CPG Galerie
#1
Hallo,

habe eine Frage zu Coppermine und Mybb Forum?

Ich habe die Version:
CPG 1.5.12
Mybb 1.6.2

Ich habe das Mybb installiert und im selben Verzeichnis habe ich auch die cpg Galerie eingebunden. Dann habe ich den Bridge-Assistent aufgerufen und die Schritte eingetragen.
Habe hier zwar schon einiges gelesen, aber irgendwie hilft mir das nicht weiter.
Nun ist meine Frage wie bekomme ich die CPG Galerie im Forum eingebunden?

Vielleicht kann mir ja hier jemand weiter helfen?

Viele Grüße dreameye
Zitieren
#2
Die ist bereits eingebunden aber nicht verlinkt. Das mußt Du schon selbst machen.
Ich hab's im Header gemacht.

Beispiel: http://DeineForumURL.tld/cpg/index.php einfügen im Template Header an der gewünschten Stelle.



















Grüsse aus Hamburg
Bernd alias BeeJayZZR

MyBB Version.: 1.8.6
PHP Version...: 5.3.18-nmm1
MySQL Version: 5.1.43


[Bild: signature_red_en_us.php]
Zitieren
#3
Hallo Bernd,

danke für deine Antwort, muss ich es in der Styles PHP einsetzen?

Gruß dreameye
Zitieren
#4
Nein, einfach verlinken.
Die CPG läuft ja eigenständig. Die Bridge sorgt nur dafür, dass die Benutzer mit ihren Rechten die CPG ohne gesonderte Anmeldung/Registrierung auch nutzen können. Dafür benutzt CPG die Datenbank des Forums.
Grüsse aus Hamburg
Bernd alias BeeJayZZR

MyBB Version.: 1.8.6
PHP Version...: 5.3.18-nmm1
MySQL Version: 5.1.43


[Bild: signature_red_en_us.php]
Zitieren
#5
Hallo Bernd,

Das habe ich nicht gefunden

einfügen im Template Header an der gewünschten Stelle.

Ich habe mir das Forum erst seit ein paar Tagen neu installiert und bin da noch etwas Neu.

Ich klicke auf Templates & Styles dann auf Templates dann auf Default Templates da habe ich kein Header gefunden, aber Startseite Templates und wenn ich mein Forum so einsetze wie du es geschrieben hast, dann zeigt er mir nur den Link an, aber nich meine Galerie.

Könntest Du mir bitte da noch mal kurz schreiben wie es einzu fügen habe.

Ich sage schon mal vielen Dank :-)

Gruß dreameye


Zitieren
#6
(24.03.2011, 08:32)dreameye schrieb: Ich klicke auf Templates & Styles dann auf Templates dann auf Default Templates da habe ich kein Header gefunden...

Du bist schon fast da.

Default Templates -> Seitenkopf Templates -> Header

Vorher das angehängte Free Icon (von http://famfamfam.com/lab/icons/silk/ ) oder eines Deiner Wahl (16x16, .gif, .jpg oder .png) in den Ordner /images/toplinks/ hochladen. Dieses Icon heißt im Folgebeispiel "camera.png" und wir verlinken in den Toplinks vor oder hinter der "Suche".

Suche:
Code:
<li><a href="{$mybb->settings['bburl']}/search.php"><img src="{$mybb->settings['bburl']}/{$theme['imgdir']}/toplinks/search.gif" alt="" title="" />{$lang->toplinks_search}</a></li>

Davor oder dahinter einfügen:
Code:
<li><a title="Zur Fotogalerie (öffnet im neuen Fenster)" href="{$mybb->settings['bburl']}/cpg/index.php" target="_blank"><img src="{$mybb->settings['bburl']}/{$theme['imgdir']}/toplinks/camera.png" alt="Fotogalerie" />Fotogalerie</a></li>

Abspeichern und fertig.

PS Ich übernehme keine Verantwortung für etwaige Fehler in der Templatebearbeitung



Angehängte Dateien
.png   camera.png (Größe: 665 Bytes / Downloads: 108)
Grüsse aus Hamburg
Bernd alias BeeJayZZR

MyBB Version.: 1.8.6
PHP Version...: 5.3.18-nmm1
MySQL Version: 5.1.43


[Bild: signature_red_en_us.php]
Zitieren
#7
Wozu gibt es denn den FAQ-Eintrag dazu? https://www.mybb.de/doku/haeufig-gestell...enzen.html
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
Zitieren
#8
Vielen Dank :-)

Gruß dreameye
Zitieren
#9
(24.03.2011, 10:54)BeeJayZZR schrieb: Davor oder dahinter einfügen:
Code:
<li><a title="Zur Fotogalerie (öffnet im neuen Fenster)" href="{$mybb->settings['bburl']}/cpg/index.php" target="_blank"><img src="{$mybb->settings['bburl']}/{$theme['imgdir']}/toplinks/camera.png" alt="Fotogalerie" />Fotogalerie</a></li>

Abspeichern und fertig.

PS Ich übernehme keine Verantwortung für etwaige Fehler in der Templatebearbeitung

Ich habe den Code hier jetzt unter myBB 1.6.8 auch mal eingesetzt. Das resultierte in "FotogalerieFotogalerie" bei den oberen Links (also Doppeleintrag).
Ich habe einfach " alt="Fotogalerie" am Ende des Codes herausgenommen, dann wurds richtig angezeigt.
Das camera.png wird aber nicht angezeigt, obwohl im richtigen Verzeichnis.
Zitieren
#10
Darum wird ja auch der alternative Text "Fotogalerie" angezeigt, weil das Bild nicht vorhanden ist. Deshalb auch FotogalerieFotogalerie Wink

Du musst das Bild camera.png aus dem Beitrag #6 in das Verzeichnis toplinks laden.
viele Grüße
Jockl
übersetzte und eigene Plugins
Zitieren


Möglicherweise verwandte Themen...
Thema Verfasser Antworten Ansichten Letzter Beitrag
  cpg 1.5 > Bridge > Umlaute > Username kibuntu 4 1.115 11.08.2010, 15:43
Letzter Beitrag: kibuntu
  Frage zur Galerie moguai 3 972 06.10.2006, 08:15
Letzter Beitrag: Samu