Hallo, Gast! (Registrieren)

Letzte Ankündigung: MyBB 1.8.8 veröffentlicht (17.10.16)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
Wer ist Online Template
#1
Question 
Guten Tag,

ich habe ein script,das mir anzeigt,wer im Chat ist und habe dies als Iframe eingebaut und das sieht,naja sehr bescheiden aus.

Jetzt meine frage diesbezüglich.

Kann man dieses Script,als Template einbaun?Plugin wäre auch gut,aber sowas kann ich leider nicht.

Hier mal der Code.

Code:
<?php

// like $GLOBALS["path"] = "./et_chat_v3.06/";
$GLOBALS["path"] = "./";

function __autoload($class_name) {
        require_once ($GLOBALS["path"].'class/'.$class_name.'.class.php');        
}

class ExternUserView extends DbConectionMaker
{
    /**
    * Constructor
    *
    * @uses ConnectDB::sqlGet()
    * @uses ConnectDB::close()    
    * @return void
    */
    public function __construct (){
    
        // call parent Constructor from class DbConectionMaker
        parent::__construct();
        
        unset($GLOBALS["path"]);

        $erg=$this->dbObj->sqlGet("SELECT count(etchat_onlineid) FROM {$this->_prefix}etchat_useronline WHERE
        etchat_onlinetimestamp > ".(date('U')-30)."
        and (etchat_user_online_user_status_img is null or etchat_user_online_user_status_img <> 'status_invisible')");

        echo $erg[0][0]." User sind online. <br />";

        $erg_user=$this->dbObj->sqlGet("SELECT etchat_user_online_user_name, etchat_user_online_user_priv FROM {$this->_prefix}etchat_useronline
        WHERE etchat_onlinetimestamp > ".(date('U')-30)."
        and (etchat_user_online_user_status_img is null or etchat_user_online_user_status_img <> 'status_invisible')
        order by etchat_user_online_user_name");

        if ($us[1]=="admin") echo "<span style='color:red'><b>".$us[0]."</b></span>,";
else if ($us[1]=="mod") echo "<span style='color:green'><b>".$us[0]."</b></span>,";
else echo $us[0].",";
}
else echo '<span style="color:#3A5FCD;">'."<b>Es ist niemand im Chat</b></span>";

// close DB connect
$this->dbObj->close();

}
}




// initialise
new ExternUserView;

?>

LG Corle
Zitieren
#2
Siehe: https://www.mybb.de/forum/thread-6052-po...l#pid43459
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
Zitieren
#3
Danke.

Habe alles genau so gemacht,wie beschrieben,aber es wird mir nichts angezeigt.

habe in der index.php nach dem <?php

ob_start();
include("chaton.php");
$chaton = ob_get_contents();
ob_end_clean();

eingefügt,danach in den Templates index geöffnet und die zeile

{$chaton}
über den Boardstats eingefügt,da es nicht ging an anderen stellen versucht,auch nichts.


Jetzt is dieser fehler aufgetaucht.

Warning: require_once(./class/DbConectionMaker.class.php) [function.require-once]: failed to open stream: No such file or directory in /data/multiserv/users/197184/projects/232424/www/chaton.php on line 7

Fatal error: require_once() [function.require]: Failed opening required './class/DbConectionMaker.class.php' (include_path='.:/usr/lib/php') in /data/multiserv/users/197184/projects/232424/www/chaton.php on line 7


Habe es mal solange aus gestellt,weil es erreicht ja keiner mehr das Forum.
So,habe den fehler gefunden,musste den pfad noch ändern,aber jetzt wird mir nichts angezeigt.
Zitieren
#4
Die chaton.php liegt im Order des Forums? Wird etwas angezeigt, wenn du diese direkt aufrufst?

Gruß,
Michael
[Bild: banner.png]
Support erfolgt NUR im Forum!
Bitte gelöste Themen als "erledigt" markieren.
Beiträge mit mangelhafter Rechtschreibung/Grammatik werden kommentarlos gelöscht.
Zitieren
#5
Nein,die chaton.php liegt nicht direkt im Ordner des Forums,habe ja auch die index.php so beschrieben

Code:
<?php
ob_start();
include("./m_chat/chaton.php");
$chaton = ob_get_contents();
ob_end_clean();

/**
* MyBB 1.6
* Copyright 2010 MyBB Group, All Rights Reserved
*
* Website: http://mybb.com
* License: http://mybb.com/about/license
*
* $Id: index.php 5016 2010-06-12 00:24:02Z RyanGordon $
*/


define("IN_MYBB", 1);
define('THIS_SCRIPT', 'index.php');
das der anfang der inde.php

und im Template index über den Boardstas dies eingefügt.

{$chaton}

aber wenn ich dann das Forum neu aufrufe,kommt diese fehler meldung und das Forum geht nicht mehr,also wéiße seite.

Code:
Warning: require_once(./class/DbConectionMaker.class.php) [function.require-once]: failed to open stream: No such file or directory in /data/multiserv/users/197184/projects/232424/www/m_chat/chaton.php on line 6

Fatal error: require_once() [function.require]: Failed opening required './class/DbConectionMaker.class.php' (include_path='.:/usr/lib/php') in /data/multiserv/users/197184/projects/232424/www/m_chat/chaton.php on line 6

Ganz oben in meinem Thread ist die chaton.php zu sehen.
Als Iframe geht das,aber sieht bescheiden aus,daher möchte ich ja gerne die Online anzeige des Chats im Forum mit einbinden.
Zitieren
#6
Ich vermute hier ein Problem mit den relativen Pfaden im Chat-Skript. Wäre es nicht möglich, dass du die Ausgabe der chaton.php so anpasst, dass sie in das Design des Forums passt und man den iFrame nicht erkennt?

Gruß,
Michael
[Bild: banner.png]
Support erfolgt NUR im Forum!
Bitte gelöste Themen als "erledigt" markieren.
Beiträge mit mangelhafter Rechtschreibung/Grammatik werden kommentarlos gelöscht.
Zitieren
#7
Den Iframe erkennt man und ist im Forum eingebaut,man sieht die namen und die anzahl,deshalb versteh ich ja nicht,warum das Forum rum zickt,wenn ich es im Forum einbaue,wie von ihnen beschrieben.

Wenn ich den Hintergrund am Forum anpasse sieht man die Schrift nich mehr,bekomme es leider nicht hin,die Schrift zu ändern.
Denn dann kommt auch sofort wieder nen fehler code.

Deshalb möchte ich ja auch,das es im forum eingebaut wird und auch zu Design passt.
Zitieren
#8
Das Problem ist, dass der Chat mit relativen Pfaden arbeitet und dann seine eigenen Dateien nicht finden kann. Das hat mit dem von mir vorgeschlagenen Code gar nichts zu tun.
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
Zitieren
#9
Wenn du die Ausgabe von chaton.php so formatierst wie im Design des Forums erkennt man den Iframe zumindest nicht mehr. Was genau ist da das Problem?

Gruß,
Michael
[Bild: banner.png]
Support erfolgt NUR im Forum!
Bitte gelöste Themen als "erledigt" markieren.
Beiträge mit mangelhafter Rechtschreibung/Grammatik werden kommentarlos gelöscht.
Zitieren
#10
Ich habe diesen PHP Code jetzt als Iframe eingebaut und ein HTML Gerüst drum rum gebaut.
Das Problem war,das ich dies nicht,wie von ihnen beschrieben ins Forum einbinden konnte,sondern nur als Iframe.

Habe es auch hinbekommen im PHP Code die farben mit einzubinden.

PHP-Code:
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN"
        "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd"
>
<
html xmlns="http://www.w3.org/1999/xhtml">
                 

<
head>
<
meta http-equiv="content-type" content="text/html; charset=utf-8" />
<
title>Mystical Chat</title>
    
                   

          
</
head>
<
body bgcolor="1A1A1A">

 <?
php
// like $GLOBALS["path"] = "./et_chat_v3.06/";
$GLOBALS["path"] = "./";

function 
__autoload($class_name) {
        require_once (
$GLOBALS["path"].'class/'.$class_name.'.class.php');        
}

class 
ExternUserView extends DbConectionMaker
{
    
/**
    * Constructor
    *
    * @uses ConnectDB::sqlGet()
    * @uses ConnectDB::close()    
    * @return void
    */
    
public function __construct (){
    
        
// call parent Constructor from class DbConectionMaker
        
parent::__construct();
        
        unset(
$GLOBALS["path"]);

        
$erg=$this->dbObj->sqlGet("SELECT count(etchat_onlineid) FROM {$this->_prefix}etchat_useronline WHERE 
        etchat_onlinetimestamp > "
.(date('U')-30)."
        and (etchat_user_online_user_status_img is null or etchat_user_online_user_status_img <> 'status_invisible')"
);

       echo 
"<span style='color:#4874a3'><b>"$erg[0][0]. "<b> User Online im Chat.</b></span><br/>";

        
$erg_user=$this->dbObj->sqlGet("SELECT etchat_user_online_user_name, etchat_user_online_user_priv FROM {$this->_prefix}etchat_useronline 
        WHERE etchat_onlinetimestamp > "
.(date('U')-30).
        and (etchat_user_online_user_status_img is null or etchat_user_online_user_status_img <> 'status_invisible')
        order by etchat_user_online_user_name"
);

        if(
is_array($erg_user)) foreach($erg_user as $us)
{


if (
$us[1]=="admin") echo "<i><span style='color:#fe088d'>".$us[0]."</span></i> , ";
else if (
$us[1]=="mod") echo "<i><span style='color:#cc00ff'>".$us[0]."</span></i> , ";
else if (
$us[1]=="gast") echo "<i><span style='color:#3399CC'>".$us[0]."</span></i> , ";
else echo 
$us[0]." , ";
}
else echo 
'<span style="color:#3A5FCD;">'."<i>Es ist niemand im Chat</i></span>";

// close DB connect
$this->dbObj->close();

}

}

// initialise
new ExternUserView;
 echo
'

          
   


</body>

</html>'
;

?>

Hätte auch gerne gehabt,das das so aussieht,wie in Wer ist Online,mit border ec.
Und Verlinkungen aufs Profiel,wenn man auf den namen,des jeweiligen Users Klickt.
Ein Problem gibt es aber noch mit äÄöÖ usw,diese werden falsch angezeigt.
Zitieren


Möglicherweise verwandte Themen...
Thema Verfasser Antworten Ansichten Letzter Beitrag
  wer ist online - location - farbig hkkp 4 286 20.10.2015, 17:50
Letzter Beitrag: hkkp
  Wer ist Online List im Header problemkind 2 599 24.06.2009, 12:29
Letzter Beitrag: problemkind
  Wer ist online logo Corleone 5 786 13.11.2007, 21:31
Letzter Beitrag: Garlant
  Wer ist online iamstillalive 6 1.168 10.12.2006, 19:34
Letzter Beitrag: frankrieger
  Männchen vor der Benutzernamen in der Wer ist Online anzeige... Crasher 5 896 21.10.2006, 16:01
Letzter Beitrag: ElkeK.