Hallo, Gast! (Registrieren)

Letzte Ankündigung: MyBB 1.8.8 veröffentlicht (17.10.16)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
Fehlermeldung nach Verfassung eines Threads
#1
Ich habe MyBB von 1.4.9 auf 1.6.1 umgestellt (upgrade). Datenbank ist PostgreSQL. Beim Test lief alles prima. Jetzt hat ein neuer User einen Thread erstellt. Versucht man ihn anzuklicken, taucht folgende Fehlermeldung auf:

Code:
Type: 20
File:  (Line no. 0)
Message
SQL Error: 22P02 - ERROR:  invalid input syntax for integer: ""
LINE 3:    SET firstpost='' WHERE tid='999'
                        ^

Query:
            UPDATE mybb_threads
            SET firstpost='' WHERE tid='999'

Kann jemand helfen und weiss woran das liegt?
Nach dem Verfassen eines Threads als neu angemeldetes Mitglied taucht folgende Meldung auf:

Zitat:Dir fehlt die Berechtigung, diese Seite zu betreten. Grund dafür könnte einer der folgenden sein:
Dein Account wurde entweder eingeschränkt oder du wurdest aus dem Forum ausgeschlossen.
Dir fehlt die Berechtigung, diese Seite zu betreten. Versuchst du auf eine Administratoren-Seite zu kommen? Lies in den Forenregeln, ob du diese Aktion durchführen darfst.
Dein Account wartet auf Aktivierung oder Moderation. (Aktivierungscode erneut zuschicken)
Du rufst diese Seite direkt auf, anstatt das entsprechende Formular oder den entsprechenden Link zu benutzen.

Du bist zur Zeit unter diesem Benutzernamen angemeldet: 'tester'

Die Benutzer auf der Indexseite (Startseite vom Forum) sind nicht anklickbar.
#2
Zu 1) Um das Problem auf eine Codestelle einzugrenzen, versuche bitte folgendes: Öffne die Datei inc/functions.php und suche Zeile 4224:
PHP-Code:
"firstpost" => $post['pid'
Ersetzen durch?
PHP-Code:
"firstpost" => intval($post['pid']) 
Wird dann noch die Fehlermeldung ausgegeben? Bitte beachte, dass die Änderung das Grundproblem nicht löst, sondern lediglich umgeht.

Zu 2) Kann diese Benutzergruppe Themen generell lesen? Bitte stelle sicher, dass die Berechtigungen entsprechend gesetzt sind.

Zu 3) Hast du einen Link dazu?

Grundsätzlich: Hast du nach dem Upgrade deine Templates angepasst/zurückgesetzt? Du kannst im ACP -> Templates & Style -> Templates -> Aktualisierte finden eine Liste mit betroffenen Templates ausgeben lassen. Meist verschwinden dann viele Probleme.

Gruß,
Michael
[Bild: banner.png]
Support erfolgt NUR im Forum!
Bitte gelöste Themen als "erledigt" markieren.
Beiträge mit mangelhafter Rechtschreibung/Grammatik werden kommentarlos gelöscht.


Möglicherweise verwandte Themen...
Thema Verfasser Antworten Ansichten Letzter Beitrag
  Schreib-/Lese-Berechtigung eines Threads Manni 3 616 16.03.2013, 14:34
Letzter Beitrag: Licht
  Fehlemeldung bei Auswahl eines Forums / Threads th0sch 3 1.995 24.12.2010, 17:09
Letzter Beitrag: th0sch