Hallo, Gast! (Registrieren)

Letzte Ankündigung: MyBB 1.8.8 veröffentlicht (17.10.16)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
Side Box Problem - Doppelt?
#1
Hallo,
ich schon wieder ;-). Ich habe gerade die aktuelle Version der Side Box installiert und vorher natürlich die alte deinstalliert. Leider sieht das Forum etwas verschoben aus:
http://www.fantec-user.de/index.php

Irgendetwas stimmt da ja nicht. Ich habe im Template Startseiten templates--index folgendes stehen:
Code:
<html>
<head>
<title>{$mybb->settings['bbname']}</title>
{$headerinclude}
{$metag}
<script type="text/javascript">
<!--
    lang.no_new_posts = "{$lang->no_new_posts}";
    lang.click_mark_read = "{$lang->click_mark_read}";
// -->
</script>
<link rel="shortcut icon" type="image/x-icon" href="/message.ico"/>
</head>
<body>
{$header}
<table width="100%"  border="0">
  <tr>
    <td width="75%" valign="top"><table width="100%"  border="0">
  <tr>
    <td width="75%" valign="top">{$forums}

</td>
    <td width="25%" valign="top">{$sb_welcome}{$sb_search}{$sb_stats}{$sb_latestthreads}{$sb_additional}</td>
  </tr>
</table></td>
{$boardstats}

<dl class="forum_legend smalltext">
    <dt><img src="{$theme['imgdir']}/on.gif" alt="{$lang->new_posts}" title="{$lang->new_posts}" style="vertical-align: middle; padding-bottom: 4px;" /></dt>
    <dd>{$lang->new_posts}</dd>

    <dt><img src="{$theme['imgdir']}/off.gif" alt="{$lang->no_new_posts}" title="{$lang->no_new_posts}" style="vertical-align: middle; padding-bottom: 4px;" /></dt>
    <dd>{$lang->no_new_posts}</dd>

    <dt><img src="{$theme['imgdir']}/offlock.gif" alt="{$lang->forum_locked}" title="{$lang->forum_locked}" style="vertical-align: middle;" /></dt>
    <dd>{$lang->forum_locked}</dd>
</dl>
<br style="clear: both" />
{$footer}
{$lexcange}
</body>
</html>

Nur finde ich den fehler nicht, es müsste doch alles passen, oder übersehe ich da etwas?
Viele grüße,
Max
Zitieren
#2
Hallo vip3r,

verwende einmal diesen Code:
Code:
<html>
<head>
<title>{$mybb->settings['bbname']}</title>
{$headerinclude}
{$metag}
<script type="text/javascript">
<!--
    lang.no_new_posts = "{$lang->no_new_posts}";
    lang.click_mark_read = "{$lang->click_mark_read}";
// -->
</script>
<link rel="shortcut icon" type="image/x-icon" href="/message.ico"/>
</head>
<body>
{$header}
<table width="100%"  border="0">
    <tr>
        <td width="75%" valign="top">{$forums}</td>
        <td width="25%" valign="top">{$sb_welcome}{$sb_search}{$sb_stats}{$sb_latestthreads}{$sb_additional}</td>
    </tr>
</table>
{$boardstats}

<dl class="forum_legend smalltext">
    <dt><img src="{$theme['imgdir']}/on.gif" alt="{$lang->new_posts}" title="{$lang->new_posts}" style="vertical-align: middle; padding-bottom: 4px;" /></dt>
    <dd>{$lang->new_posts}</dd>

    <dt><img src="{$theme['imgdir']}/off.gif" alt="{$lang->no_new_posts}" title="{$lang->no_new_posts}" style="vertical-align: middle; padding-bottom: 4px;" /></dt>
    <dd>{$lang->no_new_posts}</dd>

    <dt><img src="{$theme['imgdir']}/offlock.gif" alt="{$lang->forum_locked}" title="{$lang->forum_locked}" style="vertical-align: middle;" /></dt>
    <dd>{$lang->forum_locked}</dd>
</dl>
<br style="clear: both" />
{$footer}
{$lexcange}
</body>
</html>
Zitieren
#3
Hmm, leider hat das nichts gebracht ;-(.
Zitieren
#4
Hast du die Änderung im richtigen Template vorgenommen?

Akt. Auszug aus Quelltext:
Code:
...
<table width="100%"  border="0">
  <tr>
    <td width="75%" valign="top"><table width="100%"  border="0">
  <tr>
    <td width="75%" valign="top"><!-- start: forumbit_depth1_cat -->
<table border="0" cellspacing="1" cellpadding="6" class="tborder">
<thead>
...
Zitieren
#5
Ja, ich habe das richtige Template gewählt. Dieses ändert sich auch, wenn ich das Plugin deaktiviere.
Das dürfte auch das einzigste sein, welches geändert wird, wenn das Plugin installiert wird.
Hab jetzt schon mehrere Dinge entfernt und getestet, aber diesen leeren Bereich bekomme ich einfach nicht mehr weg. Auch wenn ich das Plugin deinstalliere, bleibt der freie Bereich da ;-(.

Edit: Ich habe jetzt mal beide 75% Angaben auf 100% geändert und es scheint zu passen, oder? Ich kapiere das nicht wirklich. Die SideBox wird ausserhalb angezeigt, vorher war sie innerhalb des Forums. Hab mal nen Screenshot gemacht um das zu verdeutlichen:
[Bild: http://img155.imageshack.us/img155/2606/sidebox.jpg]
Vorher war die SideBox in dem, auf dem Bild, freien bereich.
Zitieren
#6
Das ist "Selbstbetrug"... Wink

Irgendetwas läuft da falsch - der Quelltext gibt immer noch invaliden Code aus, z. B.:
Code:
...
<table width="100%"  border="0"><tr><td width="auto" valign="top">
<table width="100%"  border="0">
  <tr>
    <td width="100%" valign="top"><table width="100%"  border="0">
  <tr>
    <td width="100%" valign="top">
...

Der von mir gepostete Code liefert mir dieses Ergebnis:
   

Siehe auch > http://validator.w3.org/check?uri=http%3...ne&group=0

Zitieren
#7
Genauso sollte es auch aussehen, ich verstehe das nicht...
Habe jetzt noch ein wenig rumprobiert, aber es hilft nichts, ich bekomme es nicht mehr so hin. Es ist zwar jetzt akzeptabel, aber nicht wirklich gut gelöst..;-(
Zitieren
#8
Verwendest du das Plugin > Sidebox von Nayar?

Wenn ja, verwende folgenden Code im Template "index":
Code:
<html>
<head>
<title>{$mybb->settings['bbname']}</title>
{$headerinclude}
{$metag}
<script type="text/javascript">
<!--
    lang.no_new_posts = "{$lang->no_new_posts}";
    lang.click_mark_read = "{$lang->click_mark_read}";
// -->
</script>
<link rel="shortcut icon" type="image/x-icon" href="/message.ico"/>
</head>
<body>
{$header}
{$forums}
{$boardstats}
<dl class="forum_legend smalltext">
    <dt><img src="{$theme['imgdir']}/on.gif" alt="{$lang->new_posts}" title="{$lang->new_posts}" style="vertical-align: middle; padding-bottom: 4px;" /></dt>
    <dd>{$lang->new_posts}</dd>

    <dt><img src="{$theme['imgdir']}/off.gif" alt="{$lang->no_new_posts}" title="{$lang->no_new_posts}" style="vertical-align: middle; padding-bottom: 4px;" /></dt>
    <dd>{$lang->no_new_posts}</dd>

    <dt><img src="{$theme['imgdir']}/offlock.gif" alt="{$lang->forum_locked}" title="{$lang->forum_locked}" style="vertical-align: middle;" /></dt>
    <dd>{$lang->forum_locked}</dd>
</dl>
<br style="clear: both" />
{$footer}
{$lexcange}
</body>
</html>

Das Plugin nimmt keine direkten Template-Änderungen vor, so dass du vom jew. (Original-)Template ausgehen kannst.
Zitieren
#9
Vielen Dank ;-), aber leider ist es immer noch so, dass der Footer bereich reduziert ist. Ich habe mal eine Testinstallation local erstellt und da ist das selbe Problem, der footer wird reduziert in der breite. Das scheint vielleicht daran zu liegen, dass die sidebox alles in der breite reduziert und sich einfach "reinquetscht". Bei der alten version hat es das Template geändert und war ansehnlicher, meine ich zumindest.
Wenn Du noch mehr Ideen hast, immer gerne ;-).
Viele Grüße,
Max
Zitieren
#10
Ersetze einmal in der Plugin-Datei "sidebox.php"

Zeile (~ 366)
PHP-Code:
            $templates->cache['index'] = str_replace('{$footer}','{$footer}</td><td width="'.$lmao1.'" valign="top">'.$lol1."".$lol2."".$lol3."".$lol4."".$lol5."".$lol6."".$lol7."".$lol8."".$lol9.'</td></tr></table>',$templates->cache['index']); 
durch
PHP-Code:
            $templates->cache['index'] = str_replace('{$footer}','</td><td width="'.$lmao1.'" valign="top">'.$lol1."".$lol2."".$lol3."".$lol4."".$lol5."".$lol6."".$lol7."".$lol8."".$lol9.'</td></tr></table>{$footer}',$templates->cache['index']); 

Zeile (~ 384)
PHP-Code:
            $templates->cache['forumdisplay'] = str_replace('{$footer}','{$footer}</td><td width="'.$lmao1.'" valign="top">'.$lol1."".$lol2."".$lol3."".$lol4."".$lol5."".$lol6."".$lol7."".$lol8."".$lol9.'</td></tr></table>',$templates->cache['forumdisplay']); 
durch
PHP-Code:
            $templates->cache['forumdisplay'] = str_replace('{$footer}','</td><td width="'.$lmao1.'" valign="top">'.$lol1."".$lol2."".$lol3."".$lol4."".$lol5."".$lol6."".$lol7."".$lol8."".$lol9.'</td></tr></table>{$footer}',$templates->cache['forumdisplay']); 

Zeile (~ 399)
PHP-Code:
            $templates->cache['showthread'] = str_replace('{$footer}','{$footer}</td><td width="'.$lmao1.'" valign="top">'.$lol1."".$lol2."".$lol3."".$lol4."".$lol5."".$lol6."".$lol7."".$lol8."".$lol9.'</td></tr></table>',$templates->cache['showthread']); 
durch
PHP-Code:
            $templates->cache['showthread'] = str_replace('{$footer}','</td><td width="'.$lmao1.'" valign="top">'.$lol1."".$lol2."".$lol3."".$lol4."".$lol5."".$lol6."".$lol7."".$lol8."".$lol9.'</td></tr></table>{$footer}',$templates->cache['showthread']); 
Zitieren


Möglicherweise verwandte Themen...
Thema Verfasser Antworten Ansichten Letzter Beitrag
  Side Bar mit MyBB 1.8.3 Juetzel 6 530 06.12.2014, 09:08
Letzter Beitrag: Juetzel
  Add this button in side box fixieren Flobse 7 702 24.03.2013, 13:52
Letzter Beitrag: Jockl
  "Simple Calendar on Portal" (Plugin ) -> in Side Box einbinden Martito 5 1.653 06.04.2011, 18:31
Letzter Beitrag: Lunak
  Frage zu Side Boxes 2.1 Juetzel 3 936 25.03.2011, 09:20
Letzter Beitrag: StefanT
  Bestimmte Threads in den Side-Boxen! Sunny93 15 1.675 30.05.2010, 20:01
Letzter Beitrag: Jockl