Hallo, Gast! (Registrieren)

Letzte Ankündigung: MyBB 1.8.8 veröffentlicht (17.10.16)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
Problem mit dem QuickLogin: "undefined" und "NaN"
#1
Hallo,

Nach dem Update heute ist mir aufgefallen, das der Login (JS-basierte Schnellanmeldung) nicht richtig läuft. Der Text wird dabei immer zu undefined / NaN.
Funktionieren tut es zwar aber es sieht ziemlich doof aus: http://das-computer-board.de/

Grüße,
MaR-V-iN
#2
Da ist ein Fehler im Template header_welcomeblock_guest.

Schau bitte mal nach ob dort folgendes steht:
PHP-Code:
lang.register_url " &mdash; <a href=\"{$mybb->settings['bburl']}/member.php?action=register\">{$lang->welcome_register}<\/a>"
#3
Ja, steht da
#4
Bitte aktualisiere deine Templates, ich schätze ein welcomeblock-Template ist veraltet.
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
#5
Ich habe das welcomeblock-template wieder auf den Ursprungzustand zurückgesetzt aber es bleibt alles beim alten.
#6
Du meinst hoffentlich die Templates? Das sind mehrere...
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
#7
Zurückgesetzt habe ich nur das "header_welcomeblock_guest"-Template. Die andern habe ich nur entsprechend der Änderungen abgeändert. Wobei das auch egal ist, denn sie dürften eigentlich nichts damit zu tun haben. Ich frage mich z.Z. ob das vll. sogar vorher schon so war und ichs nur nie mitbekommen hab .?.
#8
Das ist eine Änderung von MyBB 1.6. Dann könnte es am headerinclude-Template liegen.
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
#9
im headerinclude war nix zu finden (waren da überhaupt Änderungen außer der Versionsnummer? Smile)

Habe das Problem gefunden! Es lag am Statistik-Script das ich eingebaut hab (man ich muss mal mit den leuten reden Smile)
#10
Seltsam, ich habe plötzlich auch genau das gleiche Problem (1.6.16). Kann mir nicht erklären,  woran das liegt. Vielleicht habe ich versehentlich irgendetwas zerschossen.


Meine headerinclude sieht so aus:

Code:
<link rel="alternate" type="application/rss+xml" title="{$lang->latest_threads} (RSS 2.0)" href="{$mybb->settings['bburl']}/syndication.php" />
<link rel="alternate" type="application/atom+xml" title="{$lang->latest_threads} (Atom 1.0)" href="{$mybb->settings['bburl']}/syndication.php?type=atom1.0" />
<link rel="shortcut icon" type="image/x-icon" href="{$mybb->settings['bburl']}/{$theme['imgdir']}/favicon.ico" />
<meta http-equiv="Content-Type" content="text/html; charset={$charset}" />
<meta http-equiv="Content-Script-Type" content="text/javascript" />
<meta http-equiv="Content-Style-Type" content="text/css" />
<script type="text/javascript" src="{$mybb->settings['bburl']}/jscripts/prototype.js?ver=1603"></script>
<script type="text/javascript" src="{$mybb->settings['bburl']}/jscripts/general.js?ver=1603"></script>
<script type="text/javascript" src="{$mybb->settings['bburl']}/jscripts/popup_menu.js?ver=1600"></script>
{$stylesheets}
<script type="text/javascript">
<!--
var cookieDomain = "{$mybb->settings['cookiedomain']}";
var cookiePath = "{$mybb->settings['cookiepath']}";
var cookiePrefix = "{$mybb->settings['cookieprefix']}";
var deleteevent_confirm = "{$lang->deleteevent_confirm}";
var removeattach_confirm = "{$lang->removeattach_confirm}";
var loading_text = '{$lang->ajax_loading}';
var saving_changes = '{$lang->saving_changes}';
var use_xmlhttprequest = "{$mybb->settings['use_xmlhttprequest']}";
var my_post_key = "{$mybb->post_code}";
var imagepath = "{$theme['imgdir']}";
// -->
</script>
{$newpmmsg}



Meine header_welcomeblock_guest so:
Code:
<script type="text/javascript">
<!--
lang.username = "{$login_username}";
lang.password = "{$lang->login_password}";
lang.login = "{$lang->login}";
lang.lost_password = " &mdash; <a href=\"{$mybb->settings['bburl']}/member.php?action=lostpw\">{$lang->lost_password}<\/a>";
lang.register_url = " &mdash; <a href=\"{$mybb->settings['bburl']}/member.php?action=register">{$lang->welcome_register}<\/a>";
lang.remember_me = "{$lang->remember_me}";
// -->
</script>
<div class="my_seitenkopf_gast"> 
<span id="quick_login">
<a href="{$mybb->settings['bburl']}/member.php?action=login" onclick="MyBB.quickLogin(); return false;">{$lang->welcome_login}</a>
 &mdash; 
<a href="{$mybb->settings['bburl']}/member.php?action=register">Kostenlos {$lang->welcome_register}</a>
 &mdash; 
 <a href="{$mybb->settings['bburl']}/search.php" rel="nofollow">{$lang->toplinks_search}</a>
 &mdash; 
 <a href="{$mybb->settings['bburl']}/contact.php" rel="nofollow">Kontakt</a> </span>
</div>

Die Frage hat sich erledigt, es muss ein Fehler in der header_welcomeblock_guest gesteckt haben.


Möglicherweise verwandte Themen...
Thema Verfasser Antworten Ansichten Letzter Beitrag
  Beiträge mit Inhalt undefined navis 10 1.035 18.12.2014, 08:51
Letzter Beitrag: navis
  Fatal error: Call to undefined method captcha Astrofan 4 487 29.07.2014, 09:23
Letzter Beitrag: Flobo x3
  Mal wieder undefined Weltenbummler 0 568 24.05.2014, 17:29
Letzter Beitrag: Weltenbummler
  Anstatt merken Undefined nightr0ad 4 564 01.02.2013, 16:06
Letzter Beitrag: nightr0ad
  Checkbox beim Quicklogin traax 5 596 12.01.2012, 17:41
Letzter Beitrag: traax