Hallo, Gast! (Registrieren)

Letzte Ankündigung: MyBB 1.8.8 veröffentlicht (17.10.16)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
PHP-Warnungen beim Aktivieren des eigenen Plugins
#11
Und wieso wird bei dir keine Template-Änderung ausgeführt?
Zitieren
#12
Nach dem "warum" habe ich nicht näher gesucht. Aber warum führst Du die Templateänderung nicht mit find_replace_templatesets durch?
viele Grüße
Jockl
übersetzte und eigene Plugins
Zitieren
#13
Weil ich zum ersten Mal ein MyBB-Plugin mache, und keinen Ahnung von all den Befehlen habe. Wie kann man es anwenden? Wo finde ich weitere Befehle?
Zitieren
#14
Hallo magent,

1. es fehlt (mind.)
PHP-Code:
global $db
und somit die Einbindung der Datenbank.

2. verwendest du nicht die db-Klasse
PHP-Code:
$qry1 "SELECT footer FROM ".TABLE_PREFIX."_templates WHERE title='footer'";
$footer1 mysql_query($qry1); 
wenn, dann verwende
PHP-Code:
$qry1 $db->query("SELECT footer FROM ".TABLE_PREFIX."templates WHERE title='footer'");
while(
$footer1 $db->fetch_array($qry1)) {
    ...


3. solltest du in "function better_copyright_activate()" das Template besser mit "find_replace_templatesets()" aktualisieren
...
require MYBB_ROOT.'/inc/adminfunctions_templates.php';
find_replace_templatesets("footer", '#alter_string#', 'neuer_string');


Vergleiche einmal generell den Aufbau anderer Plugins mit deinem.
Zitieren
#15
Ermal vielen Dank für deine Antwort.

Das Plugin sieht setzt wie folgt aus:

.php   better_copyright.php (Größe: 1,25 KB / Downloads: 3)

Wenn man es aktiviert, kommt folgende Warnmeldung dazwischen:
   
Und das ganze sieht dann so aus (falsch):
   

Wenn man es deaktiviert, kommt folgende Warnmeldung dazwischen:
   
Und das ganze sieht dann so aus (Copyright ist ganz weg):
   

Was mache ich falsch?

P.S.: Was ist ein Hook?
Zitieren
#16
http://www.mybbcoder.info/wiki/informati...ugins.html
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
Zitieren
#17
Danke Stefan, zwar habe ich Hooks noch nicht ganz Verstanden, aber besser als Vorhin.
Zitieren
#18
Schau dir doch einfach mal die vorhanden Plugins an! Wink
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
Zitieren
#19
(08.11.2009, 21:00)magent schrieb: ...Was mache ich falsch?...

Sieh dir mal die angehängte Datei an.


Angehängte Dateien
.php   better_copyright.php (Größe: 1,23 KB / Downloads: 2)
Zitieren
#20
Hallo linwinman.

Ich hatte erst jetzt Zeit das Plugin anzuschauen und zu Testen. Ich werde dieses Plugin noch etwas weiter ausbauen (nein, das war nur ein kleiner teil des plugins), und es später zum download stellen.
Es freut mich, das ich mich immer wieder an euch wenden kann. Egal ob es sich um ein Technisches Problem handelt oder um ein Sachliches Problem.

Edit: "compatibility", muss es im Format 149 sein oder 1409?
Ich glaube, ich habs noch immer nicht gerafft mit dieser Funktion.
PHP-Code:
    find_replace_templatesets("footer"'#{$lang->powered_by} <a href="http://www.mybboard.net" target="_blank">MyBB{$mybbversion}</a>, &copy; 2002-{$copy_year} <a href="http://www.mybboard.net" target="_blank">MyBB Group</a>#''{$lang->powered_by} <a href="http://www.mybboard.net" target="_blank">MyBB{$mybbversion}</a> <br> &copy; 2002-{$copy_year} <a href="http://www.mybboard.net" target="_blank">MyBB Group</a>'); 
Da tut sich einfach nichts.
Zitieren


Möglicherweise verwandte Themen...
Thema Verfasser Antworten Ansichten Letzter Beitrag
  php in eigenen Postings erlauben Vorlonski 14 846 03.12.2012, 21:32
Letzter Beitrag: Vorlonski
  Warnungen im Forum gehen nicht weg. Devon 13 2.139 03.09.2009, 09:34
Letzter Beitrag: StefanT
  Beim aktivieren eines Plugins Templateveränderung henningstorck 1 910 30.11.2008, 16:35
Letzter Beitrag: StefanT
  Beim aktivieren eines Plugins Templateveränderung henningstorck 3 886 30.11.2008, 15:48
Letzter Beitrag: Michael
  replace beim deaktivieren und aktivieren eines Plugins Garlant 9 1.860 14.06.2006, 22:26
Letzter Beitrag: Garlant