Hallo, Gast! (Registrieren)

Letzte Ankündigung: MyBB 1.8.8 veröffentlicht (17.10.16)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
Problem mit verschachteltem background
#1
Hallo zusammen,

in den Zitaten werden die Sprung-Pfeile ja über diese CSS-Klasse erzeugt
Code:
.quick_jump {
    background: url(images/nav_pfeil.gif) no-repeat 0;
    width: 13px;
    height: 13px;
    padding-left: 13px; /* amount of padding needed for image to fully show */
    vertical-align: middle;
    border: none;
}

Im Template postbit bzw. post_classic habe ich folgende Änderung vorgenommen:
Code:
<div id="pid_{$post['pid']}" class="postmsg">
    {$post['message']}
</div>
Über die Klasse postmsg steuere ich die Darstellung von externen und internen Links innerhalb von Beiträgen
Code:
.postmsg a[href^="http:"] {
    background: url(images/ext_link.png) top right no-repeat;
    color: #4b8052;
    padding-right: 9px;
}

.postmsg a[href^="http:"]:hover {
    text-decoration: underline !important;
    color: #bebebe;
}

.postmsg a[href^="http://www.meineSeite.com"] {
    background: transparent;
    color: #4b8052;
    padding-right: 0px;
}

Nun zum Problem: Die Klasse postmsg sorgt dafür, dass mein Sprung-Pfeil (weil interner Link) transparent wird und damit verschwindet. Wenn ich postmsg entferne, ist der Pfeil wieder da.
Ich befinde mich jetzt irgendwie in einer Sackgasse. Der Zitatpfeil soll natürlich weiterhin angezeigt werden. Über Hilfe würde ich mich freuen. Wink
viele Grüße
Jockl
übersetzte und eigene Plugins
Zitieren
#2
Lustig, daß man in CSS Attribut-Werte matchen kann, wusste ich noch gar nicht. Wink

Wozu brauchst du das background: transparent in der postmsg eigentlich?
Zitieren
#3
Hallo,
setze background lieber auf none und die .quick_jump-Formatierung hinter dein .postmsg innerhalb der CSS-Datei. So sollte es funktionieren.
Zitieren
#4
Danke für Eure Antworten!

(07.08.2009, 21:57)frostschutz schrieb: Wozu brauchst du das background: transparent in der postmsg eigentlich?
Damit bei internen Links die Kennzeichnung nicht erfolgt.

(07.08.2009, 23:42)querschlaeger schrieb: Hallo,
setze background lieber auf none und die .quick_jump-Formatierung hinter dein .postmsg innerhalb der CSS-Datei. So sollte es funktionieren.
Leider hatte das keine Auswirkungen. Die Idee war aber gut. Smile
viele Grüße
Jockl
übersetzte und eigene Plugins
Zitieren
#5
Dann kopier mal das .quickjump und setz es nochmal als .postmsg .quick_jump { in die CSS Datei. Besser wärs dem Postparser beizubringen, externen Links direkt ne eigene Klasse zu verpassen, damit man die Elemente ohne solche Verrenkungen ansprechen kann... erfordert dann halt Codeänderungen.
Zitieren
#6
Leider klappt das mit ".postmsg .quick_jump" nicht. Dann werde ich wohl an Codeänderungen nicht vorbei kommen!?
Über CSS wäre es halt bei Updates einfacher, weil man dann nicht immer Dateien abgleichen muss. Wink

Nachtrag:

Habe jetzt folgende Änderung gemacht und das scheint auch zu funktionieren:

inc/class_parser.php
PHP-Code:
return "<blockquote><cite>{$span}".htmlspecialchars_uni($username).$lang->wrote{$linkback}</cite>{$message}</blockquote>\n"
geändert in
PHP-Code:
return "<blockquote><cite>{$span}".htmlspecialchars_uni($username).$lang->wrote  <a href=\"$url\"><img src=\"images/nav_pfeil.gif\" alt=\" =>\"/></a></cite>{$message}</blockquote>\n"

Danke Euch beiden! Smile
viele Grüße
Jockl
übersetzte und eigene Plugins
Zitieren


Möglicherweise verwandte Themen...
Thema Verfasser Antworten Ansichten Letzter Beitrag
  Background problem Styyy.Le 7 852 29.11.2010, 14:33
Letzter Beitrag: Styyy.Le
  kleines prob mit dem background Lucifer 2 605 09.10.2007, 14:21
Letzter Beitrag: Lucifer