Hallo, Gast! (Registrieren)

Letzte Ankündigung: MyBB 1.8.8 veröffentlicht (17.10.16)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
Login/Cookies ohne domain.tld funktioniert nicht
#1
Hallo,
ich möchte MyBB in einem Intranet verwenden. Der Server ist über "http://servername", dh. ohne .domain.tld erreichbar.
Bei der Installation wurde als cookiedomain ".servername" vorgeschlagen. Das funktioniert aber nicht, es werden dann keine Cookies gesetzt und es kann daher auch kein Login erfolgen.

Ich habe auch schon probiert "servername" - also ohne Punkt als cookiedomain einzustellen - funktioniert auch nicht. Wenn ich den Domainnamen inklusive domain.tld aufrufe, und die cookiedomain entsprechend einstelle, funktioniert es. Dies ist allerdings unerwünscht, da der servername sehr kurz ist, und domain.tld sehr lange.

Hat wer eine Idee woran das liegt oder was ich noch probieren könnte?

Danke!
Gomez
#2
http://stackoverflow.com/questions/10198...net-domain

lösung (scheinbar) ist den host entweder umzubenennen (z.B. mit einem intranetkuerzel a la servername.firmenname) oder einfach keine cookie domain zu spezifizieren
#3
Danke für die rasche Antwort! Ohne cookiedomain funktioniert es einwandfrei.
Danke auch für den Link mit der ausführlichen Erklärung!
Gomez


Möglicherweise verwandte Themen...
Thema Verfasser Antworten Ansichten Letzter Beitrag
  Mit Cookies klappt immer noch nicht. Alex0815 1 604 18.06.2010, 19:46
Letzter Beitrag: StefanT
  Top level domain login problem daniel133 11 1.423 15.02.2010, 19:16
Letzter Beitrag: querschlaeger
  Gehts auch ohne Cookies? chess 7 1.202 05.02.2009, 16:22
Letzter Beitrag: StefanT
  Externer Login und Cookies? Waluigi 25 3.470 04.02.2009, 17:06
Letzter Beitrag: StefanT