Hallo, Gast! (Registrieren)

Letzte Ankündigung: MyBB 1.8.8 veröffentlicht (17.10.16)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
Externer Login und Cookies?
#11
PHP-Code:
<?php
if($mybb->user['uid'])
{
echo 
"<table width='290' border='0' cellspacing='0' cellpadding='0'>
  <tr>
    <td width='290'>Willkommen zur&uuml;ck, "
.htmlspecialchars($mybb->user['username'])." </td>
  </tr>
  <tr>
    <td><a href='"
.$mybb->settings['bburl']."/member.php?action=logout&amp;logoutkey=".$mybb->user['logoutkey']."'>Ausloggen</a></td>
  </tr>
</table>"
;
}
else
{
echo 
"[...]";
}
?>

Gruß,
Michael
[Bild: banner.png]
Support erfolgt NUR im Forum!
Bitte gelöste Themen als "erledigt" markieren.
Beiträge mit mangelhafter Rechtschreibung/Grammatik werden kommentarlos gelöscht.
#12
Danke, aber was mich etwas irritiert:

Wenn ich mich einlogge, dann steht da die Weiterleitung und dann werde ich wieder zu meiner Page weitergeleitet, wo man sich eingeloggt hat.

Wie mache ich das gleiche mit dem Ausloggen?

Und noch etwas ist mir gerade aufgefallen.

Seit gerade kann ich mich im Forum nicht mehr ausloggen?! Hat aber warscheinlich nichts mit dem Script jetzt zu tun, oder?

MfG,
Waluigi
#13
(02.02.2009, 17:49)Waluigi schrieb: Seit gerade kann ich mich im Forum nicht mehr ausloggen?! Hat aber warscheinlich nichts mit dem Script jetzt zu tun, oder?

Sind Cookie-Domain oder Pfad korrekt?
Lösche einmal die Cache und Deine Cookies, logge Dich erneut ein, und versuch Dich auszuloggen.
Bitte die Suche u. die Doku nutzen.
______________________________

mfg Murphy
#14
Das mit den Cookies und Cache löschen hat geholfen, Danke.

Was ist denn, wenn dies eines meiner Forennutzer passiert oder warum ist mir dies passiert?

Oder kann es nur mir passieren?Blush

Aber die Frage ist ja noch offen, wie ich die Weiterleitung zu meiner Page wieder mache, nachdem ich mich ausgeloggt habe.

Wäre sehr nett =)

Edit:
Code:
<input type='hidden' name='url' value='../index.php' />

Hier muss ja eigentlich nur etwas umgeschrieben werden, oder? Ich weiß nur nicht wie.

MfG,
Waluigi
#15
Wenn die Cookie-Einstellungen geändert werden, betrifft das jeden.

Zur Weiterleitung: Öffne die Datei member.php und suche nach:
PHP-Code:
redirect("index.php"$lang->redirect_loggedout); 
Ersetze index.php durch die gewünschte URL.

Gruß,
Michael
[Bild: banner.png]
Support erfolgt NUR im Forum!
Bitte gelöste Themen als "erledigt" markieren.
Beiträge mit mangelhafter Rechtschreibung/Grammatik werden kommentarlos gelöscht.
#16
Vielen Dank Smile
#17
Hallo liebe myBB-Gemeide Smile
ich bin neu hier, wie man sicher sieht. Gestern habe ich mir die aktuellste Version runtergeladen, installiert. Läuft auch alles super soweit.
Nur dieses LogIn-problem betrifft auch mich Sad

Folgende Struktur ist gegeben:
- Eigener Linux-Server auf dem myBB installiert und auch fast perfekt läuft
- Domain registriert bei DomainFactory
- Domain wird umgeleitet auf die Server-IP mit dem entsprechenden Unterverzeichnis wo das Board liegt.

Nun stehe ich vor dem gleichen LogIn-Problem wie hier einige auch. Ich logge mich ein. LogIn wird auch mit "erfolgreich" bestätigt. Dann wird der letzte Aufenthaltsort angezeigt und ich bin nicht mehr eingeloggt. Dieses PingPong-Spiel kann ich beliebig fortsetzen. Egal ob ich über die IP die Seite im Browser aufrufe oder über die weitergeleitete Domain Angry

Wie kann ich da nun vorgehen?

Hier habe ich auch schon nachgelesen: https://www.mybb.de/doku/haeufig-gestell...elden.html
Bringt aber keine Lösung Sad
#18
Lösche mal die Cookies und den Cache im Browser und versuche es erneut. Wenn das nicht geht, poste bitte einen Link zu deinem Forum.

Gruß,
Michael
[Bild: banner.png]
Support erfolgt NUR im Forum!
Bitte gelöste Themen als "erledigt" markieren.
Beiträge mit mangelhafter Rechtschreibung/Grammatik werden kommentarlos gelöscht.
#19
Cache und Cockies habe ich schon mehrfach geleert Rolleyes
Die Adresse zum Board ist http://www.nettop-board.de/
(wird ein Bord zu Nettop- und Netbook-Geräten wie man erkennen kann *gg*)

Edit:
Ups. Ich glaube jetzt hab ich es völlig vergeigt Toungue Ich habe noch ein paar Einstellungen ausprobiert und etwas herumprobiert. Mit dem Ergebnis, dass ich im Adminpanel nichts mehr machen kann und bei jedem Mausklick rausfliege und beim LogIn-Sreen lande.... Sad
#20
Du benutzt deine Frame-Weiterleitung bei deiner Domain. Das macht Probleme mit den Cookies. Du musst ohne Frame arbeiten.
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.


Möglicherweise verwandte Themen...
Thema Verfasser Antworten Ansichten Letzter Beitrag
  Login/Cookies ohne domain.tld funktioniert nicht gomez 2 756 15.07.2009, 21:33
Letzter Beitrag: gomez
  Login Problem bei externer Seite Waluigi 10 2.174 08.02.2009, 15:00
Letzter Beitrag: Waluigi