Hallo, Gast! (Registrieren)

Letzte Ankündigung: MyBB 1.8.8 veröffentlicht (17.10.16)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
Fehler beim Hinzufügen des Attachments
#11
Hallo Michael,

Feststellung:
Die existierenden Verzeichnisse 200809 und 200810 haben den Besitzer xxxxxx (also nicht wwwrun).

Ich habe das Verzeichnis 20010 auf _200810 renamed und danach im Forum versucht ein Upload vorzunehmen. Ein Upload konnte problemlos vorgenommen werden und das Attachement konnte in den Beitrag eingefügt werden. Das komische daran ist das das neue automatisch erstellte Verzeichnis 200810 die rechte 755 hat (nicht 777) und den Besitzer wwwrun.

Wieso haben die alten Verzeichnisse nicht auch wwwrun als Besitzer ?
Wurden diese Verzeichnisse erstellt als ein nicht Forum-Admin das erste Upload des Monats 20009 vorgenommen hat und MyBB im Hintergrund ein anderer als Besitzer des Verzeichnisses hinzugefügt hat.

Die Masterfrage stellt sich jetzt wie im nächsten Monat (November) die Eigenschaften (Besitzer + rechte) des Verzeichnis 200811 aussehen wenn der erste upload von einem nicht Forum-Admin vorgenommen wird.
Wenn das Verzeichnis wiederum nicht wwwrun hat, genügen die rechte 755 nicht.

   

PS: Die php-Codeänderungen habe ich momentan nicht vorgenommen.

Salamander
#12
Der Webserver als Besitzer und die Rechte CHMOD 755 sind korrekt. Warum das bei den anderen Ordnern nicht so ist, wird dir nur dein Hoster beantworten können.

Gruß,
Michael
[Bild: banner.png]
Support erfolgt NUR im Forum!
Bitte gelöste Themen als "erledigt" markieren.
Beiträge mit mangelhafter Rechtschreibung/Grammatik werden kommentarlos gelöscht.
#13
Das selbe Problem ergibt sich bei mir auch (1.4.4).

Es wird ein entsprechendes Unterverzeichnis mit CHMOD 755 unter uploads/ erstellt. Der Besitzer des Verzeichnisses ist ebenfalls ein anderer wie bei uploads/.
Die Attachments werden jedoch nicht dort, sondern direkt unter uploads/ gespeichert. Fehlermeldung erscheint keine, die Attachments sind in den Beiträgen auch sichtbar. Die erstellten Unterordner sind leer!

Den o.a. Code von Michael habe ich ausprobiert. Es wird dann zwar ein Unterverzeichnis mit den entsprechenden Rechten erstellt, die Attachments werden aber weiterhin im Verzeichnis uploads/ gespeichert......


Noch eine andere Frage:
in der Version 1.2 waren die von MyBB vergebenen Attachmentnamen noch vergleichsweise "kurz". Nun kann man bei den 1.4er Attachmentnamen kaum noch das Ende des selben erkennen, so lang sind sie. Ist das richtig so? Macht bei Änderungen der Namen (in unserem Forum leider immer wieder notwendig) mal so richtig Spaß. Toungue
viele Grüße
Jockl
übersetzte und eigene Plugins
#14
Ja, die Dateinamen wurden wegen Problemen verlängert. Allerdings hat man damit doch nichts zu tun?
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
#15
Wenn der safe_mode in der PHP-Konfiguration aktiv ist, werden die Dateien nicht in Unterordner gelegt.

Gruß,
Michael
[Bild: banner.png]
Support erfolgt NUR im Forum!
Bitte gelöste Themen als "erledigt" markieren.
Beiträge mit mangelhafter Rechtschreibung/Grammatik werden kommentarlos gelöscht.
#16
(08.01.2009, 09:46)Dragon schrieb: Ja, die Dateinamen wurden wegen Problemen verlängert. Allerdings hat man damit doch nichts zu tun?
Es kommt nicht oft vor, aber wenn, dann zumeist gleich so richtig. Leider haben wir in unserem Forum immer wieder das Problem, dass User Ihre Fotos nicht korrekt hochladen. Ich bearbeite dann die Posts, ändere die Daten in der DB und "muss" dann die Filenamen auf dem Server entsprechend anpassen. Unter Umständen habe ich unter Linux aber den Dreh noch nicht raus, wie man so lange Dateinamen einfach umbenennen kann. Blush

(08.01.2009, 14:06)Michael schrieb: Wenn der safe_mode in der PHP-Konfiguration aktiv ist, werden die Dateien nicht in Unterordner gelegt.
Unter local value ist safe_mode On und unter master value auf Off. In der php.ini steht safe_mode auf Off !? Mir ist leider nicht ganz klar, was jetzt da herangezogen werden muss.
viele Grüße
Jockl
übersetzte und eigene Plugins
#17
(08.01.2009, 22:27)Jockl schrieb: Unter Umständen habe ich unter Linux aber den Dreh noch nicht raus, wie man so lange Dateinamen einfach umbenennen kann. Blush
Code:
mv altername.endung neuername.endung
Warum ist das Bearbeiten denn in der Datenbank nötig? Es ist nicht empfehlenswert, da das MyBB gewährleistet, dass die Dateinamen einzigartig sind.
(08.01.2009, 22:27)Jockl schrieb: Unter local value ist safe_mode On und unter master value auf Off. In der php.ini steht safe_mode auf Off !? Mir ist leider nicht ganz klar, was jetzt da herangezogen werden muss.
Der Wert unter Master Value ist der allgemeingültige aus der php.ini. Der unter Local Value ist der für den Account, unter dem das Forum läuft. Du kannst den Safe Mode bei dir im SysCP ausschalten (oder damit leben, dass alle Dateien in einem Ordner landen).

Gruß,
Michael
[Bild: banner.png]
Support erfolgt NUR im Forum!
Bitte gelöste Themen als "erledigt" markieren.
Beiträge mit mangelhafter Rechtschreibung/Grammatik werden kommentarlos gelöscht.
#18
Die Verwendung des move-Befehls kenne ich, aber wenn ich
Code:
mv post_XXX_1218490859f335kj34ma345q345.attachment post_YYY_1218490859f335kj34ma345q345.attachment
durchführen möchte, wird die Eingabe des neuen Dateinamens sehr mühsam. Wie gesagt, vermutlich gibt es da einen Trick, aber ich kenne ihn nicht. Blush

Michael schrieb:Warum ist das Bearbeiten denn in der Datenbank nötig? Es ist nicht empfehlenswert, da das MyBB gewährleistet, dass die Dateinamen einzigartig sind.
Ich ändere in der DB nicht den Namen an sich, sondern die Userzuordnung. Wenn ich für einen anderen User ein Bild hochlade, bzw. sein Bild korrigiere, ist es in meinem "Besitz". Der User soll dieses Bild aber in seinem eigenen Attachment-Manager vorfinden. Es reicht mir nicht, in der DB nur die uid zu ändern, da ich sonst die Bilder im upload-Verzeichnis nicht mehr dem Namen nach (post_XXX_...) den verschiedenen Usern zuordnen kann. Diese Zuordnung möchte ich ggf. für andere Anwendungen nutzen.

Michael schrieb:Du kannst den Safe Mode bei dir im SysCP ausschalten (oder damit leben, dass alle Dateien in einem Ordner landen).
Dann werde ich das mal probieren und sehen, was dann alles nicht mehr funktioniert. Wink
Ich hätte die Bilder ganz gern in separaten Ordern, weil es sonst das uploads-Verzeichnis noch mehr aufbläht (derzeit bereits ca. 11000 Attachments).
viele Grüße
Jockl
übersetzte und eigene Plugins
#19
Du kannst den Dateinamen bei der Eingabe einfach kopieren. Das ist je nach verwendetem Client unterschiedlich. In Putty zum Beispiel musst du den Namen mit der Maus markieren und dann ein Mal rechts klicken. Dadurch wird er nochmal da eingefügt, wo sich gerade der Cursor befindet.

Gruß,
Michael
[Bild: banner.png]
Support erfolgt NUR im Forum!
Bitte gelöste Themen als "erledigt" markieren.
Beiträge mit mangelhafter Rechtschreibung/Grammatik werden kommentarlos gelöscht.
#20
Lightbulb

Wo ist denn hier der Kniefall-Smilie? Na, dann geb ich halt ein Beer aus...

Dankeschön! Big Grin
viele Grüße
Jockl
übersetzte und eigene Plugins


Möglicherweise verwandte Themen...
Thema Verfasser Antworten Ansichten Letzter Beitrag
  Fehler beim Öffnen des Forums Naddel811 12 1.980 08.12.2008, 11:18
Letzter Beitrag: Naddel811