Hallo, Gast! (Registrieren)

Letzte Ankündigung: MyBB 1.8.8 veröffentlicht (17.10.16)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
Buttons in der Beitragsansicht
#1
Guten Morgen zusammen,

mir ist gerade aufgefallen, dass in der Beitragsansicht zwei Buttons anstatt durch die Button-Grafik durch Textlinks dargestellt werden.
Ich habe mal ein Bild mit angehängt, wo man das sehen kann.
Die Button-Grafiken sind auf dem Server, sowie auch in den jeweiligen Ordnern vorhanden.
Meine Frage wäre nun, in welchem Template finde ich das (showthread, postbit)?
Der Textlink muss ja auch irgendwo stehen und die Button-Grafiken (Pfad) müssen ja auch irgendwo verlinkt werden.
Irgendwas ist da durcheinander geraten...

Für Hilfe wäre ich dankbar.

Gruß, Horest

[Bild: http://horest.de/grafik.jpg]
Zitieren
#2
Es sich aber so aus, als würden die Bilder fehlen. (Mit MyBB 1.4 hat sich auch da was geändert.) Die Pfad ist in den postbit-Templates festgelegt.
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
Zitieren
#3
Hallo Dragon,

also, die Grafik-Dateien sind definitiv auf dem Server in den jeweiligen Ordnern.
In diesem Fall wären das pm_delete.gif und postbit_quote.gif

In dem Template postbit_quote steht folgender Code drinn:
PHP-Code:
<a href="newreply.php?tid={$tid}&amp;pid={$post['pid']}"><img src="{$theme['imglangdir']}/postbit_quote.gif" alt="{$lang->postbit_quote}title="{$lang->postbit_quote}/></a

und im Template postbit_delete_pm steht drin:
PHP-Code:
<a href="private.php?action=delete&amp;pmid={$id}&amp;my_post_key={$mybb->post_code}"><img src="{$theme['imglangdir']}/pm_delete.gif" alt="{$lang->delete}title="{$lang->delete_title}/></a

Im Template postbit steht zudem:
PHP-Code:
{$ignore_bit}
<
a name="pid{$post['pid']}id="pid{$post['pid']}"></a>
<
table border="0" cellspacing="{$theme['borderwidth']}cellpadding="{$theme['tablespace']}class="tborder" style="{$post_extra_style} {$post_visibility}id="post_{$post['pid']}">
<
tbody>
<
tr>
<
td class="tcat">
<
div class="float_left smalltext">
{
$post['postdate']}, {$post['posttime']} <span id="edited_by_{$post['pid']}">{$post['editedmsg']}</span>
</
div>
{
$post['posturl']}
</
td>
</
tr>
<
tr>
<
td class="trow1 {$unapproved_shade}">
<
table cellspacing="0" cellpadding="0" border="0" style="width: 100%;">
<
tr>
<
td class="post_avatar" width="1" style="{$post['avatar_padding']}">
{
$post['useravatar']}
</
td>
<
td class="post_author">
<
strong><span class="largetext">{$post['profilelink']}</span></strong> {$post['onlinestatus']}<br />
<
span class="smalltext">
{
$post['usertitle']}<br />
{
$post['userstars']}
<
br>                                
{
$post['groupimage']}
</
span>
</
td>
<
td class="smalltext post_author_info" width="165">
{
$post['user_details']}
</
td>
</
tr>
</
table>
</
td>
</
tr>
<
tr>
<
td class="trow2 post_content {$unapproved_shade}">
<
span class="smalltext"><strong>{$post['icon']}{$post['subject']} {$post['subject_extra']}</strong></span>
<
div class="post_body" id="pid_{$post['pid']}">
{
$post['message']}
</
div>
{
$post['attachments']}
{
$post['signature']}
<
div class="post_meta" id="post_meta_{$post['pid']}">
{
$post['iplogged']}
</
div>
</
td>
</
tr>
<
tr>
<
td class="trow1 post_buttons {$unapproved_shade}">
<
div class="author_buttons float_left">
{
$post['button_email']}{$post['button_pm']}{$post['button_www']}{$post['button_find']}
</
div>
<
div class="post_management_buttons float_right">{$post['button_edit']}{$post['button_quickdelete']}{$post['button_quote']}{$post['button_multiquote']}{$post['button_report']}{$post['button_warn']}{$post['button_reply_pm']}{$post['button_replyall_pm']}{$post['button_forward_pm']}{$post['button_delete_pm']}
</
div>
</
td>
</
tr>
</
tbody>
</
table

Ich hoffe, das ist jetzt nicht übertrieben mit dem ganzen Code.

Gruß, Horest
Ich habe den Fehler gefunden (hoffe ich).
Ich habe alle Button-Grafiken vom Server gelöscht und nochmals neu hochgeladen und jetzt funktioniert es.

Gruß, Horest
Zitieren
#4
(19.08.2008, 09:53)Horest schrieb: In diesem Fall wären das pm_delete.gif und postbit_quote.gif
Das stimmt nicht. Bei den Beiträgen wird postbit_delete.gif benutzt.
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
Zitieren


Möglicherweise verwandte Themen...
Thema Verfasser Antworten Ansichten Letzter Beitrag
  Beitragsansicht Anicane 9 1.392 05.09.2006, 20:43
Letzter Beitrag: Silaz
  Layout der Beitragsansicht Thomas 5 1.187 09.06.2006, 14:03
Letzter Beitrag: Michael