Hallo, Gast! (Registrieren)

Letzte Ankündigung: MyBB 1.8.8 veröffentlicht (17.10.16)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
Upgrade von 1.1.18 auf 1.4
#1
Grüss Euch!
(Forum sagt, Dein letzter Besch war im Dezember 2006 Big Grin)
Deshalb auch meine Frage: Weder hier noch im mybboard.net Forum finde ich jemanden, der von einem 1.0.18 Board upgradet.
Gibt es niemanden, der zu faul war, seine Skins anzupassen und deshalb bei der 1.0 geblieben ist, statt auf 1.2 upzugraden?

Na, egal, ich wollte nur fragen, wie das die Prozedur aussieht, Chris schreibt ja, dass man von >1.0RC2 upgraden kann. Ist das schon live getestet worden?

Keine Sorge, wenn hier keine Erfolgsmeldungen kommen, klone ich mein Live-Forum und probiers zuerst im Trockenen, möchte mit diesem Beitrag nur Zeit sparen!!

Ich hab schon ein Testforum laufen - auch mit deutscher Übersetzung, die übrigens wirklich sehr gut ist :ok: und freu mich schon auf den Echt-Betrieb Smile

mbG,
danke,
FraGe
#2
Hallo FraGezeichen,

wahrscheinlich wird es nicht viele Benutzer geben, welche von 1.0.x Upgraden.
Du wirst also nicht drumherum kommen ein Backup zu machen und es selbst zu testen. (Sonst könntest du hier vermutlich warten, bis du vor Ärger schwarz wirst)
Wenn etwas nicht klappen sollte kannst du dich gern hier an uns wenden.
Selbiges natürlich auch, auch wenn das Upgrade reibungslos verlief.

Mfg Garlant
Ich gebe keinen Support per Messenger oder PN!
#3
Danke fürs Feedback.
ALLE haben auf 1.2 updatet?
Sensationell. Ich war damals unter Zeitdruck, und kann mir seit einem Jahr die Semperei meiner User anhören, warum wir die uralt Version verwenden Big Grin

Na, jetzt, nach dem Urlaub wirds wohl Zeit fürs Update Smile

Ich werde vielleich einmal mit einem Backup probieren - eventuell heute Nacht?

Ich meld mich,
lg,
FraGe
*args*
Nix funzt.

Obwohl Chris schreibt:
Zitat:Upgrading from previous versions
You can update your copy of MyBB to 1.4 if you're running MyBB 1.0 RC2 or onwards (which you should already be).
gehts scheinbar nicht, zumindest bekomme ich allerlei Fehlermeldungen.

z.B.

Fatal error: [SQL] [1054] Unknown column 'loginattempts' in 'field list'
UPDATE forum_bckp_sessions SET `uid`='5', `loginattempts`='1' WHERE sid='0b0ec6c7fcb9da4a20fb70cba723e76b' in /var/www/web69/html/k4um/frmtst/BCKP/inc/db_mysql.php on line 544

loginattempts gibt es halt scheinbar im 1.1.18 noch nicht Sad
ich versuchs jetzt über ein 1.2 upgrade
Ich habe mich vertan!!
Ich hab kein 1.0.18 sondern ein 1.1.18, aber das habt ihr euch wohl schon gedacht Big Grin

Wenn ich jetzt auf 1.2.4 updaten will, dann tut er das zwar erfolgreich, ich kann mich aber nimmer einloggen *argh*
#4
(05.08.2008, 23:30)FraGezeichen schrieb: Wenn ich jetzt auf 1.2.4 updaten will, dann tut er das zwar erfolgreich, ich kann mich aber nimmer einloggen *argh*
Cookie-Einstellungen richtig gesetzt?

Gruß,
Michael
[Bild: banner.png]
Support erfolgt NUR im Forum!
Bitte gelöste Themen als "erledigt" markieren.
Beiträge mit mangelhafter Rechtschreibung/Grammatik werden kommentarlos gelöscht.
#5
Cookies gelöscht, das war mein kleinstes Problem Smile

Das 1.4er upgrade reagiert nicht besonders stabil, es verändern sich ständig die Fehlermeldungen.
(Bei jedem Refresh)

Ich bin jetzt soweit, dass ich das Upgrade starte, bis zur Eingabe des Adminaccounts komme,danach noch einmal "next" drücken darf, danach macht er scheinbar was an der Datenbank:

Zitat:Fatal error: [SQL] [1044] Access denied for user 'web69'@'localhost' to database 'Array'
[READ] Unable to select database in /var/www/web69/html/k4um/frmtst/BCKP/inc/db_mysql.php on line 544

Fatal error: [SQL] [1046] No database selected
SELECT title,cache FROM datacache in /var/www/web69/html/k4um/frmtst/BCKP/inc/db_mysql.php on line 544

..
..

..
ich gebs auf, da geht noch mehr schief, wenn ich einen Fehler beheb, dann kommt der Nächste:

Fatal error: Call to undefined function: rebuild_thread_counters() in /var/www/web69/html/k4um/frmtst/BCKP/install/resources/upgrade5.php on line 548

No database selected
kommt deswegen, weil das Upgrade Script die Config File am Server umschreibt und "Array" in das DAtenbank Feld schreibt. Das spinnt doch.


Also,im richtigen Moment ausgebessert, Cookies gelöscht, Datenbank angepasst:

(in der "_groupleaders" tabelle darf kein "canmanagemembers" vorkommen, allerdings braucht er ein "gcanmanagemembers" zum umbenennen, glaub ich, also benenn ich das vorher um - ist schneller als Fehlersuchen Big Grin - zweitens: "_searchlog" darf nicht existieren, ich denke, das sind zwei Bugs des Upgrade-Scripts, werde ich an Chris melden, hmm?)


Aber vorher geh ich schlafen!!



...viel später!!

aso, ich kann das Skript anpassen *tüftel*


Gefundene Fehler:
Suche im upgrade5.php nach "groupleaders DROP gcanmanagemembers" ändere es zu "groupleaders DROP canmanagemembers" dann haut einmal das hin.

*aaaargh*

suche "$db->drop_table("searhlog");" -> ändere zu "$db->drop_table("searchlog");"

aber für das Problem mit meiner DB find ich keine Lösung, da passt alles ...
Hab das jetzt geworkarounded Wink

Wo ich mit meinen bescheidenen mysql&php Kenntnissen wirklic nimmer weiterkomm, ist der Fehler mit den thread counters:

Code:
rebuild_thread_counters($thread['tid']);

            if($thread['firstpost'] == 0)

            {

                update_first_post($thread['tid']);

            }

er beschwert sich eigentlich, dass die Funktion ned existiert - kann man ihm ned übel nehmen, tut sie ja auch ned, oder?

Code:
Call to undefined function: rebuild_thread_counters()

Findest Du da was sinnvolles drüber heraus?

Würde mich freuen, ich geh jetzt wirklich heia Smile

lg,
FraGe

Ps: wenn ich den Converter zu laufen bringe, melde ich mich natürlich auch, ich schick das Ganze Ding dann an das mybb-Team.

Obwohls wohl ausser mir niemand braucht, sonst hätt sich schon wer beschwert.
#6
Ok, vergesst den ganzen Kack von letzter Nacht, da war ich wohl schon übermüdet.
Habe alles nocheinmal im englischn Forum durchgekaut:
http://community.mybboard.net/thread-35048.html


Jetzt habe ich erfolgreich
- von 1.1.8 - das ist die wirkliche Version Wink
- auf 1.2.6 - das ist die letzte, für die der Konverter funktioniert
- auf 1.2.14 - weil der 1.4er auch nicht für 1.2.6 funktioniert und dann auf
- 1.4

Alles was ich bis jetzt gesehen habe, wurde konvertiert, meines erachtens nach passt alles.
Trotzdem hoffe ich auf eine Lösung direkt von 1.1.8 auf 1.4

Das würde dann schneller gehen,mit meinen über 100.000 Beiträgen Smile
#7
Das Upgrade-Skript unterstützt doch MyBB 1.1.x. Warum machst du Umwege?
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
#8
*hust* ich hab wohl wirklich zu lange geschrieben - oder Du liest ungern Big Grin
Schau einmal das Thema an!
Da hab ich meine Leidensgeschichte dokumentiert, drei Beiträge über diesem.

Wenns funktioieren würde, wäre dieses Thema absolet, oder?
#9
Ich hatte es überflogen. Was ist denn dein aktuelles Problem?
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
#10
Nachdem ich drei Typos selbst gefixt habe?

"Call to undefined function: rebuild_thread_counters()"
das ist eine Funktion, die in 1.2.6 das letzte Mal korrekt auftaucht (als "update_thread_count")
in der upgrade5.php ist sie einfach nicht implementiert - lese ich mit meinen beschränkten Kenntnissen aus dieser Datei.

Deshalb KANN ein Upgrade nicht funktionieren.