Hallo, Gast! (Registrieren)

Letzte Ankündigung: MyBB 1.8.8 veröffentlicht (17.10.16)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
Fehler bei Upgrade 1.2.11 -> 1.4
#1
Hallo,

wollte eben auf die 1.4 upgraden und beim Datenbankupdate erhielt ich dann die Fehlermeldung dass die Column "isdefault" in der mybb_settings Tabelle unbekannt ist.

Hab mir die Tabelle angesehen da gibt es auch kein Feld namens "isdefault".

Beim Upgrade hatte ich korrekt von Version 1.2.11 ausgewählt.

Kam dieses Feld vielleicht erst in einer Späteren version hinzu und beim upgrade stimmt da was nicht ganz? Oder ging schon bei einem früheren Upgrade etwas schief und ich sollte das Feld eigentlich haben?
Was kann ich tun? Bringt es etwas zuerst zu versuchen ein update auf 1.2.14 zu machen?
Oder kann man das Feld von hand zuvor einfügen und alles mit 0 bzw 1 füllen?

Hab nun erstmal wieder das Backup von meiner alten Version eingespielt...


Danke
#2
Hallo,

habe einen sehr ähnlichen Fehler beim Upgraden von 1.2.10 auf 1.4.

Code:
Fatal error: [SQL] [1054] Unknown column 'isdefault' in 'where clause'
SELECT name,sid FROM mybb_settings WHERE isdefault='1' OR isdefault='yes' in /mounted-storage/home74a/sub004/sc42106-KMLT/xxxxxxx.com/forum/inc/db_mysql.php on line 544

Steh etwas auf dem Schlauch ... jemand eine Idee?

Danke im Voraus!

Gruß
CP
#3
Auf welcher Seite kommt der Fehler?
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
#4
(04.08.2008, 13:38)Dragon schrieb: Auf welcher Seite kommt der Fehler?

Also bei mir direkt nach Auswählen der Version, von der aus ich auf 1.4 upgraden will. Ich klicke auf weiter, dann kommt "Performing necessary upgrade queries.. Click next to continue with the upgrade process. "

Wenn ich dann auf "Weiter" klicke, kommt sofort die Fehlermeldung.
#5
Führt bitte mal den folgenden Query in der Datenbank aus und startet dann das Upgrade von vorne:
Code:
ALTER TABLE mybb_settings ADD isdefault char(3) NOT NULL default '';

Gruß,
Michael
[Bild: banner.png]
Support erfolgt NUR im Forum!
Bitte gelöste Themen als "erledigt" markieren.
Beiträge mit mangelhafter Rechtschreibung/Grammatik werden kommentarlos gelöscht.
#6
Ja das ist genau mein Fehler, danke für den Screenshot Smile

Ok dann werd ich das als nächstes testen, komm nur im moment nicht dazu. Melde mich sobald ich mehr weiß...
#7
Danke Michael, das hat schon mal geholfen. Ein bisschen weiter bin ich in der Installationsroutine.

Jetzt stockt er hier mit folgender Fehlermeldung:

Code:
Erstellung der Caches

Fatal error: [SQL] [1146] Table 'trampss_dfsb4.mybb_stats' doesn't exist
REPLACE INTO mybb_stats SET `dateline`='1217808000',`numusers`='1332',`numthreads`='12630',`numposts`='80547' in /mounted-storage/home74a/sub004/sc42106-KMLT/xxxxxx.com/xxxx/inc/db_mysql.php on line 544

Kann damit leider überhaupt nix anfangen .. jemand von euch?
#8
Siehe: https://www.mybb.de/forum/thread-10142.html
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
#9
Zitat:(...) und wähle als Ausgangsversion MyBB 1.2.14.

Wenn ich das probiere, kommt folgende Warnung:

Zitat:Warning:

There are still 5 plugin(s) active. Active plugins can sometimes cause problems during an upgrade procedure or may break your forum afterward. It is strongly reccommended that you deactivate your plugins before continuing.

Ich gestehe, dass ich möglicherweise vergessen habe, ein Plugin zu deaktivieren vor dem Upgrade .. aber 5?? Bin jetzt natürlich bisserl verunsichert bei dem Text... weitermachen?
Also ich komme schon wesentlich weiter mit der 1.2.14 Methode, aber jetzt stockt er hier *verzweifel*

Zitat:Post IP Conversion

Converting ip 25000 to 30000 (60716 Total)

Fatal error: [SQL] [1226] User 'trampss_dfsb4' has exceeded the 'max_questions' resource (current value: 100000)
UPDATE mybb_posts SET `longipaddress`='0' WHERE pid = '29374' in /mounted-storage/home74a/sub004/sc42106-KMLT/xxxxx.com/xxxx/inc/db_mysql.php on line 544
#10
max_questions gehört zur MySQL-Konfiguration und bestimmt wie viele Abfragen pro Stunde ausgeführt werden dürfen. Das Upgrade führt sehr viele Abfragen aus und das Limit wurde erreicht. Bitte wende dich an deinen Hoster und bitte ihn, das Limit zumindest kurzzeitig hochzusetzen. Alternativ kannst du versuchen das Upgrade unter einer lokalen Installation (z.B. unter XAMPP) durchzuführen und anschließend die Datenbank auf den Webspace zu übernehmen.

Gruß,
Michael
[Bild: banner.png]
Support erfolgt NUR im Forum!
Bitte gelöste Themen als "erledigt" markieren.
Beiträge mit mangelhafter Rechtschreibung/Grammatik werden kommentarlos gelöscht.