Hallo, Gast! (Registrieren)

Letzte Ankündigung: MyBB 1.8.8 veröffentlicht (17.10.16)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
bb-code leiste
#1
Hallo Leute,
ich habe ein kleines Problem.
jeder von euch kennt bestimmt diese bb-code leiste über dem text eingabefeld.
Dort kann man Schrift, Schriftgröße, Schriftarbe, Fett, kursiv, unterstrichen, links, mittig, rechts, blocksatz ... auswählen.
Ich habe nun ein kleines Problem. Diese Leiste ist bei mir im Forum einfach weg
Es fehlt die gesamte tabelle um meine Textarea.
Habe ich das vll. versehentlich irgendwo dekativiert?
Wie bekomme ich das ganze wieder rein?
#2
Benutzer-CP -> Optionen -> Zeige die MyBBCode-Formatierungsoptionen bei der Beitragserstellung an.
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
#3
es tut mir leid, dass es nicht sooo leicht ist ^^. Der hacken ist da, aber das ganze wird immer noch nicht angezeigt.
#4
Tritt das Problem nur bei dir auf oder bei allen Benutzern deines Forums? Funktioniert es hier im Forum? Hast du etwas geändert?

Gruß,
Michael
[Bild: banner.png]
Support erfolgt NUR im Forum!
Bitte gelöste Themen als "erledigt" markieren.
Beiträge mit mangelhafter Rechtschreibung/Grammatik werden kommentarlos gelöscht.
#5
Tritt das Problem nur bei dir auf oder bei allen Benutzern deines Forums?
Das Problem tritt bei allen auf.
Mir scheint es, dass im Forum was falsch läuft ^^

Funktioniert es hier im Forum?
Hier im Forum ist das ganze Sichtbar. Es ist nur in meinem Forum nicht da.

Hast du etwas geändert?
ja, aber es ist zu viel um es aufzulisten Toungue, daher hier in kürze:
1. eigene BB-Codes gebastelt. dabe habe ich nur in der class_parser.php gearbeitet. Daher fällt das auch für mich als möglichkeit raus. Außerdem hat es danach noch funktioniert.
2. im Header habe ich eine weitere JS-Datei inkludiert für die bb-codes und ein div hinzugefügt.
3. Ich habe im "postbit" template einer Tabelle die bereits existiert mit class="post_url" versehen. Es beist sich mit keiner weiteren CSS-Klasse und sorgt für einen anderes Aussehen der URL
4. Ich habe den Style (farben) geändert
Sonst habe ich nichts geändert.

Sicher ist dass 1. und 4. nicht auslöser sind. 2. erscheint mir sehr Unwahrscheinlich.
4. erscheint mir zwar ebenfalls unwahrscheinlich, doch durch zurücksetzen des templates konnte ich auch keine Änderung erreichen. Die "bb-code-bar" bleibt verschwunden.


[EDIT] mir fällt gerade auf, dass, wenn ich auf bearbeiten klicke mir auch nicht angeboten wird, im Inlinemodus zu arbeiten
[EDIT2] Firebug meldet mir immer 2 JS fehler in meinem forum, die aber aus skripten von mybb stammen. ist es möglich das es damit zusammenhängt?
[EDIT3] Ich habe alle JS-Scripts des Forums ersetzt und meine geprüft. Die JS-Fehler bleiben vorhanden.
Code:
Event.observe is not a function  in general.js (line 477)
[Break on this error] Event.observe(expander, "click", thi...pandCollapse.bindAsEventListener(this));

clickableEditor.bindSmilieInserter is not a function  in newthread.php?fid=3 (line 200)
[Break on this error] clickableEditor.bindSmilieInserter("clickable_smilies");
letzters sorgt wohl dafür, dass ich meine Smilies nicht mehr anklicken kann, wie ich gerade festellen muss. Aber das alles erklärt nicht, wo die leiste hin ist. Es muss doch hmtl-code geben von der leiste, der auf jedenfall (egal ob js funkz oder nicht) angezeigt wird.
#6
hast du irgendwo javascript integriert? Sowas wie ne Toplist oder Hotlist oder ähnliches? Wenn ja, sofort mal raushauen.
#7
Nimm die von dir im Header eingebundenen JS-Dateien wieder raus und probiere es dann nochmal.
#8
Bingo daran lags. Ich habs gefunden.
Nur jetzt stellt sich mir die Frage, wie ich das ganze lösen kann, denn ohne das Javascript ist das Forum wertlos!!
Es handelt sich um Mootools.
Weiss einer genaueres, was sich da "beist"?
Wie kann ich das beheben?

Bisher habe ich herausgefunden, dass Mybb ein prototype und moo.fx nutzt.
allerdings heißt es, dass moo.fx (jetziges mootools) nicht mehr verwendet wird.
kann ich ein paar fehler beheben, wenn ich die mootools lib nutze und dafür die mybb moo.fx version rausnehme?
Antwort: nein

Folgender Ansatzt hat sich bei mir bisher rauskristalisiert:
Die Event Klasse von Mootools ist sowohl im mybb als auch in meiner mootools version enthalten, jedoch in unterschiedlichen Fassungen. So ist die neuere Version ohne die besagte "Event.observe" Funktion. Die mybb-version wird wahrscheinlich beim laden "überschrieben" und damit geht die benötigte Event.observe" funktion verloren.
Jetzt muss man das nur noch vermeiden ^^

Ich habe gerade einfach mal die Reihenfolge getauscht, doch das bringt auch nichts. jetzt meckert die aktuell mootools version über fehlende Funktionen ...
Dafür viel mir gerade ein, dass ich ja meine Mootools version nur beim anzeigen von posts benötige, sonst nicht. Wäre es nicht möglich, dass ganze so zu regeln, dass meine mootools version nur eingebunden wird, wenn posts angezeigt werden?
#9
Beide Scripts so nebeneinander zu benutzen, geht leider nicht.
In der englischen Community hat mal jemand versucht, beide nebeneinander lauffähig zu machen und hat es auch irgendwie geschafft. Leider finde ich den Beitrag nicht mehr, vielleicht hast du mehr Glück.
1.4 wird kein Mootools mehr verwenden, deswegen sollten die Schwierigkeiten damit aufgehoben sein. Brauchs du das Script denn wirklich im Forum oder nur auf irgendwelchen anderen Seiten? Wozu genau benutzt du es?
Vantage-Forum: http://vantage-forum.de/
#10
Ja, ich benötige das Script wirklich im Forum Big Grin
Aber im Grunde benötige ich nicht den vollständigen Funktionsumfang von mootools.
Ich benötige Ajaxrequests und den FX-Kram zum ein und ausblenden von requests.
In welchem Englischen Forum hast du das denn gefunden?
und könntest du vll. noch etwas mehr sagen (wer z.B. oder so), damit die suche etwas leichter wird?
ich brauche den kram wirklich dringend!!