Hallo, Gast! (Registrieren)

Letzte Ankündigung: MyBB 1.8.8 veröffentlicht (17.10.16)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
[G] No-Cache-Einstellung ohne Wirkung?
#1
Hallo Leute,

Ich habe das Problem, dass Seiten immer aus dem Browser-Cache geladen werden, obwohl ich die "no-cache"-Header-Option aktiviert habe.
Nach einer Überprüfung, habe ich auch festgestellt, dass dieser Header nicht gesendet wird.

Beim phpBB bewirken diese Header-Zeilen das Abschalten des Caches:
Code:
Cache-Control: private, pre-check=0, post-check=0, max-age=0
Expires: 0
Pragma: no-cache
Sowas oder etwas ähnliches gibt es beim MyBB scheinbar nicht !?

Ist das nun ein Bug oder mache ich noch etwas falsch?
Dieser Satz ist falsch!
#2
Diese Option gibt es leider nicht. Versuche es mal, indem du folgenden Code ins Template "headerinclude" einfügst:
Code:
<META HTTP-EQUIV="CACHE-CONTROL" CONTENT="PRIVATE">
<META HTTP-EQUIV="EXPIRES" CONTENT="0">
<META HTTP-EQUIV="PRAGMA" CONTENT="NO-CACHE">

Gruß,
Michael
[Bild: banner.png]
Support erfolgt NUR im Forum!
Bitte gelöste Themen als "erledigt" markieren.
Beiträge mit mangelhafter Rechtschreibung/Grammatik werden kommentarlos gelöscht.
#3
Ich habe den Quelltext nochmal unter die Lupe genommen und wohl einen kleinen Bug gefunden.

Datei: inc/functions.php:
PHP-Code:
function pageheaders() {
    global 
$settings;
    if(
$mybb->settings['nocacheheaders'] == "yes" && $mybb->settings['standardheaders'] != "yes")
    {
        
header("Expires: Sat, 1 Jan 2000 01:00:00 GMT");
        
header("Last-Modified: " gmdate("D, d M Y H:i:s") . "GMT");
        
header("Cache-Control: no-cache, must-revalidate");
        
header("Pragma: no-cache");
    }

$settings wird geholt aber $mybb genutzt... das funktioniert natürlich nicht.
Es muss also "global $mybb;" heißen, dann funktioniert es auch mit dem Cache Smile
Dieser Satz ist falsch!
#4
Das kommt davon wenn man schneller schreibt als denkt. Big Grin

Gruß,
Michael
[Bild: banner.png]
Support erfolgt NUR im Forum!
Bitte gelöste Themen als "erledigt" markieren.
Beiträge mit mangelhafter Rechtschreibung/Grammatik werden kommentarlos gelöscht.
#5
Huch, schon verschoben und im offiziellen Bugtracker gepostet. Du bist ja ein ganz schneller Big Grin
Dieser Satz ist falsch!


Möglicherweise verwandte Themen...
Thema Verfasser Antworten Ansichten Letzter Beitrag
  [G] "Ohne Cache-Header" auch im ACP poncho 0 918 20.07.2006, 15:20
Letzter Beitrag: poncho