Hallo, Gast! (Registrieren)

Letzte Ankündigung: MyBB 1.8.8 veröffentlicht (17.10.16)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
[Gelöst] Umbruch der Buttons im IE7
#1
Hi alle zusammen,

nachdem ich mein Forum heute erfolgreich meinen Vorstellungen angepasst habe, meldete sich ein User, das die Buttons unterhalb des Quick Reply nicht reinpassen würden, weil einer davon unterhalb der für sie vorgesehenen Leisten sei.

Ich machte mich gleich daran, das Problem zu reproduzieren, und habe es geschafft:
Sobald man den IE auf eine Größe von etwa 1024 Breite verkleinert, springt der rechte Button unter den linken, obwohl für beide eigentlich weit mehr als genug Platz sein müsste.

Zur Verdeutlichung ein Screenshot:
   
Ist dieses Problem bereits bekannt oder hat jemand einen Vorschlag zur Lösung?


MfG Zwoetzen
Was ist der Unterschied zwischen der Politik und der Informatik?
In der Informatik ignoriert man führende Nullen...
#2
Hm ich kann das Problem weder hier im Forum noch in meinem Testboard nach vollziehen?
Hast du mal einen Link zu deinem Board.
MyBBoard.de jetzt auf YouTube!
Fehlender Plan wird durch Wahnsinn ersetzt!!Toungue
Gruß Krafdi www.krafdi.de
#3
Der Link zum Board it in meinem Profil der WWW-Link Wink
http://funtrackers.bplaced.net/

Falls gewünscht, kann ich dir die Daten von einem Testaccount per PN schicken Wink (Weil man das Quickreply ja nur als User sieht)

EDIT: Oh, die Seite im Profil war gar nicht mehr aktuell, musst ich gleich mal aktualisieren. ^^
Was ist der Unterschied zwischen der Politik und der Informatik?
In der Informatik ignoriert man führende Nullen...
#4
Hehe, da hätte ich mal schauen sollenWink
Jap kannst du mal schicken.
MyBBoard.de jetzt auf YouTube!
Fehlender Plan wird durch Wahnsinn ersetzt!!Toungue
Gruß Krafdi www.krafdi.de
#5
Hm dein Template quickreply unterscheidet sich vom Orginal.
Orginal
Code:
</td>
</tr>

<tr>
<td colspan="2" align="center" class="tfoot"><input type="submit" class="button" value="Antwort schreiben" tabindex="2" accesskey="s" /> <input type="submit" class="button" name="previewpost" value="Beitragsvorschau" tabindex="3" /></td>
</tr>
</tbody>
</table>
</form>
Deins:
Code:
</tr>

</table>
</div>
<div class="tfoot_l"></div><div class="tfoot_r"></div>
<div class="tfoot" align="center"><input type="submit" class="button" value="Post Reply" tabindex="2" accesskey="s" /> <input type="submit" class="button" name="previewpost" value="Preview Post" tabindex="3" /></div>
</div>

</form>
Ich denke das wird der Grund sein.
MyBBoard.de jetzt auf YouTube!
Fehlender Plan wird durch Wahnsinn ersetzt!!Toungue
Gruß Krafdi www.krafdi.de
#6
Ja das ist, weil ich die Buttons in der grünen Leiste haben will.
Aber eigentlich müssten sie trotzdem genug Platz haben. Denn die beiden anderen Divs vorher nehmen jeweils nur 100px links und rechts ein, das Div tfoot nimmt dann den rest der zu verfügung stehenden Breite ein.

Das einzige, was ich bei tfoot an CSS noch angegeben habe (Neben farben und Hintergrund) ist
Code:
height: 24px;
margin: 0 100px 0 100px;
padding: 2px 4px;

Margin, um die beiden Endstücke nicht zu überdecken, und padding um ein wenig Rand zu lassen. Aber selbst bei einer 1024er Auflösung sollte dann noch mind. 500px Platz sein (200px für links das Menü, 200px für die Endstücke, und etwas freiraum natürlich) und die Buttons sind ja zusammen keine 500px breit

Außenrum ist dann noch ein Div ohne weitere Angaben, das geht um die Grüneleiste und um die darüberliegende Tabelle, um es quasi zu einer Box zusammenzufassen.
Was ist der Unterschied zwischen der Politik und der Informatik?
In der Informatik ignoriert man führende Nullen...
#7
Ich habe das Problem nun (durch Zufall) lösen können:

Ich hatte Testweise ein Wort direkt vor die Buttons geschrieben, und schon wurden die Buttons zentriert ausgerichtet. Also habe ich einfach nen Leerzeichen (& npsb; ) davor hingesetzt um das Anzeige-Problem zu lösen Smile

Trotzdem vielen Dank krafdi, dass du dir das Problem angeschaut hast Wink
Was ist der Unterschied zwischen der Politik und der Informatik?
In der Informatik ignoriert man führende Nullen...
#8
Zwoetzen schrieb:Ich habe das Problem nun (durch Zufall) lösen können:

Ich hatte Testweise ein Wort direkt vor die Buttons geschrieben, und schon wurden die Buttons zentriert ausgerichtet. Also habe ich einfach nen Leerzeichen (& npsb; ) davor hingesetzt um das Anzeige-Problem zu lösen Smile

Trotzdem vielen Dank krafdi, dass du dir das Problem angeschaut hast Wink

Jetzt wo das gelöst ist, kann ich ja eine Lösung vorschlagen. Toungue

Spaß bei Seite. Ich hab das Thema einfach zu spät angesehen...
Per
Code:
style="float:left;display:inline;"
wären die Buttons auch nebeneinander geblieben. Das
Code:
display:inline;
ist für den IE(6?), den dieser hat so seine Probleme mit Floats.

Mfg Garlant
Ich gebe keinen Support per Messenger oder PN!
#9
Auch danke an deinen Lösungsvorschlag ^^ (Find ich aber mein Leerzeichen etwas kürzer Wink)

Und auf eine Kompatibilität zum IE6 (und niedriger) brauch ich nicht achten: Da ich mehrere Transparente PNGs im Design eingebaut habe, und bis IE6 keine Transparenz unterstützt wurde, ist die Seite dadurch schon genug zerstört, da kommts auf die Buttons nicht mehr an Toungue (Wobei ich nicht weiß, wie sie wirklich im IE6 aussieht, aber dass die Hälfte grau ist kann ich mir schon denken ^^)
Was ist der Unterschied zwischen der Politik und der Informatik?
In der Informatik ignoriert man führende Nullen...


Möglicherweise verwandte Themen...
Thema Verfasser Antworten Ansichten Letzter Beitrag
  Anmeldung IE7 und URL-Weiterleitungen Heiliger Franziskus 3 645 12.09.2007, 12:45
Letzter Beitrag: StefanT
  Codebuttons und IE7 ElkeK. 9 1.247 21.02.2007, 14:16
Letzter Beitrag: Susanne