Hallo, Gast! (Registrieren)

Letzte Ankündigung: MyBB 1.8.8 veröffentlicht (17.10.16)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
1.2.6 Auf 1.2.12 Update
#1
Hi
Ich habe 1.2.6 mybb laufen möchte auf 1.2.12 Updaten, Leider bekomme ich fehler meldung beim Updaten.

MySQL error: 1045
Access denied for user 'mybb_forum'@'localhost' (using password: YES)
Query:

ich habe beiden datein config.php und setting.php gesichert und wieder hochgeladen.leider bekomme ich keine verbindung zum Update.

Muss man da noch was beachten?

Bin zimlich neu bei mybb,Könnte mir Bitte jemand helfen was ich machen muss.

MFG
#2
Hallo Crazy,

bitte editiere die config.php um sicher zu gehen, dass das Passwort korrekt ist.
Laut Fehlermeldung könnte das Passwort nicht übereinstimmen.

Mfg Garlant
Ich gebe keinen Support per Messenger oder PN!
#3
Ok das habe ich erledigt, Nun habe ich eine andere Problem.
ich habe von eine andere mybb folgende tabellen ersetzt.
mybb_templategroups
mybb_templates
mybb_templatesets
mybb_themes

Danach habe ich dieser Fehler bekommen.

Parse error: syntax error, unexpected '-', expecting '}' in /home/web1/public_html/forum/global.php(252) : eval()'d code on line 1

Parse error: syntax error, unexpected '-', expecting '}' in /home/web1/public_html/forum/global.php(259) : eval()'d code on line 1

Parse error: syntax error, unexpected '-', expecting '}' in /home/web1/public_html/forum/global.php(341) : eval()'d code on line 1

Parse error: syntax error, unexpected '-', expecting '}' in /home/web1/public_html/forum/index.php(31) : eval()'d code on line 1


Wie kann ich das wieder beheben?

MFG
#4
In den dort aufgerufenen Templates sind Fehler drin. Da kommt scheinbar anstatt der schließenden Klammer ein Minus-Zeichen. Da es bei mehreren Templates falsch ist, kommt mir das komisch vor.
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
#5
Ja das ist komisch,Ich habe zwei Board laufen wen ich irgent wo eine Fehler sehe dan nehme ich von erzatz Board und Funktioniert wieder.
#6
Hier die Fehler Seite

Code:
<html>
<head>
<title>{$lang->viewing_pm} {$pm['subject']}</title>
{$headerinclude}
</head>
<body>
{$header}
<table width="100%" border="0" align="center">
<tr>
{$usercpnav}
<td valign="top">
<table border="0" cellspacing="{$theme['borderwidth']}" cellpadding="{$theme['tablespace']}" class="tborder">
<tr>
<td class="thead" colspan="3"><table width="100%" cellspacing="0" cellpadding="0" border="0"><tr><td class="thead"><strong>{$pm['subject']}</strong></td><td class="thead" align="right"><a href="private.php?action=send&amp;pmid={$pm['pmid']}&amp;do=reply&phpMyAdmin=MrYMpgvbcW1b0yenmoXBi1nDt14">{$lang->reply}</a> | <a href="private.php?action=send&amp;pmid={$pm['pmid']}&amp;do=forward&phpMyAdmin=MrYMpgvbcW1b0yenmoXBi1nDt14">{$lang->forward}</a> | <a href="private.php?action=delete&amp;pmid={$pm['pmid']}&amp;my_post_key={$mybb->post_code}&amp;my_post_key={$mybb->post_code}&amp;my_post_key={$mybb->post_code}&amp;my_post_key={$mybb->post_code}&amp;my_post_key={$mybb-&phpMyAdmin=MrYMpgvbcW1b0yenmoXBi1nDt14>post_code}">{$lang->delete_pm}</a></td></table></td>
</tr>
{$message}
<tr>
<td class="tfoot" colspan="3"><table width="100%" cellspacing="0" cellpadding="0" border="0"><tr><td class="tfoot"><strong>{$pm['subject']}</strong></td><td class="tfoot" align="right"><a href="private.php?action=send&amp;pmid={$pm['pmid']}&amp;do=reply&phpMyAdmin=MrYMpgvbcW1b0yenmoXBi1nDt14">{$lang->reply}</a> | <a href="private.php?action=send&amp;pmid={$pm['pmid']}&amp;do=forward&phpMyAdmin=MrYMpgvbcW1b0yenmoXBi1nDt14">{$lang->forward}</a> | <a href="private.php?action=delete&amp;pmid={$pm['pmid']}&amp;my_post_key={$mybb->post_code}&amp;my_post_key={$mybb->post_code}&amp;my_post_key={$mybb->post_code}&amp;my_post_key={$mybb->post_code}&amp;my_post_key={$mybb-&phpMyAdmin=MrYMpgvbcW1b0yenmoXBi1nDt14>post_code}">{$lang->delete_pm}</a></td></table></td>
</tr>
</table>
</td>
</tr>
</table>
{$footer}
</body>
</html>


Und Hier die ersatz von meine andere Board.Und hir mit gibts keine fehler.

Code:
<html>
<head>
<title>{$lang->viewing_pm} {$pm['subject']}</title>
{$headerinclude}
</head>
<body>
{$header}
<table width="100%" border="0" align="center">
<tr>
{$usercpnav}
<td valign="top">
<table border="0" cellspacing="{$theme['borderwidth']}" cellpadding="{$theme['tablespace']}" class="tborder">
<tr>
<td class="thead" colspan="3"><table width="100%" cellspacing="0" cellpadding="0" border="0"><tr><td class="thead"><strong>{$pm['subject']}</strong></td><td class="thead" align="right"><a href="private.php?action=send&amp;pmid={$pm['pmid']}&amp;do=reply">{$lang->reply}</a> | <a href="private.php?action=send&amp;pmid={$pm['pmid']}&amp;do=forward">{$lang->forward}</a> | <a href="private.php?action=delete&amp;pmid={$pm['pmid']}&amp;my_post_key={$mybb->post_code}">{$lang->delete_pm}</a></td></table></td>
</tr>
{$message}
<tr>
<td class="tfoot" colspan="3"><table width="100%" cellspacing="0" cellpadding="0" border="0"><tr><td class="tfoot"><strong>{$pm['subject']}</strong></td><td class="tfoot" align="right"><a href="private.php?action=send&amp;pmid={$pm['pmid']}&amp;do=reply">{$lang->reply}</a> | <a href="private.php?action=send&amp;pmid={$pm['pmid']}&amp;do=forward">{$lang->forward}</a> | <a href="private.php?action=delete&amp;pmid={$pm['pmid']}&amp;my_post_key={$mybb->post_code}">{$lang->delete_pm}</a></td></table></td>
</tr>
</table>
</td>
</tr>
</table>
{$footer}
</body>
</html>
#7
Was mir auffällt: In dem Problemtemplate wird überall eine Angabe zu phpMyAdmin an die Links angehängt. Wo kommt die her?

Gruß,
Michael
[Bild: banner.png]
Support erfolgt NUR im Forum!
Bitte gelöste Themen als "erledigt" markieren.
Beiträge mit mangelhafter Rechtschreibung/Grammatik werden kommentarlos gelöscht.
#8
Keine ahnung.wo die herkommt, jetz habe ich noch eine Fehler und weis nicht wie ich sie beseitigen soll.
wen ich beiträge lösche bekomme dieser Fehler.

MySQL error: 1146
Table forum_1.mybb_reportedposts' doesn't exist
Query: UPDATE mybb_reportedposts SET reportstatus='1' WHERE tid='4721' AND reportstatus='0'

Irgent wie gibts dieser mybb_reportedposts' tabelle nicht wie ich das vwerstehe
#9
Richtig, die Tabelle existiert laut Fehlermeldung nicht. Du kannst diese über folgenden Query erzeugen:
Code:
CREATE TABLE mybb_reportedposts (
  rid int unsigned NOT NULL auto_increment,
  pid int unsigned NOT NULL default '0',
  tid int unsigned NOT NULL default '0',
  fid int unsigned NOT NULL default '0',
  uid int unsigned NOT NULL default '0',
  reportstatus int(1) NOT NULL default '0',
  reason varchar(250) NOT NULL default '',
  dateline bigint(30) NOT NULL default '0',
  KEY fid (fid),
  KEY dateline (dateline),
  PRIMARY KEY  (rid)
) TYPE=MyISAM;

Gruß,
Michael
[Bild: banner.png]
Support erfolgt NUR im Forum!
Bitte gelöste Themen als "erledigt" markieren.
Beiträge mit mangelhafter Rechtschreibung/Grammatik werden kommentarlos gelöscht.